gnu: Add rust-proc-macro-hack-impl-0.4.
[jackhill/guix/guix.git] / gnu / packages / gnome-xyz.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
3 ;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
4 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages gnome-xyz)
22 #:use-module (guix build-system trivial)
23 #:use-module (guix build-system gnu)
24 #:use-module (guix git-download)
25 #:use-module (guix packages)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (gnu packages base)
28 #:use-module (gnu packages bash)
29 #:use-module (gnu packages glib)
30 #:use-module (gnu packages gnome)
31 #:use-module (gnu packages gtk)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (gnu packages ruby)
34 #:use-module (gnu packages xml))
35
36 (define-public matcha-theme
37 (package
38 (name "matcha-theme")
39 (version "2019-11-02")
40 (source
41 (origin
42 (method git-fetch)
43 (uri
44 (git-reference
45 (url "https://github.com/vinceliuice/matcha")
46 (commit version)))
47 (file-name (git-file-name name version))
48 (sha256
49 (base32
50 "0wci9ahap8kynq8cbyxr7aba9ndb1d4kiq42xvzr34vw1rhcahrr"))))
51 (build-system trivial-build-system)
52 (arguments
53 '(#:modules ((guix build utils))
54 #:builder
55 (begin
56 (use-modules (guix build utils))
57 (let* ((out (assoc-ref %outputs "out"))
58 (source (assoc-ref %build-inputs "source"))
59 (bash (assoc-ref %build-inputs "bash"))
60 (coreutils (assoc-ref %build-inputs "coreutils"))
61 (themesdir (string-append out "/share/themes")))
62 (setenv "PATH"
63 (string-append coreutils "/bin:"
64 (string-append bash "/bin:")))
65 (copy-recursively source (getcwd))
66 (patch-shebang "Install")
67 (mkdir-p themesdir)
68 (invoke "./Install" "-d" themesdir)
69 #t))))
70 (inputs
71 `(("gtk-engines" ,gtk-engines)))
72 (native-inputs
73 `(("bash" ,bash)
74 ("coreutils" ,coreutils)))
75 (synopsis "Flat design theme for GTK 3, GTK 2 and GNOME-Shell")
76 (description "Matcha is a flat Design theme for GTK 3, GTK 2 and
77 Gnome-Shell which supports GTK 3 and GTK 2 based desktop environments
78 like Gnome, Unity, Budgie, Pantheon, XFCE, Mate and others.")
79 (home-page "https://github.com/vinceliuice/matcha")
80 (license license:gpl3+)))
81
82 (define-public delft-icon-theme
83 (package
84 (name "delft-icon-theme")
85 (version "1.10")
86 (source
87 (origin
88 (method git-fetch)
89 (uri (git-reference
90 (url "https://github.com/madmaxms/iconpack-delft.git")
91 (commit (string-append "v" version))))
92 (sha256
93 (base32
94 "0vw3yw9f9ygzfd2k3zrfih3r0vkzlhk1bmsk8sapvk7np24i1z9s"))
95 (file-name (git-file-name name version))))
96 (build-system trivial-build-system)
97 (arguments
98 `(#:modules ((guix build utils))
99 #:builder
100 (begin
101 (use-modules (guix build utils))
102 (copy-recursively (assoc-ref %build-inputs "source") "icons")
103 (substitute* "icons/Delft/index.theme"
104 (("gnome") "Adwaita"))
105 (delete-file "icons/README.md")
106 (delete-file "icons/LICENSE")
107 (delete-file "icons/logo.jpg")
108 (copy-recursively "icons" (string-append %output "/share/icons")))))
109 (home-page "https://www.gnome-look.org/p/1199881/")
110 (synopsis "Continuation of Faenza icon theme with up to date app icons")
111 (description "Delft is a fork of the popular icon theme Faenza with up to
112 date app icons. It will stay optically close to the original Faenza icons,
113 which haven't been updated for some years. The new app icons are ported from
114 the Obsidian icon theme.")
115 (license license:gpl3)))
116
117 (define-public gnome-shell-extension-appindicator
118 (package
119 (name "gnome-shell-extension-appindicator")
120 (version "30")
121 (source (origin
122 (method git-fetch)
123 (uri (git-reference
124 (url
125 "https://github.com/ubuntu/gnome-shell-extension-appindicator.git")
126 (commit (string-append "v" version))))
127 (sha256
128 (base32
129 "1fjhx23jqwv3d0smwhnjvc35gqhwk9p5f96ic22pfax653cn5vh8"))
130 (file-name (git-file-name name version))))
131 (build-system trivial-build-system)
132 (arguments
133 '(#:modules ((guix build utils))
134 #:builder
135 (begin
136 (use-modules (guix build utils))
137 (let* ((source (assoc-ref %build-inputs "source"))
138 (install-dir (string-append (assoc-ref %outputs "out")
139 "/share/gnome-shell/extensions"
140 "/appindicatorsupport@rgcjonas.gmail.com")))
141 (mkdir-p install-dir)
142 (copy-recursively source install-dir)
143 #t))))
144 (synopsis "Adds KStatusNotifierItem support to GNOME Shell")
145 (description "This extension integrates Ubuntu AppIndicators
146 and KStatusNotifierItems (KDE's successor of the systray) into
147 GNOME Shell.")
148 (home-page "https://github.com/ubuntu/gnome-shell-extension-appindicator/")
149 (license license:gpl2+)))
150
151 (define-public gnome-shell-extension-dash-to-dock
152 (package
153 (name "gnome-shell-extension-dash-to-dock")
154 (version "66")
155 (source (origin
156 (method git-fetch)
157 (uri (git-reference
158 (url "https://github.com/micheleg/dash-to-dock.git")
159 (commit (string-append "extensions.gnome.org-v"
160 version))))
161 (sha256
162 (base32
163 "04krl6rxlp1qc97psraf2kwin7h0mx4c7pnfpi7vhplmvasrwkfh"))
164 (file-name (git-file-name name version))))
165 (build-system gnu-build-system)
166 (arguments
167 '(#:tests? #f
168 #:make-flags (list (string-append "INSTALLBASE="
169 (assoc-ref %outputs "out")
170 "/share/gnome-shell/extensions"))
171 #:phases
172 (modify-phases %standard-phases
173 (delete 'bootstrap)
174 (delete 'configure))))
175 (native-inputs
176 `(("glib:bin" ,glib "bin")
177 ("intltool" ,intltool)
178 ("pkg-config" ,pkg-config)))
179 (propagated-inputs
180 `(("glib" ,glib)))
181 (synopsis "Transforms GNOME's dash into a dock")
182 (description "This extension moves the dash out of the
183 overview, transforming it into a dock for easier application launching and
184 faster window switching.")
185 (home-page "https://micheleg.github.io/dash-to-dock/")
186 (license license:gpl2+)))
187
188 (define-public gnome-shell-extension-hide-app-icon
189 (let ((commit "4188aa5f4ba24901a053a0c3eb0d83baa8625eab")
190 (revision "0"))
191 (package
192 (name "gnome-shell-extension-hide-app-icon")
193 (version (git-version "2.7" revision commit))
194 (source
195 (origin
196 (method git-fetch)
197 (uri (git-reference
198 (url (string-append "https://github.com/michael-rapp"
199 "/gnome-shell-extension-hide-app-icon.git"))
200 (commit commit)))
201 (sha256
202 (base32
203 "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
204 (file-name (git-file-name name version))))
205 (build-system gnu-build-system)
206 (arguments
207 '(#:tests? #f ; no test target
208 #:make-flags (list (string-append "EXTENSIONS_DIR="
209 (assoc-ref %outputs "out")
210 "/share/gnome-shell/extensions"))
211 #:phases
212 (modify-phases %standard-phases
213 (delete 'configure) ; no configure script
214 (replace 'install
215 (lambda* (#:key outputs #:allow-other-keys)
216 (let ((out (assoc-ref outputs "out"))
217 (pre "/share/gnome-shell/extensions/")
218 (dir "hide-app-icon@mrapp.sourceforge.com"))
219 (copy-recursively dir (string-append out pre dir))
220 #t))))))
221 (native-inputs
222 `(("glib" ,glib "bin")
223 ("intltool" ,intltool)))
224 (propagated-inputs
225 `(("glib" ,glib)))
226 (synopsis "Hide app icon from GNOME's panel")
227 (description "This extension allows to hide the icon and/or title of the
228 currently focused application in the top panel of the GNOME shell.")
229 (home-page
230 "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
231 (license
232 ;; README.md and LICENSE.txt disagree -- the former claims v3, the
233 ;; latter v2. No mention of "or later" in either place or in the code.
234 (list license:gpl2
235 license:gpl3)))))
236
237 (define-public gnome-shell-extension-dash-to-panel
238 (package
239 (name "gnome-shell-extension-dash-to-panel")
240 (version "26")
241 (source (origin
242 (method git-fetch)
243 (uri (git-reference
244 (url "https://github.com/home-sweet-gnome/dash-to-panel.git")
245 (commit (string-append "v" version))))
246 (sha256
247 (base32
248 "1phfx2pblygpcvsppsqqqflm7qnz46mqkw29hj0nv2dn69hf4xbc"))
249 (file-name (git-file-name name version))))
250 (build-system gnu-build-system)
251 (arguments
252 `(#:tests? #f
253 #:make-flags (list (string-append "INSTALLBASE="
254 (assoc-ref %outputs "out")
255 "/share/gnome-shell/extensions")
256 (string-append "VERSION="
257 ,(package-version
258 gnome-shell-extension-dash-to-panel)))
259 #:phases
260 (modify-phases %standard-phases
261 (delete 'bootstrap)
262 (delete 'configure))))
263 (native-inputs
264 `(("intltool" ,intltool)
265 ("pkg-config" ,pkg-config)))
266 (propagated-inputs
267 `(("glib" ,glib)
268 ("glib" ,glib "bin")))
269 (synopsis "Icon taskbar for GNOME Shell")
270 (description "This extension moves the dash into the gnome main
271 panel so that the application launchers and system tray are combined
272 into a single panel, similar to that found in KDE Plasma and Windows 7+.")
273 (home-page "https://github.com/home-sweet-gnome/dash-to-panel/")
274 (license license:gpl2+)))
275
276 (define-public gnome-shell-extension-noannoyance
277 (package
278 (name "gnome-shell-extension-noannoyance")
279 (version "5")
280 (source (origin
281 (method git-fetch)
282 (uri (git-reference
283 (url "https://github.com/BjoernDaase/noannoyance.git")
284 (commit "e37b5b3c31f577b4698bc6659bc9fec5ea9ac5d4")))
285 (sha256
286 (base32
287 "0fa8l3xlh8kbq07y4385wpb908zm6x53z81q16xlmin97dln32hh"))
288 (file-name (git-file-name name version))))
289 (build-system trivial-build-system)
290 (arguments
291 '(#:modules ((guix build utils))
292 #:builder
293 (begin
294 (use-modules (guix build utils))
295 (let ((dst (string-append
296 (assoc-ref %outputs "out")
297 "/share/gnome-shell/extensions/"
298 "noannoyance@daase.net")))
299 (mkdir-p dst)
300 (copy-recursively (assoc-ref %build-inputs "source") dst)))))
301 (synopsis "Removes 'Window is ready' annotation")
302 (description "One of the many extensions, that remove this message.
303 It uses ES6 syntax and claims to be more actively maintained than others.")
304 (home-page "https://extensions.gnome.org/extension/2182/noannoyance/")
305 (license license:gpl2)))
306
307 (define-public numix-theme
308 (package
309 (name "numix-theme")
310 (version "2.6.7")
311 (source (origin
312 (method git-fetch)
313 (uri (git-reference
314 (url "https://github.com/numixproject/numix-gtk-theme.git")
315 (commit version)))
316 (file-name (git-file-name name version))
317 (sha256
318 (base32
319 "12mw0kr0kkvg395qlbsvkvaqccr90cmxw5rrsl236zh43kj8grb7"))))
320 (build-system gnu-build-system)
321 (arguments
322 '(#:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
323 #:phases
324 (modify-phases %standard-phases
325 (delete 'configure)
326 (delete 'check))))
327 (native-inputs
328 `(("glib:bin" ,glib "bin") ; for glib-compile-schemas
329 ("gnome-shell" ,gnome-shell)
330 ("gtk+" ,gtk+)
331 ("xmllint" ,libxml2)
332 ("ruby-sass" ,ruby-sass)))
333 (synopsis "Flat theme with light and dark elements")
334 (description "Numix is a modern flat theme with a combination of light and
335 dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
336 (home-page "https://numixproject.github.io")
337 (license license:gpl3+)))
338
339 (define-public papirus-icon-theme
340 (let ((version "0.0.0") ;; The package does not use semver
341 (revision "0")
342 (tag "20191201"))
343 (package
344 (name "papirus-icon-theme")
345 (version (git-version version revision tag))
346 (source
347 (origin
348 (method git-fetch)
349 (uri (git-reference
350 (url "https://github.com/PapirusDevelopmentTeam/papirus-icon-theme.git")
351 (commit tag)))
352 (sha256
353 (base32
354 "0lnz1kmz28xh1f4slbsx7ycji5hgszyiyprbf5w5fbjhvi5gzw1h"))
355 (file-name (git-file-name name version))))
356 (build-system gnu-build-system)
357 (arguments
358 '(#:tests? #f
359 #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
360 #:phases
361 (modify-phases %standard-phases
362 (delete 'bootstrap)
363 (delete 'configure)
364 (delete 'build))))
365 (native-inputs
366 `(("gtk+:bin" ,gtk+ "bin")))
367 (home-page "https://git.io/papirus-icon-theme")
368 (synopsis "Fork of Paper icon theme with a lot of new icons and a few extras")
369 (description "Papirus is a fork of the icon theme Paper with a lot of new icons
370 and a few extra features.")
371 (license license:gpl3))))