Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / tv.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016, 2017, 2018 Alex Kost <alezost@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages tv)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages compression)
26 #:use-module (gnu packages fontutils)
27 #:use-module (gnu packages image)
28 #:use-module (gnu packages linux)
29 #:use-module (gnu packages pkg-config)
30 #:use-module (gnu packages xml)
31 #:use-module (gnu packages xorg))
32
33 (define-public tvtime
34 (package
35 (name "tvtime")
36 (version "1.0.11")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append
40 "https://linuxtv.org/downloads/tvtime/tvtime-"
41 version ".tar.gz"))
42 (sha256
43 (base32
44 "1367rl3n6qxwf30lqyz234zpb43s9xjhig3hrvbg7cbqcl8g4fs0"))))
45 (build-system gnu-build-system)
46 (inputs
47 `(("alsa-lib" ,alsa-lib)
48 ("libx11" ,libx11)
49 ("libxext" ,libxext)
50 ("libxt" ,libxt)
51 ("libxtst" ,libxtst)
52 ("libxinerama" ,libxinerama)
53 ("libxv" ,libxv)
54 ("libxxf86vm" ,libxxf86vm)
55 ("libpng" ,libpng)
56 ("libxml2" ,libxml2)
57 ("freetype" ,freetype)
58 ("zlib" ,zlib)))
59 (native-inputs
60 `(("pkg-config" ,pkg-config)))
61 (home-page "http://tvtime.sourceforge.net")
62 (synopsis "Television viewer")
63 (description
64 "Tvtime processes the input from your video capture card and
65 displays it on a monitor. It focuses on a high visual quality.")
66 (license license:gpl2+)))