gnu: Add lci.
[jackhill/guix/guix.git] / gnu / packages / patches / python-disable-ssl-test.patch
1 Disable a test that fails with openssl-1.0.2b.
2
3 --- Lib/test/test_ssl.py.orig 2015-02-25 06:27:45.000000000 -0500
4 +++ Lib/test/test_ssl.py 2015-06-12 03:14:09.395212502 -0400
5 @@ -2718,6 +2718,7 @@
6 chatty=True, connectionchatty=True)
7 self.assertIs(stats['compression'], None)
8
9 + @unittest.skipIf(True, "openssl 1.0.2b complains: dh key too small")
10 def test_dh_params(self):
11 # Check we can get a connection with ephemeral Diffie-Hellman
12 context = ssl.SSLContext(ssl.PROTOCOL_TLSv1)