gnu: Add lci.
[jackhill/guix/guix.git] / gnu / packages / libidn.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages libidn)
21 #:use-module (gnu packages)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27 (define-public libidn
28 (package
29 (name "libidn")
30 (replacement libidn-1.33)
31 (version "1.32")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/libidn/libidn-" version
35 ".tar.gz"))
36 (sha256 (base32
37 "1xf4hphhahcjm2xwx147lfpsavjwv9l4c2gf6hx71zxywbz5lpds"))))
38 (build-system gnu-build-system)
39 ;; FIXME: No Java and C# libraries are currently built.
40 (synopsis "Internationalized string processing library")
41 (description
42 "libidn is a library implementing of the Stringprep, Punycode and IDNA
43 specifications. These are used to encode and decode internationalized domain
44 names. It includes native C, C# and Java libraries.")
45 ;; The C code is dual-licensed gpl2+ lgpl3+, the manual is fdl1.3+,
46 ;; the command line tool is gpl3+.
47 (license (list gpl2+ gpl3+ lgpl3+ fdl1.3+))
48 (home-page "http://www.gnu.org/software/libidn/")))
49
50 (define libidn-1.33
51 (package
52 (inherit libidn)
53 (source
54 (let ((version "1.33"))
55 (origin
56 (method url-fetch)
57 (uri (string-append "mirror://gnu/libidn/libidn-" version
58 ".tar.gz"))
59 (sha256
60 (base32
61 "068fjg2arlppjqqpzd714n1lf6gxkpac9v5yyvp1qwmv6nvam9s4")))))))