gnu: Move test packages from perl to perl-check.
[jackhill/guix/guix.git] / gnu / packages / language.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages language)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages perl)
22 #:use-module (gnu packages perl-check)
23 #:use-module (gnu packages web)
24 #:use-module (guix packages)
25 #:use-module (guix build-system perl)
26 #:use-module ((guix licenses) #:select (gpl2 gpl3 perl-license))
27 #:use-module (guix download))
28
29 (define-public perl-lingua-en-findnumber
30 (package
31 (name "perl-lingua-en-findnumber")
32 (version "1.32")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "mirror://cpan/authors/id/N/NE/NEILB/"
37 "Lingua-EN-FindNumber-" version ".tar.gz"))
38 (sha256
39 (base32
40 "015ximzdp42v824llwlg2pd77vd0d172lb4xs55q9f9zhqf6s5qx"))))
41 (build-system perl-build-system)
42 (propagated-inputs
43 `(("perl-lingua-en-words2nums" ,perl-lingua-en-words2nums)))
44 (home-page "http://search.cpan.org/dist/Lingua-EN-FindNumber")
45 (synopsis "Locate (written) numbers in English text ")
46 (description "This module provides a regular expression for finding
47 numbers in English text. It also provides functions for extracting and
48 manipulating such numbers.")
49 (license perl-license)))
50
51 (define-public perl-lingua-en-inflect
52 (package
53 (name "perl-lingua-en-inflect")
54 (version "1.901")
55 (source
56 (origin
57 (method url-fetch)
58 (uri (string-append "mirror://cpan/authors/id/D/DC/DCONWAY/"
59 "Lingua-EN-Inflect-" version ".tar.gz"))
60 (sha256
61 (base32
62 "0mcwlgf6hkh4zm3s1x899f25xj4hyzrc2vssiwfxysqja36yf5ys"))))
63 (build-system perl-build-system)
64 (native-inputs `(("perl-module-build" ,perl-module-build)))
65 (home-page "http://search.cpan.org/dist/Lingua-EN-Inflect")
66 (synopsis "Convert singular to plural")
67 (description "Lingua::EN::Inflect provides plural inflections,
68 \"a\"/\"an\" selection for English words, and manipulation of numbers as
69 words. Plural forms of all nouns, most verbs, and some adjectives are
70 provided. Where appropriate, \"classical\" variants (for example: \"brother\"
71 -> \"brethren\", \"dogma\" -> \"dogmata\", etc.) are also provided.")
72 (license perl-license)))
73
74 (define-public perl-lingua-en-inflect-number
75 (package
76 (name "perl-lingua-en-inflect-number")
77 (version "1.12")
78 (source
79 (origin
80 (method url-fetch)
81 (uri (string-append "mirror://cpan/authors/id/N/NE/NEILB/"
82 "Lingua-EN-Inflect-Number-" version ".tar.gz"))
83 (sha256
84 (base32
85 "1gxccynkaqav43ww43jp4rzkyr36x97jd03yb5f6yx0jhn1k7yv6"))))
86 (build-system perl-build-system)
87 (propagated-inputs
88 `(("perl-lingua-en-inflect" ,perl-lingua-en-inflect)))
89 (home-page "http://search.cpan.org/dist/Lingua-EN-Inflect-Number")
90 (synopsis "Force number of words to singular or plural")
91 (description "This module extends the functionality of Lingua::EN::Inflect
92 with three new functions for determining plurality of a word and forcefully
93 converting a word to singular or plural.")
94 (license perl-license)))
95
96 (define-public perl-lingua-en-inflect-phrase
97 (package
98 (name "perl-lingua-en-inflect-phrase")
99 (version "0.18")
100 (source
101 (origin
102 (method url-fetch)
103 (uri (string-append "mirror://cpan/authors/id/R/RK/RKITOVER/"
104 "Lingua-EN-Inflect-Phrase-" version ".tar.gz"))
105 (sha256
106 (base32
107 "19prg6pkgnznrc82ymdkdi3l9schg815axjig7adca5yqa7mn2i9"))))
108 (build-system perl-build-system)
109 (native-inputs
110 `(("perl-test-nowarnings" ,perl-test-nowarnings)))
111 (propagated-inputs
112 `(("perl-lingua-en-findnumber" ,perl-lingua-en-findnumber)
113 ("perl-lingua-en-inflect" ,perl-lingua-en-inflect)
114 ("perl-lingua-en-inflect-number" ,perl-lingua-en-inflect-number)
115 ("perl-lingua-en-number-isordinal" ,perl-lingua-en-number-isordinal)
116 ("perl-lingua-en-tagger" ,perl-lingua-en-tagger)))
117 (home-page "http://search.cpan.org/dist/Lingua-EN-Inflect-Phrase")
118 (synopsis "Inflect short English phrases")
119 (description "This module attempts to pluralize or singularize short
120 English phrases.")
121 (license perl-license)))
122
123 (define-public perl-lingua-en-number-isordinal
124 (package
125 (name "perl-lingua-en-number-isordinal")
126 (version "0.05")
127 (source
128 (origin
129 (method url-fetch)
130 (uri (string-append "mirror://cpan/authors/id/R/RK/RKITOVER/"
131 "Lingua-EN-Number-IsOrdinal-" version ".tar.gz"))
132 (sha256
133 (base32
134 "1mhqjvh2ad30gjab5b3a6mbr4aysyrscp4wp42yy5x6001a6km98"))))
135 (build-system perl-build-system)
136 (native-inputs
137 `(("perl-try-tiny" ,perl-try-tiny)
138 ("perl-test-fatal" ,perl-test-fatal)))
139 (propagated-inputs
140 `(("perl-lingua-en-findnumber" ,perl-lingua-en-findnumber)))
141 (home-page "http://search.cpan.org/dist/Lingua-EN-Number-IsOrdinal")
142 (synopsis "Detect if English number is ordinal or cardinal")
143 (description "This module will tell you if a number, either in words or as
144 digits, is a cardinal or ordinal number.")
145 (license perl-license)))
146
147 (define-public perl-lingua-en-tagger
148 (package
149 (name "perl-lingua-en-tagger")
150 (version "0.28")
151 (source
152 (origin
153 (method url-fetch)
154 (uri (string-append "mirror://cpan/authors/id/A/AC/ACOBURN/"
155 "Lingua-EN-Tagger-" version ".tar.gz"))
156 (sha256
157 (base32
158 "1rm223d871s150dgnhbar71w56bim950cp45f0904w6px5fifcqa"))))
159 (build-system perl-build-system)
160 (propagated-inputs
161 `(("perl-memoize-expirelru" ,perl-memoize-expirelru)
162 ("perl-lingua-stem" ,perl-lingua-stem)
163 ("perl-html-parser" ,perl-html-parser)
164 ("perl-html-tagset" ,perl-html-tagset)))
165 (home-page "http://search.cpan.org/dist/Lingua-EN-Tagger")
166 (synopsis "Part-of-speech tagger for English natural language processing")
167 (description "This module is a probability based, corpus-trained tagger
168 that assigns part-of-speech tags to English text based on a lookup dictionary
169 and a set of probability values. The tagger assigns appropriate tags based on
170 conditional probabilities - it examines the preceding tag to determine the
171 appropriate tag for the current word. Unknown words are classified according
172 to word morphology or can be set to be treated as nouns or other parts of
173 speech. The tagger also extracts as many nouns and noun phrases as it can,
174 using a set of regular expressions.")
175 (license gpl3)))
176
177 (define-public perl-lingua-en-words2nums
178 (package
179 (name "perl-lingua-en-words2nums")
180 (version "0.18")
181 (source
182 (origin
183 (method url-fetch)
184 (uri (string-append "mirror://cpan/authors/id/J/JO/JOEY/"
185 "Lingua-EN-Words2Nums-" version ".tar.gz"))
186 (sha256
187 (base32
188 "118xx8qr1zbx30psv7ic55w65h15mc1vz6zicshfm96jgiwmcrb8"))))
189 (build-system perl-build-system)
190 (home-page "http://search.cpan.org/dist/Lingua-EN-Words2Nums")
191 (synopsis "Convert English text to numbers")
192 (description "This module converts English text into numbers. It supports
193 both ordinal and cardinal numbers, negative numbers, and very large numbers.")
194 (license perl-license)))
195
196 (define-public perl-lingua-pt-stemmer
197 (package
198 (name "perl-lingua-pt-stemmer")
199 (version "0.01")
200 (source
201 (origin
202 (method url-fetch)
203 (uri (string-append "mirror://cpan/authors/id/X/XE/XERN/"
204 "Lingua-PT-Stemmer-" version ".tar.gz"))
205 (sha256
206 (base32
207 "11rqc5pqnkl9c13vy7sihiyas14ci0pj3k6chrgrgjv5sjv2m4a5"))))
208 (build-system perl-build-system)
209 (home-page "http://search.cpan.org/dist/Lingua-PT-Stemmer")
210 (synopsis "Portuguese language stemming")
211 (description "This module implements a Portuguese stemming algorithm
212 proposed in the paper A Stemming Algorithm for the Portuguese Language by
213 Moreira, V. and Huyck, C.")
214 (license perl-license)))
215
216 (define-public perl-lingua-stem
217 (package
218 (name "perl-lingua-stem")
219 (version "0.84")
220 (source
221 (origin
222 (method url-fetch)
223 (uri (string-append "mirror://cpan/authors/id/S/SN/SNOWHARE/"
224 "Lingua-Stem-" version ".tar.gz"))
225 (sha256
226 (base32
227 "12avh2mnnc7llmmshrr5bgb473fvydxnlqrqbl2815mf2dp4pxcg"))))
228 (build-system perl-build-system)
229 (native-inputs
230 `(("perl-module-build" ,perl-module-build)))
231 (propagated-inputs
232 `(("perl-lingua-pt-stemmer" ,perl-lingua-pt-stemmer)
233 ("perl-lingua-stem-fr" ,perl-lingua-stem-fr)
234 ("perl-lingua-stem-it" ,perl-lingua-stem-it)
235 ("perl-lingua-stem-ru" ,perl-lingua-stem-ru)
236 ("perl-lingua-stem-snowball-da" ,perl-lingua-stem-snowball-da)
237 ("perl-snowball-norwegian" ,perl-snowball-norwegian)
238 ("perl-snowball-swedish" ,perl-snowball-swedish)
239 ("perl-text-german" ,perl-text-german)))
240 (home-page "http://search.cpan.org/dist/Lingua-Stem")
241 (synopsis "Stemming of words in various languages")
242 (description "This routine applies stemming algorithms to its parameters,
243 returning the stemmed words as appropriate to the selected locale.")
244 (license perl-license)))
245
246 (define-public perl-lingua-stem-fr
247 (package
248 (name "perl-lingua-stem-fr")
249 (version "0.02")
250 (source
251 (origin
252 (method url-fetch)
253 (uri (string-append "mirror://cpan/authors/id/S/SD/SDP/"
254 "Lingua-Stem-Fr-" version ".tar.gz"))
255 (sha256
256 (base32
257 "0vyrspwzaqjxm5mqshf4wvwa3938mkajd1918d9ii2l9m2rn8kwx"))))
258 (build-system perl-build-system)
259 (home-page "http://search.cpan.org/dist/Lingua-Stem-Fr")
260 (synopsis "Porter's stemming algorithm for French")
261 (description "This module uses a modified version of the Porter Stemming
262 Algorithm to return a stemmed French word.")
263 (license perl-license)))
264
265 (define-public perl-lingua-stem-it
266 (package
267 (name "perl-lingua-stem-it")
268 (version "0.02")
269 (source
270 (origin
271 (method url-fetch)
272 (uri (string-append "mirror://cpan/authors/id/A/AC/ACALPINI/"
273 "Lingua-Stem-It-" version ".tar.gz"))
274 (sha256
275 (base32
276 "1207r183s5hlh4mfwa6p46vzm0dhvrs2dnss5s41a0gyfkxp7riq"))))
277 (build-system perl-build-system)
278 (home-page "http://search.cpan.org/dist/Lingua-Stem-It")
279 (synopsis "Porter's stemming algorithm for Italian")
280 (description "This module applies the Porter Stemming Algorithm to its
281 parameters, returning the stemmed Italian word.")
282 (license perl-license)))
283
284 (define-public perl-lingua-stem-ru
285 (package
286 (name "perl-lingua-stem-ru")
287 (version "0.01")
288 (source
289 (origin
290 (method url-fetch)
291 (uri (string-append "mirror://cpan/authors/id/A/AL/ALGDR/"
292 "Lingua-Stem-Ru-" version ".tar.gz"))
293 (sha256
294 (base32
295 "0pqgg442fkf12ayh9fgmpa8q9x0iqx6s96181r52yn7s7pcs61h6"))))
296 (build-system perl-build-system)
297 (home-page "http://search.cpan.org/dist/Lingua-Stem-Ru")
298 (synopsis "Porter's stemming algorithm for Russian")
299 (description "This module applies the Porter Stemming Algorithm to its
300 parameters, returning the stemmed Russian (KOI8-R only) word.")
301 (license perl-license)))
302
303 (define-public perl-lingua-stem-snowball-da
304 (package
305 (name "perl-lingua-stem-snowball-da")
306 (version "1.01")
307 (source
308 (origin
309 (method url-fetch)
310 (uri (string-append "mirror://cpan/authors/id/C/CI/CINE/"
311 "Lingua-Stem-Snowball-Da-" version ".tar.gz"))
312 (sha256
313 (base32
314 "0mm0m7glm1s6i9f6a78jslw6wh573208arxhq93yriqmw17bwf9f"))))
315 (build-system perl-build-system)
316 (home-page "http://search.cpan.org/dist/Lingua-Stem-Snowball-Da")
317 (synopsis "Porters stemming algorithm for Danish")
318 (description "Lingua::Stem::Snowball::Da is a perl port of the danish
319 stemmer at http://snowball.sourceforge.net, it was originally altered from the
320 Lingua::Stem::Snowball::Se.")
321 (license gpl2)))
322
323 (define-public perl-snowball-norwegian
324 (package
325 (name "perl-snowball-norwegian")
326 (version "1.2")
327 (source
328 (origin
329 (method url-fetch)
330 (uri (string-append "mirror://cpan/authors/id/A/AS/ASKSH/"
331 "Snowball-Norwegian-" version ".tar.gz"))
332 (sha256
333 (base32
334 "0675v45bbsh7vr7kpf36xs2q79g02iq1kmfw22h20xdk4rzqvkqx"))))
335 (build-system perl-build-system)
336 (native-inputs `(("perl-module-build" ,perl-module-build)))
337 (home-page "http://search.cpan.org/dist/Snowball-Norwegian")
338 (synopsis "Porters stemming algorithm for Norwegian")
339 (description "Lingua::Stem::Snowball::No is a perl port of the norwegian
340 stemmer at http://snowball.tartarus.org.")
341 (license perl-license)))
342
343 (define-public perl-snowball-swedish
344 (package
345 (name "perl-snowball-swedish")
346 (version "1.2")
347 (source
348 (origin
349 (method url-fetch)
350 (uri (string-append "mirror://cpan/authors/id/A/AS/ASKSH/"
351 "Snowball-Swedish-" version ".tar.gz"))
352 (sha256
353 (base32
354 "0agwc12jk5kmabnpsplw3wf4ii5w1zb159cpin44x3srb0sr5apg"))))
355 (build-system perl-build-system)
356 (native-inputs `(("perl-module-build" ,perl-module-build)))
357 (home-page "http://search.cpan.org/dist/Snowball-Swedish")
358 (synopsis "Porters stemming algorithm for Swedish")
359 (description "Lingua::Stem::Snowball::Se is a perl port of the swedish
360 stemmer at http://snowball.sourceforge.net.")
361 (license perl-license)))
362
363 (define-public perl-string-toidentifier-en
364 (package
365 (name "perl-string-toidentifier-en")
366 (version "0.11")
367 (source
368 (origin
369 (method url-fetch)
370 (uri (string-append "mirror://cpan/authors/id/R/RK/RKITOVER/"
371 "String-ToIdentifier-EN-" version ".tar.gz"))
372 (sha256
373 (base32
374 "1bawghkgkkx7j3avnrj5sg3vix1z5564ks6wf9az3jc2knh8s5nh"))))
375 (build-system perl-build-system)
376 (propagated-inputs
377 `(("perl-lingua-en-inflect-phrase" ,perl-lingua-en-inflect-phrase)
378 ("perl-text-unidecode" ,perl-text-unidecode)
379 ("perl-namespace-clean" ,perl-namespace-clean)))
380 (home-page "http://search.cpan.org/dist/String-ToIdentifier-EN")
381 (synopsis "Convert strings to English program identifiers")
382 (description "This module provides a utility method, \"to_identifier\" for
383 converting an arbitrary string into a readable representation using the ASCII
384 subset of \"\\w\" for use as an identifier in a computer program. The intent
385 is to make unique identifier names from which the content of the original
386 string can be easily inferred by a human just by reading the identifier.")
387 (license perl-license)))
388
389 (define-public perl-text-german
390 (package
391 (name "perl-text-german")
392 (version "0.06")
393 (source
394 (origin
395 (method url-fetch)
396 (uri (string-append "mirror://cpan/authors/id/U/UL/ULPFR/"
397 "Text-German-" version ".tar.gz"))
398 (sha256
399 (base32
400 "1p87pgap99lw0nv62i3ghvsi7yg90lhn8vsa3yqp75rd04clybcj"))))
401 (build-system perl-build-system)
402 (home-page "http://search.cpan.org/dist/Text-German")
403 (synopsis "German grundform reduction")
404 (description "This module is a rather incomplete implementation of work
405 done by Gudrun Putze-Meier.")
406 (license perl-license)))