Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / image.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages image)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages compression)
22 #:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27 (define-public libpng
28 (package
29 (name "libpng")
30 (version "1.5.17")
31 (source (origin
32 (method url-fetch)
33
34 ;; Note: upstream removes older tarballs.
35 (uri (list (string-append "mirror://sourceforge/libpng/libpng15/"
36 version "/libpng-" version ".tar.xz")
37 (string-append
38 "ftp://ftp.simplesystems.org/pub/libpng/png/src"
39 "/libpng15/libpng-" version ".tar.xz")))
40 (sha256
41 (base32 "19wj293r4plbfgb43yhrc2qx8bsch9gbazazfqrj9haa7lsk29jp"))))
42 (build-system gnu-build-system)
43
44 ;; libpng.la says "-lz", so propagate it.
45 (propagated-inputs `(("zlib" ,zlib)))
46
47 (synopsis "Library for handling PNG files")
48 (description
49 "Libpng is the official PNG (Portable Network Graphics) reference
50 library. It supports almost all PNG features and is extensible.")
51 (license license:zlib)
52 (home-page "http://www.libpng.org/pub/png/libpng.html")))
53
54 (define-public libjpeg
55 (package
56 (name "libjpeg")
57 (version "9")
58 (source (origin
59 (method url-fetch)
60 (uri (string-append "http://www.ijg.org/files/jpegsrc.v"
61 version ".tar.gz"))
62 (sha256 (base32
63 "0dg5wxcx3cw0hal9gvivj97vid9z0s5sb1yvg55hpxmafn9rxqn4"))))
64 (build-system gnu-build-system)
65 (synopsis "Libjpeg, a library for handling JPEG files")
66 (description
67 "Libjpeg implements JPEG image encoding, decoding, and transcoding.
68 JPEG is a standardized compression method for full-color and gray-scale
69 images.
70 The included programs provide conversion between the JPEG format and
71 image files in PBMPLUS PPM/PGM, GIF, BMP, and Targa file formats.")
72 (license license:ijg)
73 (home-page "http://www.ijg.org/")))
74
75 (define-public libjpeg-8
76 (package (inherit libjpeg)
77 (version "8d")
78 (source (origin
79 (method url-fetch)
80 (uri (string-append "http://www.ijg.org/files/jpegsrc.v"
81 version ".tar.gz"))
82 (sha256 (base32
83 "1cz0dy05mgxqdgjf52p54yxpyy95rgl30cnazdrfmw7hfca9n0h0"))))))
84
85 (define-public libtiff
86 (package
87 (name "libtiff")
88 (version "4.0.3")
89 (source (origin
90 (method url-fetch)
91 (uri (string-append "ftp://ftp.remotesensing.org/pub/libtiff/tiff-"
92 version ".tar.gz"))
93 (sha256 (base32
94 "0wj8d1iwk9vnpax2h29xqc2hwknxg3s0ay2d5pxkg59ihbifn6pa"))))
95 (build-system gnu-build-system)
96 (inputs `(("zlib" ,zlib)
97 ("libjpeg-8" ,libjpeg-8)))
98 ;; currently does not compile with libjpeg version 9
99 (arguments
100 `(#:configure-flags
101 (list (string-append "--with-jpeg-include-dir="
102 (assoc-ref %build-inputs "libjpeg-8")
103 "/include"))))
104 (synopsis "Libtiff, a library for handling TIFF files")
105 (description
106 "Libtiff provides support for the Tag Image File Format (TIFF), a format
107 used for storing image data.
108 Included are a library, libtiff, for reading and writing TIFF and a small
109 collection of tools for doing simple manipulations of TIFF images.")
110 (license (license:bsd-style "file://COPYRIGHT"
111 "See COPYRIGHT in the distribution."))
112 (home-page "http://www.libtiff.org/")))