gnu: Remove "open source" from descriptions.
[jackhill/guix/guix.git] / gnu / packages / aidc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darringon <jmd@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages aidc)
22 #:use-module (gnu packages)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (gnu packages image)
28 #:use-module (guix build-system gnu))
29
30
31 (define-public barcode
32 (package
33 (name "barcode")
34 (version "0.99")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "mirror://gnu/barcode/barcode-"
38 version ".tar.xz"))
39 (sha256
40 (base32
41 "1indapql5fjz0bysyc88cmc54y8phqrbi7c76p71fgjp45jcyzp8"))))
42 (build-system gnu-build-system)
43 (synopsis "Convert text strings to printed bars in various standards")
44 (description "GNU Barcode is a flexible tool to produce printed barcodes
45 from text strings. It supports a variety of encoding standards and sizing
46 measurements. Barcodes can be output in PostScript or Encapsulated PostScript
47 formats.")
48 (license license:gpl3+)
49 (home-page "https://www.gnu.org/software/barcode/")))
50
51 (define-public qrencode
52 (package
53 (name "qrencode")
54 (version "3.4.4")
55 (source (origin
56 (method url-fetch)
57 (uri (string-append
58 "https://fukuchi.org/works/qrencode/qrencode-" version
59 ".tar.gz"))
60 (sha256
61 (base32
62 "0wiagx7i8p9zal53smf5abrnh9lr31mv0p36wg017401jrmf5577"))))
63 (build-system gnu-build-system)
64 (inputs `(("libpng" ,libpng)))
65 (native-inputs `(("pkg-config" ,pkg-config)))
66 (synopsis "Encode data into a QR Code symbol")
67 (description "Libqrencode is a C library for encoding data in a QR Code
68 symbol, a kind of 2D symbology that can be scanned by handy terminals such as
69 a mobile phone with CCD. The capacity of QR Code is up to 7000 digits or 4000
70 characters, and is highly robust.")
71 (license license:lgpl2.1+)
72 (home-page "https://fukuchi.org/works/qrencode")))
73
74 (define-public libdmtx
75 (package
76 (name "libdmtx")
77 (version "0.7.4")
78 (source
79 (origin
80 (method url-fetch)
81 (uri (string-append
82 "mirror://sourceforge/libdmtx/" name "/" version "/"
83 name "-" version ".tar.bz2"))
84 (sha256
85 (base32 "0xnxx075ycy58n92yfda2z9zgd41h3d4ik5d9l197lzsqim5hb5n"))))
86 (build-system gnu-build-system)
87 (native-inputs
88 `(("pkg-config" ,pkg-config)))
89 (home-page "http://libdmtx.sourceforge.net/")
90 (synopsis "Library for reading and writing Data Matrix 2D barcodes")
91 (description "libdmtx is software for reading and writing Data Matrix 2D
92 barcodes on Linux and Unix. At its core libdmtx is a shared library, allowing
93 C/C++ programs to use its capabilities without restrictions or overhead.")
94 (license license:bsd-3)))