gnu: libexif: Fix CVE-2018-20030.
[jackhill/guix/guix.git] / gnu / packages / photo.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015, 2017, 2019 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2015, 2017 Andreas Enge <andreas@enge.fr>
5 ;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
7 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages photo)
26 #:use-module (guix build-system cmake)
27 #:use-module (guix build-system gnu)
28 #:use-module (guix build-system perl)
29 #:use-module (guix download)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (guix packages)
32 #:use-module (guix utils)
33 #:use-module (gnu packages)
34 #:use-module (gnu packages algebra)
35 #:use-module (gnu packages autotools)
36 #:use-module (gnu packages base)
37 #:use-module (gnu packages boost)
38 #:use-module (gnu packages compression)
39 #:use-module (gnu packages curl)
40 #:use-module (gnu packages gettext)
41 #:use-module (gnu packages ghostscript)
42 #:use-module (gnu packages gl)
43 #:use-module (gnu packages gnome)
44 #:use-module (gnu packages glib)
45 #:use-module (gnu packages graphics)
46 #:use-module (gnu packages gtk)
47 #:use-module (gnu packages image)
48 #:use-module (gnu packages imagemagick)
49 #:use-module (gnu packages libcanberra)
50 #:use-module (gnu packages libusb)
51 #:use-module (gnu packages llvm)
52 #:use-module (gnu packages man)
53 #:use-module (gnu packages maths)
54 #:use-module (gnu packages perl)
55 #:use-module (gnu packages pkg-config)
56 #:use-module (gnu packages popt)
57 #:use-module (gnu packages python)
58 #:use-module (gnu packages python-xyz)
59 #:use-module (gnu packages readline)
60 #:use-module (gnu packages sqlite)
61 #:use-module (gnu packages tex)
62 #:use-module (gnu packages web)
63 #:use-module (gnu packages wxwidgets)
64 #:use-module (gnu packages xfig)
65 #:use-module (gnu packages xorg)
66 #:use-module (gnu packages xml)
67 #:use-module ((srfi srfi-1) #:hide (zip))
68 #:use-module (srfi srfi-26))
69
70 (define-public libraw
71 (package
72 (name "libraw")
73 (version "0.19.3")
74 (source (origin
75 (method url-fetch)
76 (uri (string-append "https://www.libraw.org/data/LibRaw-"
77 version ".tar.gz"))
78 (sha256
79 (base32
80 "0xs1qb6pcvc4c43fy5xi3nkqxcif77gakkw99irf0fc5iccdd5px"))))
81 (build-system gnu-build-system)
82 (native-inputs
83 `(("pkg-config" ,pkg-config)))
84 (inputs
85 `(("libjpeg" ,libjpeg))) ;for lossy DNGs and old Kodak cameras
86 (propagated-inputs
87 `(("lcms" ,lcms))) ;for color profiles
88 (home-page "https://www.libraw.org")
89 (synopsis "Raw image decoder")
90 (description
91 "LibRaw is a library for reading RAW files obtained from digital photo
92 cameras (CRW/CR2, NEF, RAF, DNG, and others).")
93 ;; LibRaw is distributed under both LGPL2.1 and CDDL 1.0. From the README:
94 ;; "You may use one of these licensing modes and switch between them. If
95 ;; you modify LibRaw source and made your changes public, you should accept
96 ;; both two licensing modes for your changes/additions."
97 (license (list license:lgpl2.1 license:cddl1.0))))
98
99 (define-public libraw-0.18
100 (package (inherit libraw)
101 (name "libraw")
102 (version "0.18.12")
103 (source (origin
104 (method url-fetch)
105 (uri (string-append "https://www.libraw.org/data/LibRaw-"
106 version ".tar.gz"))
107 (sha256
108 (base32
109 "1m2khr2cij8z6lawgbmdksjn14fpnjsy8ad4qahnpqapm1slsxap"))))))
110
111 (define-public libexif
112 (package
113 (name "libexif")
114 (version "0.6.21")
115 (source (origin
116 (method url-fetch)
117 (uri (string-append "mirror://sourceforge/libexif/libexif/"
118 version "/libexif-" version ".tar.bz2"))
119 (patches (search-patches "libexif-CVE-2016-6328.patch"
120 "libexif-CVE-2017-7544.patch"
121 "libexif-CVE-2018-20030.patch"))
122 (sha256
123 (base32
124 "06nlsibr3ylfwp28w8f5466l6drgrnydgxrm4jmxzrmk5svaxk8n"))))
125 (build-system gnu-build-system)
126 (home-page "https://libexif.github.io/")
127 (synopsis "Read and manipulate EXIF data in digital photographs")
128 (description
129 "The libexif C library allows applications to read, edit, and save EXIF
130 data as produced by digital cameras.")
131 (license license:lgpl2.1+)))
132
133 (define-public libgphoto2
134 (package
135 (name "libgphoto2")
136 (version "2.5.23")
137 (source (origin
138 (method url-fetch)
139 (uri (string-append "mirror://sourceforge/gphoto/libgphoto/"
140 version "/libgphoto2-" version ".tar.bz2"))
141 (sha256
142 (base32
143 "0bc5x2bkqbfi4hbkz8ab5xc0bkks9vvks1vygxhdh3x498v27byq"))))
144 (build-system gnu-build-system)
145 (native-inputs `(("pkg-config" ,pkg-config)))
146 (inputs
147 `(("libjpeg-turbo" ,libjpeg-turbo)
148 ("libltdl" ,libltdl)
149 ("libusb" ,libusb)
150 ("libxml2" ,libxml2)))
151 (propagated-inputs
152 `(;; The .pc refers to libexif.
153 ("libexif" ,libexif)))
154 (home-page "http://www.gphoto.org/proj/libgphoto2/")
155 (synopsis "Accessing digital cameras")
156 (description
157 "This is the library backend for gphoto2. It contains the code for PTP,
158 MTP, and other vendor specific protocols for controlling and transferring data
159 from digital cameras.")
160
161 ;; 'COPYING' says LGPLv2.1+, but in practices files are under LGPLv2+.
162 (license license:lgpl2.1+)))
163
164 (define-public gphoto2
165 (package
166 (name "gphoto2")
167 (version "2.5.23")
168 (source (origin
169 (method url-fetch)
170 (uri (string-append "mirror://sourceforge/gphoto/gphoto/" version
171 "/gphoto2-" version ".tar.bz2"))
172 (sha256
173 (base32
174 "1laqwhxr0xhbykmp0dhd3j4rr2lhj5y228s31afnqxp700hhk1yz"))))
175 (build-system gnu-build-system)
176 (native-inputs
177 `(("pkg-config" ,pkg-config)))
178 (inputs
179 `(("readline" ,readline)
180 ("libjpeg-turbo" ,libjpeg-turbo)
181 ("popt" ,popt)
182 ("libexif" ,libexif)
183 ("libgphoto2" ,libgphoto2)))
184 (arguments
185 '(#:phases
186 (modify-phases %standard-phases
187 (add-before 'check 'pre-check
188 (lambda* (#:key inputs #:allow-other-keys)
189 (substitute* (find-files "tests/data" "\\.param$")
190 (("/usr/bin/env")
191 (which "env")))
192 #t)))
193
194 ;; FIXME: There is 1 test failure, most likely related to the build
195 ;; environment.
196 #:tests? #f))
197
198 (home-page "http://www.gphoto.org/")
199 (synopsis "Command-line tools to access digital cameras")
200 (description
201 "Gphoto2 is a set of command line utilities for manipulating a large
202 number of different digital cameras. Through libgphoto2, it supports PTP,
203 MTP, and much more.")
204
205 ;; Files are typically under LGPLv2+, but 'COPYING' says GPLv2+.
206 (license license:gpl2+)))
207
208 ;; Note: See <https://metacpan.org/pod/Image::ExifTool> for the latest
209 ;; release. The versions at <https://www.sno.phy.queensu.ca/~phil/exiftool/>
210 ;; are not meant for production use according to the Changes file.
211 (define-public perl-image-exiftool
212 (package
213 (name "perl-image-exiftool")
214 (version "11.30")
215 (source
216 (origin
217 (method url-fetch)
218 (uri (list
219 (string-append "mirror://cpan/authors/id/E/EX/EXIFTOOL/"
220 "Image-ExifTool-" version ".tar.gz")
221 ;; New releases may take a while to hit CPAN.
222 (string-append "https://www.sno.phy.queensu.ca/~phil/exiftool/"
223 "Image-ExifTool-" version ".tar.gz")))
224 (sha256
225 (base32 "0vkjb2c1a3jdlq8rx1jywx4p3f1bmgjn7rzfwx6dxgij2lx76lrs"))))
226 (build-system perl-build-system)
227 (arguments
228 '(#:phases
229 (modify-phases %standard-phases
230 (add-after 'install 'post-install
231 (lambda* (#:key outputs #:allow-other-keys)
232 ;; Make sure the 'exiftool' commands finds the library.
233 ;; XXX: Shouldn't it be handled by PERL-BUILD-SYSTEM?
234 (let* ((out (assoc-ref outputs "out"))
235 (pm (find-files out "^ExifTool\\.pm$"))
236 (lib (dirname (dirname (car pm)))))
237 (wrap-program (string-append out "/bin/exiftool")
238 `("PERL5LIB" prefix (,lib)))
239 #t))))))
240 (home-page "https://metacpan.org/release/Image-ExifTool")
241 (synopsis "Program and Perl library to manipulate EXIF and other metadata")
242 (description "This package provides the @code{exiftool} command and the
243 @code{Image::ExifTool} Perl library to manipulate EXIF tags of digital images
244 and a wide variety of other metadata.")
245 (license license:perl-license)))
246
247 (define-public libpano13
248 (package
249 (name "libpano13")
250 (version "2.9.19")
251 (source (origin
252 (method url-fetch)
253 (uri (string-append "mirror://sourceforge/panotools/libpano13/"
254 "libpano13-" version "/"
255 "libpano13-" version ".tar.gz"))
256 (sha256
257 (base32
258 "1a4m3plmfcrrplqs9zfzhc5apibn10m5sajpizm1sd3q74w5fwq3"))))
259 (build-system cmake-build-system)
260 (inputs
261 `(("libjpeg" ,libjpeg)
262 ("libpng" ,libpng)
263 ("libtiff" ,libtiff)
264 ("zlib" ,zlib)))
265 (home-page "http://panotools.sourceforge.net/")
266 (synopsis "Library for panoramic images")
267 (description
268 "The libpano13 package contains the backend library written by the
269 Panorama Tools project for building panoramic images from a set of
270 overlapping images, as well as some command line tools.")
271 (license license:gpl2+)))
272
273 (define-public enblend-enfuse
274 (package
275 (name "enblend-enfuse")
276 (version "4.2")
277 (source (origin
278 (method url-fetch)
279 (uri (string-append "mirror://sourceforge/enblend/"
280 name "/"
281 name "-" (version-major+minor version) "/"
282 name "-" version ".tar.gz"))
283 (sha256
284 (base32
285 "0j5x011ilalb47ssah50ag0a4phgh1b0wdgxdbbp1gcyjcjf60w7"))))
286 (build-system gnu-build-system)
287 (native-inputs
288 `(("pkg-config" ,pkg-config)
289 ("perl" ,perl)
290 ("perl-timedate" ,perl-timedate)
291 ;; for building the documentation
292 ("gnuplot" ,gnuplot)
293 ("help2man" ,help2man)
294 ("imagemagick" ,imagemagick)
295 ("libxml2" ,libxml2)
296 ("texlive-minimal" ,texlive-tiny)
297 ("tidy" ,tidy)
298 ("transfig" ,transfig)))
299 (inputs
300 `(("boost" ,boost)
301 ("gsl" ,gsl)
302 ("lcms" ,lcms)
303 ("libjpeg" ,libjpeg)
304 ("libpng" ,libpng)
305 ("libtiff" ,libtiff)
306 ("openexr" ,openexr)
307 ("vigra" ,vigra)
308 ("zlib" ,zlib)))
309 (arguments
310 `(#:configure-flags `("--enable-openmp")))
311 (home-page "http://enblend.sourceforge.net/")
312 (synopsis "Tools for combining and blending images")
313 (description
314 "Enblend blends away the seams in a panoramic image mosaic using a
315 multi-resolution spline. Enfuse merges different exposures of the same
316 scene to produce an image that looks much like a tone-mapped image.")
317 (license license:gpl2+)))
318
319 (define-public lensfun
320 (package
321 (name "lensfun")
322 (version "0.3.2")
323 (source (origin
324 (method url-fetch)
325 (uri (string-append
326 "mirror://sourceforge/lensfun/"
327 version "/lensfun-" version ".tar.gz"))
328 (sha256
329 (base32
330 "0cfk8jjhs9nbfjfdy98plrj9ayi59aph0nx6ppslgjhlcvacm2xf"))))
331 (build-system cmake-build-system)
332 (arguments
333 `(,@(if (any (cute string-prefix? <> (or (%current-system)
334 (%current-target-system)))
335 '("x86_64" "i686"))
336 ;; SSE and SSE2 are supported only on Intel processors.
337 '()
338 '(#:configure-flags '("-DBUILD_FOR_SSE=OFF" "-DBUILD_FOR_SSE2=OFF")))
339 #:tests? #f)) ; There are no tests to run.
340 (native-inputs
341 `(("pkg-config" ,pkg-config)))
342 (inputs
343 `(("glib" ,glib)))
344 (home-page "https://sourceforge.net/projects/lensfun/")
345 (synopsis "Library to correct optical lens defects with a lens database")
346 (description "Digital photographs are not ideal. Of course, the better is
347 your camera, the better the results will be, but in any case if you look
348 carefully at shots taken even by the most expensive cameras equipped with the
349 most expensive lenses you will see various artifacts. It is very hard to make
350 ideal cameras, because there are a lot of factors that affect the final image
351 quality, and at some point camera and lens designers have to trade one factor
352 for another to achieve the optimal image quality, within the given design
353 restrictions and budget. But we all want ideal shots, don't we? So that's
354 what's Lensfun is all about: rectifying the defects introduced by your
355 photographic equipment.")
356 ;; The libraries are licensed under the LGPL3, the programs are
357 ;; licensed GPL3, and the database is license CC-BY-SA 3.0. See the
358 ;; README.md file for this clarification.
359 (license (list license:lgpl3 license:gpl3 license:cc-by-sa3.0))))
360
361 (define-public darktable
362 (package
363 (name "darktable")
364 (version "2.6.2")
365 (source
366 (origin
367 (method url-fetch)
368 (uri (string-append
369 "https://github.com/darktable-org/darktable/releases/"
370 "download/release-" version "/darktable-" version ".tar.xz"))
371 (sha256
372 (base32 "0igvgyd042j7hm4y8fcm6dc1qqjs4d1r7y6f0pzpa0x416xyzfcw"))))
373 (build-system cmake-build-system)
374 (arguments
375 `(#:tests? #f ; there are no tests
376 #:configure-flags '("-DBINARY_PACKAGE_BUILD=On")
377 #:make-flags
378 (list
379 (string-append "CPATH=" (assoc-ref %build-inputs "ilmbase")
380 "/include/OpenEXR:" (or (getenv "CPATH") "")))
381 #:phases
382 (modify-phases %standard-phases
383 (add-before 'configure 'set-ldflags
384 (lambda* (#:key outputs #:allow-other-keys)
385 (setenv "LDFLAGS"
386 (string-append
387 "-Wl,-rpath="
388 (assoc-ref outputs "out") "/lib/darktable"))
389 #t)))))
390 (native-inputs
391 `(("llvm" ,llvm-3.9.1)
392 ("clang" ,clang-3.9.1)))
393 (inputs
394 `(("libxslt" ,libxslt)
395 ("libxml2" ,libxml2)
396 ("pugixml" ,pugixml)
397 ("gtk+" ,gtk+)
398 ("sqlite" ,sqlite)
399 ("libjpeg" ,libjpeg)
400 ("libpng" ,libpng)
401 ("cairo" ,cairo)
402 ("lcms" ,lcms)
403 ("exiv2" ,exiv2)
404 ("libtiff" ,libtiff)
405 ("curl" ,curl)
406 ("libgphoto2" ,libgphoto2)
407 ("dbus-glib" ,dbus-glib)
408 ("openexr" ,openexr)
409 ("ilmbase" ,ilmbase)
410 ("libsoup" ,libsoup)
411 ("python-jsonschema" ,python-jsonschema)
412 ("intltool" ,intltool)
413 ("perl" ,perl)
414 ("pkg-config" ,pkg-config)
415 ("libwebp" ,libwebp)
416 ("lensfun" ,lensfun)
417 ("librsvg" ,librsvg)
418 ("json-glib" ,json-glib)
419 ("freeimage" ,freeimage)))
420 (home-page "https://www.darktable.org")
421 (synopsis "Virtual lighttable and darkroom for photographers")
422 (description "Darktable is a photography workflow application and RAW
423 developer. It manages your digital negatives in a database, lets you view
424 them through a zoomable lighttable and enables you to develop raw images
425 and enhance them.")
426 ;; See src/is_supported_platform.h for supported platforms.
427 (supported-systems '("i686-linux" "x86_64-linux" "aarch64-linux"))
428 (license license:gpl3+)))
429
430 (define-public hugin
431 (package
432 (name "hugin")
433 (version "2019.0.0")
434 (source (origin
435 (method url-fetch)
436 (uri (string-append "mirror://sourceforge/hugin/hugin/hugin-"
437 (version-major+minor version)
438 "/hugin-" version ".tar.bz2"))
439 (sha256
440 (base32
441 "1l925qslp98gg7yzmgps10h6dq0nb60wbfk345anlxsv0g2ifizr"))))
442 (build-system cmake-build-system)
443 (native-inputs
444 `(("gettext" ,gnu-gettext)
445 ("pkg-config" ,pkg-config)))
446 (inputs
447 `(("boost" ,boost)
448 ("enblend-enfuse" ,enblend-enfuse)
449 ("exiv2" ,exiv2-0.26)
450 ("fftw" ,fftw)
451 ("flann" ,flann)
452 ("freeglut" ,freeglut)
453 ("glew" ,glew)
454 ("lcms" ,lcms)
455 ("libjpeg" ,libjpeg)
456 ("libpano13" ,libpano13)
457 ("libpng" ,libpng)
458 ("libtiff" ,libtiff)
459 ("libxi" ,libxi)
460 ("libxmu" ,libxmu)
461 ("mesa" ,mesa)
462 ("openexr" ,openexr)
463 ("sqlite" ,sqlite)
464 ("vigra" ,vigra)
465 ("wxwidgets" ,wxwidgets)
466 ("zlib" ,zlib)))
467 (arguments
468 `(#:tests? #f ; no check target
469 #:configure-flags
470 (list
471 ;; The header files of ilmbase (propagated by openexr) are not found
472 ;; when included by the header files of openexr, and an explicit
473 ;; flag needs to be set.
474 (string-append "-DCMAKE_CXX_FLAGS=-I"
475 (assoc-ref %build-inputs "ilmbase")
476 "/include/OpenEXR")
477 ;; Disable installation of the Python scripting interface.
478 ;; It would require the additional inputs python and swig.
479 ;; Installation would need to be tweaked, as it tries to install
480 ;; into the python directory.
481 "-DBUILD_HSI=OFF")
482 #:phases
483 (modify-phases %standard-phases
484 (add-before 'configure 'substitute
485 (lambda _
486 (substitute* "src/hugin1/base_wx/StitchingExecutor.cpp"
487 (("wxT\\(\"enblend\"\\)")
488 (string-append "wxT(\"" (which "enblend") "\")"))
489 (("wxT\\(\"enfuse\"\\)")
490 (string-append "wxT(\"" (which "enfuse") "\")")))
491 #t)))))
492 (home-page "http://hugin.sourceforge.net/")
493 (synopsis "Panorama photo stitcher")
494 (description
495 "Hugin is an easy to use panoramic imaging toolchain with a graphical
496 user interface. It can be used to assemble a mosaic of photographs into
497 a complete panorama and stitch any series of overlapping pictures.")
498 (license license:gpl2+)))
499
500 (define-public rawtherapee
501 (package
502 (name "rawtherapee")
503 (version "5.6")
504 (source (origin
505 (method url-fetch)
506 (uri (string-append "http://rawtherapee.com/shared/source/"
507 "rawtherapee-" version ".tar.xz"))
508 (sha256
509 (base32
510 "0x0dcfp6f3j08gr11wq5ah4prp790xy4iadbgsm9kgc0jlalpspr"))))
511 (build-system cmake-build-system)
512 (arguments
513 '(#:tests? #f ; no test suite
514 #:build-type "release"
515 #:configure-flags
516 (list (string-append "-DLENSFUNDBDIR="
517 (assoc-ref %build-inputs "lensfun")
518 "/share/lensfun")
519 ;; Don't optimize the build for the host machine. See the file
520 ;; 'ProcessorTargets.cmake' in the source distribution for more
521 ;; information.
522 "-DPROC_TARGET_NUMBER=1"
523 ;; These flags are recommended by upstream for distributed packages.
524 ;; See the file 'RELEASE_NOTES.txt' in the source distribution.
525 "-O3"
526 "-DCACHE_NAME_SUFFIX=\"\"")))
527 (native-inputs
528 `(("pkg-config" ,pkg-config)))
529 (inputs
530 `(("expat" ,expat)
531 ("fftw" ,fftwf)
532 ("glib" ,glib)
533 ("glibmm" ,glibmm)
534 ("gtk+" ,gtk+)
535 ("gtkmm" ,gtkmm)
536 ("lcms" ,lcms)
537 ("lensfun" ,lensfun)
538 ("libcanberra" ,libcanberra)
539 ("libiptcdata" ,libiptcdata)
540 ("libjpeg" ,libjpeg)
541 ("libpng" ,libpng)
542 ("librsvg" ,librsvg)
543 ("libsigc++" ,libsigc++)
544 ("libtiff" ,libtiff)
545 ("zlib" ,zlib)))
546 (home-page "http://rawtherapee.com")
547 (synopsis "Raw image developing and processing")
548 (description "RawTherapee is a raw image processing suite. It comprises a
549 subset of image editing operations specifically aimed at non-destructive raw
550 photo post-production and is primarily focused on improving a photographer's
551 workflow by facilitating the handling of large numbers of images. Most raw
552 formats are supported, including Pentax Pixel Shift, Canon Dual-Pixel, and those
553 from Foveon and X-Trans sensors.")
554 (license license:gpl3+)))