gnu: glib: Upgrade to 2.40.0.
[jackhill/guix/guix.git] / gnu / packages / cursynth.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages cursynth)
20 #:use-module (guix packages)
21 #:use-module (guix licenses)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages ncurses)
27 #:use-module (gnu packages linux))
28
29 (define-public cursynth
30 (package
31 (name "cursynth")
32 (version "1.5")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/cursynth/cursynth-"
37 version ".tar.gz"))
38 (sha256
39 (base32 "1dhphsya41rv8z6yqcv9l6fwbslsds4zh1y56zizi39nd996d40v"))
40 (patches (list (search-patch "cursynth-wave-rand.patch")))))
41 (build-system gnu-build-system)
42 (native-inputs `(("pkg-config" ,pkg-config)))
43 ;; TODO: See https://github.com/iyoko/cursynth/issues/4 which currently
44 ;; prevents us from using pulseaudio
45 (inputs `(("ncurses" ,ncurses)
46 ("alsa" ,alsa-lib)))
47 (home-page "http://www.gnu.org/software/cursynth")
48 (synopsis "Polyphonic and MIDI subtractive music synthesizer using curses")
49 (description "GNU cursynth is a polyphonic synthesizer that runs
50 graphically in the terminal. It is built on a full-featured subtractive
51 synthesis engine. Notes and parameter changes may be entered via MIDI or the
52 computer's keyboard.")
53 (license gpl3+)))