gnu: glib: Upgrade to 2.40.0.
[jackhill/guix/guix.git] / gnu / packages / curl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages curl)
20 #:use-module ((guix licenses)
21 #:renamer (symbol-prefix-proc 'license:))
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages gnutls)
28 #:use-module (gnu packages groff)
29 #:use-module (gnu packages gsasl)
30 #:use-module (gnu packages libidn)
31 #:use-module (gnu packages openldap)
32 #:use-module (gnu packages perl)
33 #:use-module (gnu packages pkg-config)
34 #:use-module (gnu packages python)
35 #:use-module (gnu packages ssh))
36
37 (define-public curl
38 (package
39 (name "curl")
40 (version "7.35.0")
41 (source (origin
42 (method url-fetch)
43 (uri (string-append "http://curl.haxx.se/download/curl-"
44 version ".tar.lzma"))
45 (sha256
46 (base32
47 "14w5cwh6b1426lxkq6kp6h4vxryr4n7wfrrwhny1r4123q7n8ab9"))
48 (patches
49 ;; This patch fixes testcase 172 which uses a hardcoded cookie
50 ;; expiration value which is expired as of Feb 1, 2014.
51 (list (search-patch "curl-fix-test172.patch")))))
52 (build-system gnu-build-system)
53 (inputs `(("gnutls" ,gnutls)
54 ("gss" ,gss)
55 ("libidn" ,libidn)
56 ("libssh2" ,libssh2)
57 ("openldap" ,openldap)
58 ("zlib" ,zlib)))
59 (native-inputs
60 `(("perl" ,perl)
61 ;; to enable the --manual option and make test 1026 pass
62 ("groff" ,groff)
63 ("pkg-config" ,pkg-config)
64 ("python" ,python-2)))
65 (arguments
66 `(#:configure-flags '("--with-gnutls" "--with-gssapi")
67 ;; Add a phase to patch '/bin/sh' occurances in tests/runtests.pl
68 #:phases
69 (alist-cons-before
70 'check 'patch-runtests
71 (lambda _
72 (substitute* "tests/runtests.pl"
73 (("/bin/sh") (which "sh"))))
74 %standard-phases)))
75 (synopsis "curl, command line tool for transferring data with URL syntax")
76 (description
77 "curl is a command line tool for transferring data with URL syntax,
78 supporting DICT, FILE, FTP, FTPS, Gopher, HTTP, HTTPS, IMAP, IMAPS, LDAP,
79 LDAPS, POP3, POP3S, RTMP, RTSP, SCP, SFTP, SMTP, SMTPS, Telnet and TFTP.
80 curl supports SSL certificates, HTTP POST, HTTP PUT, FTP uploading,
81 HTTP form based upload, proxies, cookies, user+password authentication
82 (Basic, Digest, NTLM, Negotiate, kerberos...), file transfer resume,
83 proxy tunneling, and so on")
84 (license (license:bsd-style "file://COPYING"
85 "See COPYING in the distribution."))
86 (home-page "http://curl.haxx.se/")))