distro: Rename (distro) to (gnu packages).
[jackhill/guix/guix.git] / gnu / packages / rsync.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages rsync)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages perl)
22 #:use-module (gnu packages acl)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu))
27
28
29 (define-public rsync
30 (package
31 (name "rsync")
32 (version "3.0.9")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "http://rsync.samba.org/ftp/rsync/rsync-"
36 version ".tar.gz"))
37 (sha256
38 (base32
39 "01bw4klqsrlhh3i9lazd485sd9qx5djvnwa21lj2h3a9sn6hzw9h"))))
40 (build-system gnu-build-system)
41 (inputs `(("perl" ,perl)
42 ("acl" ,acl)))
43 (synopsis "rsync, a remote (and local) file copying tool")
44 (description
45 "rsync is a fast and versatile file copying tool. It can copy locally,
46 to/from another host over any remote shell, or to/from a remote rsync daemon.
47 Its delta-transfer algorithm reduces the amount of data sent over the network
48 by sending only the differences between the source files and the existing
49 files in the destination.")
50 (license gpl3+)
51 (home-page "http://rsync.samba.org/")))