distro: Rename (distro) to (gnu packages).
[jackhill/guix/guix.git] / gnu / packages / recutils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages recutils)
20 #:use-module (guix licenses)
21 #:use-module (gnu packages)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix utils)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages emacs)
27 #:use-module (gnu packages check)
28 #:use-module (gnu packages algebra))
29
30 (define-public recutils
31 (package
32 (name "recutils")
33 (version "1.5")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/recutils/recutils-"
37 version ".tar.gz"))
38 (sha256
39 (base32
40 "1v2xzwwwhc5j5kmvg4sv6baxjpsfqh8ln7ilv4mgb1408rs7xmky"))))
41 (build-system gnu-build-system)
42 (inputs `(;; TODO: Enable optional deps when they're packaged.
43 ;; ("curl" ,(nixpkgs-derivation "curl"))
44 ("emacs" ,emacs)
45 ("check" ,check)
46 ("bc" ,bc)
47 ("patch/gets"
48 ,(search-patch "diffutils-gets-undeclared.patch"))))
49 (arguments `(#:patches (list (assoc-ref %build-inputs "patch/gets"))))
50 (synopsis "GNU recutils, tools and libraries to access human-editable,
51 text-based databases")
52 (description
53 "GNU recutils is a set of tools and libraries to access human-editable,
54 text-based databases called recfiles. The data is stored as a sequence of
55 records, each record containing an arbitrary number of named fields.")
56 (license gpl3+)
57 (home-page "http://www.gnu.org/software/recutils/")))