gnu: python-pyqt: Fix build for new python-sip.
[jackhill/guix/guix.git] / gnu / packages / patches / hdf-eos2-remove-gctp.patch
1 Don't build the GCTP bundled with the source and link with the
2 system's -lgctp instead. We also remove references to the
3 "testdrivers" directory, which is not distributed together with the
4 source, causing autoreconf to fail.
5
6 diff --git a/Makefile.in b/Makefile.in
7 index d468af2..90428a7 100644
8 --- a/Makefile.in
9 +++ b/Makefile.in
10 @@ -206,7 +206,7 @@ LIBGCTP = $(top_builddir)/gctp/src/libGctp.la
11 @TESTDRIVERS_CONDITIONAL_TRUE@TESTDRIVERS = testdrivers
12 @INSTALL_INCLUDE_CONDITIONAL_FALSE@INCLUDE =
13 @INSTALL_INCLUDE_CONDITIONAL_TRUE@INCLUDE = include
14 -SUBDIRS = gctp src $(INCLUDE) samples $(TESTDRIVERS)
15 +SUBDIRS = src $(INCLUDE) samples $(TESTDRIVERS)
16 all: all-recursive
17
18 .SUFFIXES:
19 diff --git a/include/Makefile.in b/include/Makefile.in
20 index 9938b23..afb7f40 100644
21 --- a/include/Makefile.in
22 +++ b/include/Makefile.in
23 @@ -190,7 +190,7 @@ LIBGCTP = $(top_builddir)/gctp/src/libGctp.la
24 # Boilerplate include
25
26 # Headers to install
27 -include_HEADERS = HE2_config.h HdfEosDef.h HDFEOSVersion.h cfortHdf.h ease.h
28 +include_HEADERS = HdfEosDef.h HDFEOSVersion.h cfortHdf.h ease.h
29 all: HE2_config.h
30 $(MAKE) $(AM_MAKEFLAGS) all-am
31
32 diff --git a/samples/Makefile.in b/samples/Makefile.in
33 index 9da6e28..6a6186c 100644
34 --- a/samples/Makefile.in
35 +++ b/samples/Makefile.in
36 @@ -108,7 +108,6 @@ AppendField_SOURCES = AppendField.c
37 AppendField_OBJECTS = AppendField.$(OBJEXT)
38 AppendField_LDADD = $(LDADD)
39 am__DEPENDENCIES_1 = $(top_builddir)/src/libhdfeos.la
40 -am__DEPENDENCIES_2 = $(top_builddir)/gctp/src/libGctp.la
41 AppendField_DEPENDENCIES = $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_2)
42 DefineFields_SOURCES = DefineFields.c
43 DefineFields_OBJECTS = DefineFields.$(OBJEXT)
44 @@ -481,7 +480,7 @@ sharedstatedir = @sharedstatedir@
45 sysconfdir = @sysconfdir@
46 target_alias = @target_alias@
47 LIBHDFEOS2 = $(top_builddir)/src/libhdfeos.la
48 -LIBGCTP = $(top_builddir)/gctp/src/libGctp.la
49 +LIBGCTP =
50
51 # Boilerplate definitions file
52
53 --
54 2.10.0
55