gnu: python-pyqt: Fix build for new python-sip.
[jackhill/guix/guix.git] / gnu / packages / patches / dstat-skip-devices-without-io.patch
1 From: Tobias Geerinckx-Rice <me@tobias.gr>
2 Date: Sun, 16 Jun 2019 02:36:23 +0200
3 Subject: [PATCH] gnu: dstat: Skip devices without I/O.
4
5 Taken verbatim from a pull request[0] that will never be merged.
6
7 [0]: https://github.com/dagwieers/dstat/pull/164
8
9 From 0988589ea4ee092b285bd4049d56add5f61e3f69 Mon Sep 17 00:00:00 2001
10 From: Tobias Gruetzmacher <tobias-git@23.gs>
11 Date: Fri, 15 Feb 2019 18:46:57 +0100
12 Subject: [PATCH] Skip devices without I/O
13
14 Linux 4.18+ has added more fields to the diskstats proc file, so the
15 original skip condition for devices without I/O didn't apply anymore.
16 ---
17 dstat | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20 diff --git a/dstat b/dstat
21 index 9359965..5c2fb53 100755
22 --- a/dstat
23 +++ b/dstat
24 @@ -763,7 +763,7 @@ class dstat_disk(dstat):
25 ret = []
26 for l in self.splitlines():
27 if len(l) < 13: continue
28 - if l[3:] == ['0',] * 11: continue
29 + if l[3:] == ['0',] * (len(l) - 3): continue
30 name = l[2]
31 ret.append(name)
32 for item in objlist: ret.append(item)