gnu: fish: Update to 2.7.1.
[jackhill/guix/guix.git] / gnu / packages / ssh.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
5 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
7 ;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
8 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
9 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
10 ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
11 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
12 ;;;
13 ;;; This file is part of GNU Guix.
14 ;;;
15 ;;; GNU Guix is free software; you can redistribute it and/or modify it
16 ;;; under the terms of the GNU General Public License as published by
17 ;;; the Free Software Foundation; either version 3 of the License, or (at
18 ;;; your option) any later version.
19 ;;;
20 ;;; GNU Guix is distributed in the hope that it will be useful, but
21 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
22 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
23 ;;; GNU General Public License for more details.
24 ;;;
25 ;;; You should have received a copy of the GNU General Public License
26 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
27
28 (define-module (gnu packages ssh)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages autotools)
31 #:use-module (gnu packages base)
32 #:autoload (gnu packages boost) (boost)
33 #:use-module (gnu packages compression)
34 #:use-module (gnu packages crypto)
35 #:use-module (gnu packages elf)
36 #:use-module (gnu packages gnupg)
37 #:use-module (gnu packages gperf)
38 #:use-module (gnu packages groff)
39 #:use-module (gnu packages guile)
40 #:use-module (gnu packages linux)
41 #:use-module (gnu packages logging)
42 #:use-module (gnu packages m4)
43 #:use-module (gnu packages multiprecision)
44 #:use-module (gnu packages ncurses)
45 #:use-module (gnu packages nettle)
46 #:use-module (gnu packages kerberos)
47 #:use-module (gnu packages perl)
48 #:use-module (gnu packages pkg-config)
49 #:use-module (gnu packages popt)
50 #:autoload (gnu packages protobuf) (protobuf)
51 #:use-module (gnu packages readline)
52 #:use-module (gnu packages texinfo)
53 #:use-module (gnu packages tls)
54 #:use-module (gnu packages xorg)
55 #:use-module (guix build-system cmake)
56 #:use-module (guix build-system gnu)
57 #:use-module (guix download)
58 #:use-module (guix git-download)
59 #:use-module ((guix licenses) #:prefix license:)
60 #:use-module (guix packages)
61 #:use-module (srfi srfi-1))
62
63 (define-public libssh
64 (package
65 (name "libssh")
66 (version "0.7.5")
67 (source (origin
68 (method url-fetch)
69 (uri (string-append
70 "https://red.libssh.org/attachments/download/218/libssh-"
71 version ".tar.xz"))
72 (sha256
73 (base32
74 "15bh6dm9c50ndddzh3gqcgw7axp3ghrspjpkb1z3dr90vkanvs2l"))
75 (patches (search-patches "libssh-hostname-parser-bug.patch"))))
76 (build-system cmake-build-system)
77 (outputs '("out" "debug"))
78 (arguments
79 '(#:configure-flags '("-DWITH_GCRYPT=ON")
80
81 ;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
82 #:tests? #f))
83 (inputs `(("zlib" ,zlib)
84 ("libgcrypt" ,libgcrypt)))
85 (synopsis "SSH client library")
86 (description
87 "libssh is a C library implementing the SSHv2 and SSHv1 protocol for
88 client and server implementations. With libssh, you can remotely execute
89 programs, transfer files, and use a secure and transparent tunnel for your
90 remote applications.")
91 (home-page "https://www.libssh.org")
92 (license license:lgpl2.1+)))
93
94 (define-public libssh2
95 (package
96 (name "libssh2")
97 (version "1.8.0")
98 (source (origin
99 (method url-fetch)
100 (uri (string-append
101 "https://www.libssh2.org/download/libssh2-"
102 version ".tar.gz"))
103 (sha256
104 (base32
105 "1m3n8spv79qhjq4yi0wgly5s5rc8783jb1pyra9bkx1md0plxwrr"))
106 (patches
107 (search-patches "libssh2-fix-build-failure-with-gcrypt.patch"))))
108 (build-system gnu-build-system)
109 ;; The installed libssh2.pc file does not include paths to libgcrypt and
110 ;; zlib libraries, so we need to propagate the inputs.
111 (propagated-inputs `(("libgcrypt" ,libgcrypt)
112 ("zlib" ,zlib)))
113 (arguments '(#:configure-flags `("--with-libgcrypt")
114 #:phases (modify-phases %standard-phases
115 (add-before 'configure 'autoreconf
116 (lambda _
117 (zero? (system* "autoreconf" "-v")))))))
118 (native-inputs `(("autoconf" ,autoconf)
119 ("automake" ,automake)))
120 (synopsis "Client-side C library implementing the SSH2 protocol")
121 (description
122 "libssh2 is a library intended to allow software developers access to
123 the SSH-2 protocol in an easy-to-use self-contained package. It can be built
124 into an application to perform many different tasks when communicating with
125 a server that supports the SSH-2 protocol.")
126 (license license:bsd-3)
127 (home-page "http://www.libssh2.org/")))
128
129 (define-public openssh
130 (package
131 (name "openssh")
132 (version "7.6p1")
133 (source (origin
134 (method url-fetch)
135 (uri (string-append "mirror://openbsd/OpenSSH/portable/"
136 name "-" version ".tar.gz"))
137 (sha256
138 (base32
139 "08qpsb8mrzcx8wgvz9insiyvq7sbg26yj5nvl2m5n57yvppcl8x3"))))
140 (build-system gnu-build-system)
141 (native-inputs `(("groff" ,groff)))
142 (inputs `(("openssl" ,openssl)
143 ("pam" ,linux-pam)
144 ("mit-krb5" ,mit-krb5)
145 ("zlib" ,zlib)
146 ("xauth" ,xauth))) ;for 'ssh -X' and 'ssh -Y'
147 (arguments
148 `(#:test-target "tests"
149 #:configure-flags `("--sysconfdir=/etc/ssh"
150
151 ;; Default value of 'PATH' used by sshd.
152 "--with-default-path=/run/current-system/profile/bin"
153
154 ;; configure needs to find krb5-config
155 ,(string-append "--with-kerberos5="
156 (assoc-ref %build-inputs "mit-krb5")
157 "/bin")
158
159 ;; Enable PAM support in sshd.
160 "--with-pam")
161
162 #:phases
163 (modify-phases %standard-phases
164 (add-after 'configure 'reset-/var/empty
165 (lambda* (#:key outputs #:allow-other-keys)
166 (let ((out (assoc-ref outputs "out")))
167 (substitute* "Makefile"
168 (("PRIVSEP_PATH=/var/empty")
169 (string-append "PRIVSEP_PATH=" out "/var/empty")))
170 #t)))
171 (add-before 'check 'patch-tests
172 (lambda _
173 ;; remove 't-exec' regress target which requires user 'sshd'
174 (substitute* "regress/Makefile"
175 (("^(REGRESS_TARGETS=.*) t-exec(.*)" all pre post)
176 (string-append pre post)))
177 #t))
178 (replace 'install
179 (lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
180 ;; install without host keys and system configuration files
181 (and (zero? (apply system* "make" "install-nosysconf" make-flags))
182 (begin
183 (install-file "contrib/ssh-copy-id"
184 (string-append (assoc-ref outputs "out")
185 "/bin/"))
186 (chmod (string-append (assoc-ref outputs "out")
187 "/bin/ssh-copy-id") #o555)
188 (install-file "contrib/ssh-copy-id.1"
189 (string-append (assoc-ref outputs "out")
190 "/share/man/man1/"))
191 #t)))))))
192 (synopsis "Client and server for the secure shell (ssh) protocol")
193 (description
194 "The SSH2 protocol implemented in OpenSSH is standardised by the
195 IETF secsh working group and is specified in several RFCs and drafts.
196 It is composed of three layered components:
197
198 The transport layer provides algorithm negotiation and a key exchange.
199 The key exchange includes server authentication and results in a
200 cryptographically secured connection: it provides integrity, confidentiality
201 and optional compression.
202
203 The user authentication layer uses the established connection and relies on
204 the services provided by the transport layer. It provides several mechanisms
205 for user authentication. These include traditional password authentication
206 as well as public-key or host-based authentication mechanisms.
207
208 The connection layer multiplexes many different concurrent channels over the
209 authenticated connection and allows tunneling of login sessions and
210 TCP-forwarding. It provides a flow control service for these channels.
211 Additionally, various channel-specific options can be negotiated.")
212 (license (license:non-copyleft "file://LICENSE"
213 "See LICENSE in the distribution."))
214 (home-page "http://www.openssh.org/")))
215
216 (define-public guile-ssh
217 (package
218 (name "guile-ssh")
219 (version "0.11.2")
220 (home-page "https://github.com/artyom-poptsov/guile-ssh")
221 (source (origin
222 ;; ftp://memory-heap.org/software/guile-ssh/guile-ssh-VERSION.tar.gz
223 ;; exists, but the server appears to be too slow and unreliable.
224 ;; Also, using this URL allows the GitHub updater to work.
225 (method url-fetch)
226 (uri (string-append home-page "/archive/v"
227 version ".tar.gz"))
228 (file-name (string-append name "-" version ".tar.gz"))
229 (sha256
230 (base32
231 "1w0k5s09xj5xycb7lbp5b7rm0xncclms3jwl98lwj8fxwngi1s90"))))
232 (build-system gnu-build-system)
233 (outputs '("out" "debug"))
234 (arguments
235 '(#:phases (modify-phases %standard-phases
236 (add-after 'unpack 'autoreconf
237 (lambda* (#:key inputs #:allow-other-keys)
238 (zero? (system* "autoreconf" "-vfi"))))
239 (add-before 'build 'fix-libguile-ssh-file-name
240 (lambda* (#:key outputs #:allow-other-keys)
241 ;; Build and install libguile-ssh.so so that we can use
242 ;; its absolute file name in .scm files, before we build
243 ;; the .go files.
244 (and (zero? (system* "make" "install"
245 "-C" "libguile-ssh"
246 "-j" (number->string
247 (parallel-job-count))))
248 (let* ((out (assoc-ref outputs "out"))
249 (libdir (string-append out "/lib")))
250 (substitute* (find-files "." "\\.scm$")
251 (("\"libguile-ssh\"")
252 (string-append "\"" libdir "/libguile-ssh\"")))
253 #t)))))
254
255 ;; Tests are not parallel-safe.
256 #:parallel-tests? #f))
257 (native-inputs `(("autoconf" ,autoconf)
258 ("automake" ,automake)
259 ("libtool" ,libtool)
260 ("texinfo" ,texinfo)
261 ("pkg-config" ,pkg-config)
262 ("which" ,which)))
263 (inputs `(("guile" ,guile-2.2)
264 ("libssh" ,libssh)
265 ("libgcrypt" ,libgcrypt)))
266 (synopsis "Guile bindings to libssh")
267 (description
268 "Guile-SSH is a library that provides access to the SSH protocol for
269 programs written in GNU Guile interpreter. It is a wrapper to the underlying
270 libssh library.")
271 (license license:gpl3+)))
272
273 (define-public guile2.2-ssh
274 (deprecated-package "guile2.2-ssh" guile-ssh))
275
276 (define-public guile2.0-ssh
277 (package
278 (inherit guile-ssh)
279 (name "guile2.0-ssh")
280 (inputs `(("guile" ,guile-2.0)
281 ,@(alist-delete "guile" (package-inputs guile-ssh))))))
282
283 (define-public corkscrew
284 (package
285 (name "corkscrew")
286 (version "2.0")
287 (source
288 (origin
289 (method url-fetch)
290 ;; The agroman.net domain name expired on 2017-03-23, and the original
291 ;; "http://www.agroman.net/corkscrew/corkscrew-2.0.tar.gz" now returns
292 ;; bogus HTML. Perhaps it will yet return. Until then, use a mirror.
293 (uri (string-append "https://downloads.openwrt.org/sources/"
294 "corkscrew-" version ".tar.gz"))
295 (sha256 (base32
296 "1gmhas4va6gd70i2x2mpxpwpgww6413mji29mg282jms3jscn3qd"))))
297 (build-system gnu-build-system)
298 (arguments
299 ;; Replace configure phase as the ./configure script does not link
300 ;; CONFIG_SHELL and SHELL passed as parameters
301 '(#:phases
302 (modify-phases %standard-phases
303 (replace 'configure
304 (lambda* (#:key outputs inputs system build target
305 #:allow-other-keys #:rest args)
306 (let* ((configure (assoc-ref %standard-phases 'configure))
307 (prefix (assoc-ref outputs "out"))
308 (bash (which "bash"))
309 ;; Set --build and --host flags as the provided config.guess
310 ;; is not able to detect them
311 (flags `(,(string-append "--prefix=" prefix)
312 ,(string-append "--build=" build)
313 ,(string-append "--host=" (or target build)))))
314 (setenv "CONFIG_SHELL" bash)
315 (zero? (apply system* bash
316 (string-append "." "/configure")
317 flags)))))
318 (add-after 'install 'install-documentation
319 (lambda* (#:key outputs #:allow-other-keys)
320 (let* ((out (assoc-ref outputs "out"))
321 (doc (string-append out "/share/doc/corkscrew")))
322 (install-file "README" doc)
323 #t))))))
324 (home-page "http://www.agroman.net/corkscrew")
325 (synopsis "SSH tunneling through HTTP(S) proxies")
326 (description
327 "Corkscrew tunnels SSH connections through most HTTP and HTTPS proxies.
328 Proxy authentication is only supported through the plain-text HTTP basic
329 authentication scheme.")
330 (license license:gpl2+)))
331
332 (define-public mosh
333 (package
334 (name "mosh")
335 (version "1.3.2")
336 (source (origin
337 (method url-fetch)
338 (uri (string-append "https://mosh.org/mosh-" version ".tar.gz"))
339 (sha256
340 (base32
341 "05hjhlp6lk8yjcy59zywpf0r6s0h0b9zxq0lw66dh9x8vxrhaq6s"))))
342 (build-system gnu-build-system)
343 (arguments
344 '(#:phases
345 (modify-phases %standard-phases
346 (add-after 'install 'wrap
347 (lambda* (#:key outputs #:allow-other-keys)
348 ;; Make sure 'mosh' can find 'mosh-client' and
349 ;; 'mosh-server'.
350 (let* ((out (assoc-ref outputs "out"))
351 (bin (string-append out "/bin")))
352 (wrap-program (string-append bin "/mosh")
353 `("PATH" ":" prefix (,bin)))))))))
354 (native-inputs
355 `(("pkg-config" ,pkg-config)))
356 (inputs
357 `(("openssl" ,openssl)
358 ("perl" ,perl)
359 ("perl-io-tty" ,perl-io-tty)
360 ("zlib" ,zlib)
361 ("ncurses" ,ncurses)
362 ("protobuf" ,protobuf)
363 ("boost-headers" ,boost)))
364 (home-page "https://mosh.org/")
365 (synopsis "Remote shell tolerant to intermittent connectivity")
366 (description
367 "Remote terminal application that allows roaming, supports intermittent
368 connectivity, and provides intelligent local echo and line editing of user
369 keystrokes. Mosh is a replacement for SSH. It's more robust and responsive,
370 especially over Wi-Fi, cellular, and long-distance links.")
371 (license license:gpl3+)))
372
373 (define-public et
374 (package
375 (name "et")
376 (version "3.1.0")
377 (source
378 (origin
379 (method url-fetch)
380 (uri (string-append
381 "https://github.com/MisterTea/EternalTCP/archive/et-v"
382 version ".tar.gz"))
383 (sha256
384 (base32 "1n2w2kqbshdmbb0gz4yizyw9gqfls6qm2dnwx1d9c2hz7hmi7521"))))
385 (build-system cmake-build-system)
386 (arguments `(#:tests? #f))
387 (native-inputs
388 `(("pkg-config" ,pkg-config)))
389 (inputs `(("glog" ,glog)
390 ("gflags" ,gflags)
391 ("libsodium" ,libsodium)
392 ("protobuf" ,protobuf)))
393 (synopsis "Remote shell that automatically reconnects")
394 (description
395 "Eternal Terminal (ET) is a remote shell that automatically reconnects
396 without interrupting the session. Unlike SSH sessions, ET sessions will
397 survive even network outages and IP changes. ET uses a custom protocol over
398 TCP, not the SSH protocol.")
399 (home-page "https://mistertea.github.io/EternalTCP/")
400 (license license:asl2.0)))
401
402 (define-public dropbear
403 (package
404 (name "dropbear")
405 (version "2017.75")
406 (source (origin
407 (method url-fetch)
408 (uri (string-append
409 "https://matt.ucc.asn.au/" name "/releases/"
410 name "-" version ".tar.bz2"))
411 (sha256
412 (base32
413 "1309cm2aw62n9m3h38prvgsqr8bj85hfasgnvwkd42cp3k5ivg3c"))))
414 (build-system gnu-build-system)
415 (arguments `(#:tests? #f)) ; There is no "make check" or anything similar
416 (inputs `(("zlib" ,zlib)))
417 (synopsis "Small SSH server and client")
418 (description "Dropbear is a relatively small SSH server and
419 client. It runs on a variety of POSIX-based platforms. Dropbear is
420 particularly useful for embedded systems, such as wireless routers.")
421 (home-page "https://matt.ucc.asn.au/dropbear/dropbear.html")
422 (license (license:x11-style "" "See file LICENSE."))))
423
424 (define-public liboop
425 (package
426 (name "liboop")
427 (version "1.0")
428 (source
429 (origin
430 (method url-fetch)
431 (uri (string-append "http://download.ofb.net/liboop/liboop-"
432 version ".tar.gz"))
433 (sha256
434 (base32
435 "0z6rlalhvfca64jpvksppc9bdhs7jwhiw4y35g5ibvh91xp3rn1l"))
436 (patches (search-patches "liboop-mips64-deplibs-fix.patch"))))
437 (build-system gnu-build-system)
438 (home-page "http://www.lysator.liu.se/liboop/")
439 (synopsis "Event loop library")
440 (description "Liboop is a low-level event loop management library for
441 POSIX-based operating systems. It supports the development of modular,
442 multiplexed applications which may respond to events from several sources. It
443 replaces the \"select() loop\" and allows the registration of event handlers
444 for file and network I/O, timers and signals. Since processes use these
445 mechanisms for almost all external communication, liboop can be used as the
446 basis for almost any application.")
447 (license license:lgpl2.1+)))
448
449 (define-public lsh
450 (package
451 (name "lsh")
452 (version "2.1")
453 (source (origin
454 (method url-fetch)
455 (uri (string-append "mirror://gnu/lsh/lsh-"
456 version ".tar.gz"))
457 (sha256
458 (base32
459 "1qqjy9zfzgny0rkb27c8c7dfsylvb6n0ld8h3an2r83pmaqr9gwb"))
460 (modules '((guix build utils)))
461 (snippet
462 '(begin
463 (substitute* "src/testsuite/functions.sh"
464 (("localhost")
465 ;; Avoid host name lookups since they don't work in
466 ;; chroot builds.
467 "127.0.0.1")
468 (("set -e")
469 ;; Make tests more verbose.
470 "set -e\nset -x"))
471
472 (substitute* (find-files "src/testsuite" "-test$")
473 (("localhost") "127.0.0.1"))
474
475 (substitute* "src/testsuite/login-auth-test"
476 (("/bin/cat") "cat"))))))
477 (build-system gnu-build-system)
478 (native-inputs
479 `(("m4" ,m4)
480 ("guile" ,guile-2.0)
481 ("gperf" ,gperf)
482 ("psmisc" ,psmisc))) ; for `killall'
483 (inputs
484 `(("nettle" ,nettle-2)
485 ("linux-pam" ,linux-pam)
486
487 ;; 'rl.c' uses the 'CPPFunction' type, which is no longer in
488 ;; Readline 6.3.
489 ("readline" ,readline-6.2)
490
491 ("liboop" ,liboop)
492 ("zlib" ,zlib)
493 ("gmp" ,gmp)
494
495 ;; The server (lshd) invokes xauth when X11 forwarding is requested.
496 ;; This adds 24 MiB (or 27%) to the closure of lsh.
497 ("xauth" ,xauth)))
498 (arguments
499 '(;; Skip the `configure' test that checks whether /dev/ptmx &
500 ;; co. work as expected, because it relies on impurities (for
501 ;; instance, /dev/pts may be unavailable in chroots.)
502 #:configure-flags '("lsh_cv_sys_unix98_ptys=yes"
503
504 ;; Use glibc's argp rather than the bundled one.
505 "--with-system-argp"
506
507 ;; 'lsh_argp.h' checks HAVE_ARGP_PARSE but nothing
508 ;; defines it.
509 "CPPFLAGS=-DHAVE_ARGP_PARSE")
510
511 ;; FIXME: Tests won't run in a chroot, presumably because
512 ;; /etc/profile is missing, and thus clients get an empty $PATH
513 ;; and nothing works.
514 #:tests? #f
515
516 #:phases
517 (modify-phases %standard-phases
518 (add-before 'configure 'pre-configure
519 (lambda* (#:key inputs #:allow-other-keys)
520 (let* ((nettle (assoc-ref inputs "nettle"))
521 (sexp-conv (string-append nettle "/bin/sexp-conv")))
522 ;; Remove argp from the list of sub-directories; we don't want
523 ;; to build it, really.
524 (substitute* "src/Makefile.in"
525 (("^SUBDIRS = argp")
526 "SUBDIRS ="))
527
528 ;; Make sure 'lsh' and 'lshd' pick 'sexp-conv' in the right place
529 ;; by default.
530 (substitute* "src/environ.h.in"
531 (("^#define PATH_SEXP_CONV.*")
532 (string-append "#define PATH_SEXP_CONV \""
533 sexp-conv "\"\n")))
534
535 ;; Same for the 'lsh-authorize' script.
536 (substitute* "src/lsh-authorize"
537 (("=sexp-conv")
538 (string-append "=" sexp-conv)))
539
540 ;; Tell lshd where 'xauth' lives. Another option would be to
541 ;; hardcode "/run/current-system/profile/bin/xauth", thereby
542 ;; reducing the closure size, but that wouldn't work on foreign
543 ;; distros.
544 (with-fluids ((%default-port-encoding "ISO-8859-1"))
545 (substitute* "src/server_x11.c"
546 (("define XAUTH_PROGRAM.*")
547 (string-append "define XAUTH_PROGRAM \""
548 (assoc-ref inputs "xauth")
549 "/bin/xauth\"\n")))))
550
551 ;; Tests rely on $USER being set.
552 (setenv "USER" "guix"))))))
553 (home-page "http://www.lysator.liu.se/~nisse/lsh/")
554 (synopsis "GNU implementation of the Secure Shell (ssh) protocols")
555 (description
556 "GNU lsh is a free implementation of the SSH version 2 protocol. It is
557 used to create a secure line of communication between two computers,
558 providing shell access to the server system from the client. It provides
559 both the server daemon and the client application, as well as tools for
560 manipulating key files.")
561 (license license:gpl2+)))
562
563 (define-public sshpass
564 (package
565 (name "sshpass")
566 (version "1.06")
567 (synopsis "Non-interactive password authentication with SSH")
568 (home-page "https://sourceforge.net/projects/sshpass/")
569 (source
570 (origin
571 (method url-fetch)
572 (uri (string-append "mirror://sourceforge/sshpass/sshpass/"
573 version "/sshpass-" version ".tar.gz"))
574 (sha256
575 (base32
576 "0q7fblaczb7kwbsz0gdy9267z0sllzgmf0c7z5c9mf88wv74ycn6"))))
577 (build-system gnu-build-system)
578 (description "sshpass is a tool for non-interactivly performing password
579 authentication with SSH's so-called @dfn{interactive keyboard password
580 authentication}.")
581 (license license:gpl2+)))
582
583 (define-public autossh
584 (package
585 (name "autossh")
586 (version "1.4e")
587 (source
588 (origin
589 (method url-fetch)
590 (uri (string-append
591 "http://www.harding.motd.ca/autossh/autossh-"
592 version ".tgz"))
593 (sha256
594 (base32 "0mlicw28vq2jxa0jf0dys5ja75v0fxpjavlq9dpif6bnknji13ly"))))
595 (build-system gnu-build-system)
596 (arguments `(#:tests? #f)) ; There is no "make check" or anything similar
597 (inputs `(("openssh" ,openssh)))
598 (synopsis "Automatically restart SSH sessions and tunnels")
599 (description "autossh is a program to start a copy of @command{ssh} and
600 monitor it, restarting it as necessary should it die or stop passing traffic.")
601 (home-page "http://www.harding.motd.ca/autossh/")
602 (license
603 ;; Why point to a source file? Well, all the individual files have a
604 ;; copy of this license in their headers, but there's no separate file
605 ;; with that information.
606 (license:non-copyleft "file://autossh.c"))))
607
608 (define-public pdsh
609 (package
610 (name "pdsh")
611 (version "2.29")
612 (source
613 (origin
614 (method url-fetch)
615 (uri (string-append "https://storage.googleapis.com/"
616 "google-code-archive-downloads/v2/code.google.com/"
617 "pdsh/pdsh-" version ".tar.bz2"))
618 (sha256
619 (base32 "1kvzz01fyaxfqmbh53f4ljfsgvxdykh5jyr6fh4f1bw2ywxr1w2p"))))
620 (build-system gnu-build-system)
621 (arguments
622 `(#:configure-flags
623 (list "--with-ssh")
624 #:phases
625 (modify-phases %standard-phases
626 (add-after 'unpack 'patch-/bin/sh
627 (lambda _
628 (substitute* '("tests/runtests.sh"
629 "tests/test-lib.sh"
630 "tests/test-modules/pcptest.c")
631 (("/bin/sh") (which "bash")))
632 #t)))))
633 (inputs
634 `(("openssh" ,openssh)
635 ("mit-krb5" ,mit-krb5)
636 ("perl" ,perl)))
637 (home-page "https://code.google.com/archive/p/pdsh")
638 (synopsis "Parallel distributed shell")
639 (description "Pdsh is a an efficient, multithreaded remote shell client
640 which executes commands on multiple remote hosts in parallel. Pdsh implements
641 dynamically loadable modules for extended functionality such as new remote
642 shell services and remote host selection.")
643 (license license:gpl2+)))