gnu: fish: Update to 2.7.1.
[jackhill/guix/guix.git] / gnu / packages / irc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
4 ;;; Copyright © 2015, 2017 Ludovic Courtès <ludo@gnu.org>
5 ;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016 ng0 <ng0@infotropique.org>
7 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
8 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages irc)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix download)
28 #:use-module (guix packages)
29 #:use-module (guix build-system cmake)
30 #:use-module (guix build-system gnu)
31 #:use-module (guix build-system python)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages aspell)
34 #:use-module (gnu packages autogen)
35 #:use-module (gnu packages autotools)
36 #:use-module (gnu packages base)
37 #:use-module (gnu packages backup)
38 #:use-module (gnu packages check)
39 #:use-module (gnu packages compression)
40 #:use-module (gnu packages curl)
41 #:use-module (gnu packages cyrus-sasl)
42 #:use-module (gnu packages databases)
43 #:use-module (gnu packages file)
44 #:use-module (gnu packages gettext)
45 #:use-module (gnu packages glib)
46 #:use-module (gnu packages gnupg)
47 #:use-module (gnu packages guile)
48 #:use-module (gnu packages lua)
49 #:use-module (gnu packages ncurses)
50 #:use-module (gnu packages kde)
51 #:use-module (gnu packages kde-frameworks)
52 #:use-module (gnu packages perl)
53 #:use-module (gnu packages pkg-config)
54 #:use-module (gnu packages python)
55 #:use-module (gnu packages python-crypto)
56 #:use-module (gnu packages ruby)
57 #:use-module (gnu packages qt)
58 #:use-module (gnu packages tcl)
59 #:use-module (gnu packages time)
60 #:use-module (gnu packages tls)
61 #:use-module (gnu packages web))
62
63 (define-public quassel
64 (package
65 (name "quassel")
66 (version "0.12.4")
67 (source
68 (origin
69 (method url-fetch)
70 (uri (string-append "http://quassel-irc.org/pub/quassel-"
71 version ".tar.bz2"))
72 (patches (search-patches "quassel-fix-tls-check.patch"))
73 (sha256
74 (base32
75 "0ka456fb8ha3w7g74xlzfg6w4azxjjxgrhl4aqpbwg3lnd6fbr4k"))
76 (modules '((guix build utils)))
77 ;; We don't want to install the bundles scripts
78 (snippet
79 '(begin
80 (delete-file-recursively "data/scripts")
81 (substitute* "data/CMakeLists.txt"
82 (("NOT WIN32") "WIN32"))))))
83 (build-system cmake-build-system)
84 (arguments
85 ;; The three binaries are not mutually exlusive, and are all built
86 ;; by default.
87 '(#:configure-flags '(;;"-DWANT_QTCLIENT=OFF" ; 5.2 MiB
88 ;;"-DWANT_CORE=OFF" ; 2.4 MiB
89 ;;"-DWANT_MONO=OFF" ; 6.4 MiB
90 "-DUSE_QT5=ON" ; default is qt4
91 "-DWITH_KDE=OFF" ; no to kde integration ...
92 "-DWITH_OXYGEN=ON" ; therefore we install bundled icons
93 "-DWITH_WEBKIT=OFF") ; qtwebkit isn't packaged
94 #:tests? #f)) ; no test target
95 (native-inputs
96 `(("extra-cmake-modules" ,extra-cmake-modules)
97 ("pkg-config" ,pkg-config)
98 ("qttools" ,qttools)))
99 (inputs
100 `(("qca" ,qca)
101 ("qtbase", qtbase)
102 ("qtscript" ,qtscript)
103 ("snorenotify" ,snorenotify)
104 ("zlib" ,zlib)))
105 (home-page "http://quassel-irc.org/")
106 (synopsis "Distributed IRC client")
107 (description "Quassel is a distributed IRC client, meaning that one or more
108 clients can attach to and detach from the central core. It resembles the
109 popular combination of screen and a text-based IRC client such as WeeChat or
110 irssi, but graphical.")
111 (license (list license:gpl2 license:gpl3)))) ;; dual licensed
112
113 (define-public irssi
114 (package
115 (name "irssi")
116 (version "1.0.5")
117 (source (origin
118 (method url-fetch)
119 (uri (string-append "https://github.com/irssi/irssi/"
120 "releases/download/" version "/irssi-"
121 version ".tar.xz"))
122 (sha256
123 (base32
124 "055r9fhbfcfkzinsnprnlqd8psspdyn3j26lzsmnrc1fw4kn8mf2"))))
125 (build-system gnu-build-system)
126 (arguments
127 `(#:phases
128 (modify-phases %standard-phases
129 (replace 'configure
130 (lambda* (#:key inputs outputs #:allow-other-keys)
131 (let ((out (assoc-ref outputs "out")))
132 (setenv "CONFIG_SHELL" (which "bash"))
133 (zero?
134 (system* "./configure"
135 (string-append "--prefix=" out)
136 (string-append "--with-proxy")
137 (string-append "--with-socks")
138 (string-append "--with-bot")))))))))
139 (inputs
140 `(("glib" ,glib)
141 ("ncurses" ,ncurses)
142 ("openssl" ,openssl)
143 ("perl" ,perl)))
144 (native-inputs
145 `(("pkg-config" ,pkg-config)))
146 (home-page "https://irssi.org/")
147 (synopsis "Terminal-based IRC client")
148 (description
149 "Irssi is a terminal based IRC client for UNIX systems. It also supports
150 SILC and ICB protocols via plugins.")
151 (license license:gpl2+)))
152
153 (define-public weechat
154 (package
155 (name "weechat")
156 (version "2.0.1")
157 (source (origin
158 (method url-fetch)
159 (uri (string-append "https://weechat.org/files/src/weechat-"
160 version ".tar.xz"))
161 (sha256
162 (base32
163 "1l854dramvn9vfba7jpazkjwm4k4i5pshq58vjv6z2mxmcp5hhv9"))
164 (patches (search-patches "weechat-python.patch"))))
165 (build-system cmake-build-system)
166 (native-inputs
167 `(("gettext" ,gettext-minimal)
168 ("pkg-config" ,pkg-config)
169 ;; For tests.
170 ("cpputest" ,cpputest)))
171 (inputs `(("ncurses" ,ncurses)
172 ("libgcrypt" ,libgcrypt "out")
173 ("zlib" ,zlib)
174 ("aspell" ,aspell)
175 ("curl" ,curl)
176 ("gnutls" ,gnutls)
177 ("guile" ,guile-2.0)
178 ("lua" ,lua-5.1)
179 ("python" ,python-2)
180 ("perl" ,perl)
181 ("tcl" ,tcl)))
182 (arguments
183 `(#:configure-flags
184 (list "-DENABLE_TESTS=ON") ; ‘make test’ fails otherwise
185 #:phases
186 (modify-phases %standard-phases
187 (add-after 'unpack 'disable-failing-tests
188 ;; For reasons best left to the imagination, CppUTest cannot skip
189 ;; more than one single test... Resort to manual patching instead.
190 ;; See <https://cpputest.github.io/manual.html#command_line>.
191 (λ _
192 ;; Don't test plugin support for languages we don't enable.
193 (substitute* "tests/unit/test-plugins.cpp"
194 ((".*\\$\\{plugin.name\\} == (javascript|php|ruby)" all)
195 (string-append "// SKIP" all)))
196 (substitute* "tests/scripts/test-scripts.cpp"
197 ((".*\\{ \"(jvascript|php|ruby)\", " all) ; sic
198 (string-append "// SKIP" all)))
199 #t))
200 (add-after 'install 'wrap
201 (lambda* (#:key inputs outputs #:allow-other-keys)
202 (let ((out (assoc-ref outputs "out"))
203 (py2 (assoc-ref inputs "python")))
204 (wrap-program (string-append out "/bin/weechat")
205 `("PATH" ":" prefix (,(string-append py2 "/bin"))))
206 #t))))))
207 (synopsis "Extensible chat client")
208 (description "WeeChat (Wee Enhanced Environment for Chat) is an
209 @dfn{Internet Relay Chat} (IRC) client, which is designed to be light and fast.
210 The client uses a curses frontend, and there are remote interfaces for Web,
211 Qt, Android, and Emacs.
212
213 Everything in WeeChat can be done with the keyboard, though it also supports
214 using a mouse. It is customizable and extensible with plugins and scripts.")
215 (home-page "https://www.weechat.org/")
216 (license license:gpl3)))
217
218 (define-public ircii
219 (package
220 (name "ircii")
221 (version "20151120")
222 (source (origin
223 (method url-fetch)
224 (uri (string-append "https://ircii.warped.com/"
225 name "-" version ".tar.gz"))
226 (sha256
227 (base32
228 "178dc279f5j894qvp96dzz7c0jpryqlcqw5g0dc9yaxg9kgw1lqm"))))
229 (build-system gnu-build-system)
230 ;; TODO: We should package a small socks4/5 library/server to configure
231 ;; ircii with socks client. `ghc-socks' pulls in lots of haskell, which
232 ;; is too big.
233 (arguments
234 `(#:tests? #f
235 #:configure-flags (list
236 "--enable-ipv6"
237 "--with-emacs-meta-keys"
238 (string-append "--with-openssl="
239 (assoc-ref %build-inputs "openssl")))
240 #:phases
241 (modify-phases %standard-phases
242 (add-after 'unpack 'patch-bsdinstall-absolute-path-bins
243 (lambda* (#:key inputs #:allow-other-keys)
244 (substitute* "bsdinstall"
245 (("/bin/strip") "strip")
246 (("/bin/cp") "cp")
247 (("/bin/chmod") "chmod")
248 (("/etc/chown") "chown")
249 (("/bin/chgrp") "chgrp")
250 (("/bin/mkdir") "mkdir")
251 (("/bin/rm") "rm")
252 (("/bin/mv") "mv")))))))
253 (inputs
254 `(("ncurses" ,ncurses)
255 ("openssl" ,openssl)))
256 (native-inputs
257 `(("pkg-config" ,pkg-config)
258 ("perl" ,perl)))
259 (home-page "http://www.eterna.com.au/ircii/")
260 (synopsis "Terminal-based IRC and ICB client")
261 (description
262 "ircII is a terminal based IRC and ICB client for UNIX systems.")
263 (license license:bsd-3)))
264
265 (define-public ii
266 (package
267 (name "ii")
268 (version "1.7")
269 (source (origin
270 (method url-fetch)
271 (uri (string-append "http://dl.suckless.org/tools/"
272 name "-" version ".tar.gz"))
273 (sha256
274 (base32
275 "176cqwnn6h7w4kbfd66hzqa243l26pqp2b06bii0nmnm0rkaqwis"))))
276 (build-system gnu-build-system)
277 (arguments
278 `(#:tests? #f ; no tests
279 #:make-flags (list (string-append "PREFIX=" %output)
280 "CC=gcc")
281 #:phases
282 (modify-phases %standard-phases
283 (delete 'configure)))) ; no configure
284 (home-page "http://tools.suckless.org/ii/")
285 (synopsis "FIFO and file system based IRC client")
286 (description
287 "ii (Irc it) is a minimalist FIFO and file system based IRC client.")
288 (license license:expat)))
289
290 (define-public sic
291 (package
292 (name "sic")
293 (version "1.2")
294 (source (origin
295 (method url-fetch)
296 (uri (string-append "http://dl.suckless.org/tools/"
297 name "-" version ".tar.gz"))
298 (sha256
299 (base32
300 "11aiavxp44yayibc58bvimi8mrxvbw1plbci8cnbl4syk42zj1xc"))))
301 (build-system gnu-build-system)
302 (arguments
303 `(#:tests? #f ; no tests
304 #:make-flags (list "CC=gcc"
305 (string-append "PREFIX=" %output))
306 #:phases
307 (modify-phases %standard-phases
308 (delete 'configure)))) ; no configure
309 (home-page "http://tools.suckless.org/sic/")
310 (synopsis "Simple IRC client")
311 (description
312 "sic is a simple IRC client, even more minimalistic than ii.")
313 (license license:expat)))
314
315 (define-public limnoria
316 (package
317 (name "limnoria")
318 (version "2017.10.01")
319 (source
320 (origin
321 (method url-fetch)
322 (uri (pypi-uri "limnoria" version))
323 (sha256
324 (base32
325 "1hd8h257x7a0s4rvb4aqvfi77qfcyv6jaz70nndg7y6p4yhvjmy6"))))
326 (build-system python-build-system)
327 (inputs
328 `(("python-pytz" ,python-pytz)
329 ("python-chardet" ,python-chardet)
330 ("python-dateutil" ,python-dateutil)
331 ("python-gnupg" ,python-gnupg)
332 ("python-feedparser" ,python-feedparser)
333 ("python-sqlalchemy" ,python-sqlalchemy)
334 ("python-socksipy-branch" ,python-socksipy-branch)
335 ("python-ecdsa" ,python-ecdsa)))
336 (native-inputs
337 `(("python-mock" ,python-mock)))
338 ;; Despite the existence of a test folder there is no test phase.
339 ;; We need to package https://github.com/ProgVal/irctest and write
340 ;; our own testphase.
341 (arguments
342 `(#:tests? #f))
343 (home-page "https://github.com/ProgVal/Limnoria")
344 (synopsis "Modified version of Supybot (an IRC bot and framework)")
345 (description
346 "Modified version of Supybot with Python 3 and IRCv3 support,
347 embedded web server, translations (fr, fi, it, hu, de), and many
348 other enhancements and bug fixes.")
349 (license license:bsd-3)))
350
351 (define-public epic5
352 (package
353 (name "epic5")
354 (version "2.0.1")
355 (source (origin
356 (method url-fetch)
357 (uri (string-append "http://ftp.epicsol.org/pub/"
358 "epic/EPIC5-PRODUCTION/"
359 name "-" version ".tar.xz"))
360 (sha256
361 (base32
362 "1ap73d5f4vccxjaaq249zh981z85106vvqmxfm4plvy76b40y9jm"))))
363 (build-system gnu-build-system)
364 (arguments
365 `(#:test-target "test"
366 #:phases
367 (modify-phases %standard-phases
368 (add-after 'unpack 'patch-perl
369 (lambda _
370 (substitute* "regress/crash-irc"
371 (("perl5") (which "perl")))
372 #t))
373 (add-after 'unpack 'patch-bsdinstall
374 ;; If we just remove /bin/ some part of the bsdinstall breaks.
375 ;; Furthermore bsdinstalls has a reference to /etc/chmod here, which
376 ;; means if we leave /etc/ in, install fails.
377 (lambda _
378 (substitute* "bsdinstall"
379 (("/bin/strip") "strip")
380 (("/bin/cp") "cp")
381 (("/bin/chmod") "chmod")
382 (("/bin/chgrp") "chgrp")
383 (("/bin/mkdir") "mkdir")
384 (("/bin/rm") "rm")
385 (("/bin/mv") "mv")
386 (("/etc/") ""))
387 #t))
388 (replace 'configure
389 (lambda* (#:key outputs #:allow-other-keys)
390 ;; The tarball uses a very old version of autconf. It does not
391 ;; understand extra flags like `--enable-fast-install', so
392 ;; we need to invoke it with just what it understands.
393 (let ((out (assoc-ref outputs "out")))
394 ;; 'configure' doesn't understand '--host'.
395 ,@(if (%current-target-system)
396 `((setenv "CHOST" ,(%current-target-system)))
397 '())
398 (setenv "CONFIG_SHELL" (which "bash"))
399 (setenv "SHELL" (which "bash"))
400 (zero?
401 (system* "./configure"
402 (string-append "--prefix=" out)
403 "--with-ipv6" "--with-libarchive"
404 ;; We use libressl because openssl does not come
405 ;; with the lib/libssl.a which is needed for epic5.
406 ;; XXX: No matter which implementation is chosen,
407 ;; epic5 fails to connect to tls ports of roundrobin
408 ;; irc networks. This however is believed to be an
409 ;; protocol issue at epic5 related to ircd.
410 (string-append "--with-ssl="
411 (assoc-ref %build-inputs "libressl"))
412 (string-append "--with-tcl="
413 (assoc-ref %build-inputs "tcl")
414 "/lib/tclConfig.sh")))))))))
415 (inputs
416 `(("libressl" ,libressl)
417 ("ncurses" ,ncurses)
418 ("libarchive" ,libarchive) ; CHANGELOG: "Support for loading zip files"
419 ("perl" ,perl)
420 ("tcl" ,tcl)
421 ("ruby" ,ruby)))
422 (native-inputs
423 `(("pkg-config" ,pkg-config)))
424 (home-page "http://epicsol.org")
425 (synopsis "Epic5 IRC Client")
426 (description
427 "EPIC is a IRC client that has been under active development for
428 over 20 years. It is stable and mature, and offers an excellent ircII
429 interface for those who are accustomed to the ircII way of doing things.")
430 (license (list license:bsd-3
431 license:isc
432 license:bsd-4
433 ;; The epic license is equal to the standard three-clause
434 ;; BSD license except that you are not permitted to remove the
435 ;; "Redistribution is permitted" clause of the license if you
436 ;; distribute binaries.
437 (license:non-copyleft "http://epicsol.org/copyright")))))