gnu: ruby-connection-pool: Update to 2.2.2.
[jackhill/guix/guix.git] / gnu / packages / acl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
5 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages acl)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages attr)
25 #:use-module (gnu packages base)
26 #:use-module (gnu packages gettext)
27 #:use-module (gnu packages perl)
28 #:use-module (guix packages)
29 #:use-module (guix download)
30 #:use-module (gnu packages)
31 #:use-module (guix build-system gnu))
32
33 (define-public acl
34 (package
35 (name "acl")
36 (version "2.2.52")
37 (source
38 (origin
39 (method url-fetch)
40 (uri (string-append "mirror://savannah/acl/acl-"
41 version ".src.tar.gz"))
42 (sha256
43 (base32
44 "08qd9s3wfhv0ajswsylnfwr5h0d7j9d4rgip855nrh400nxp940p"))
45 (patches (search-patches "acl-fix-perl-regex.patch"
46 "acl-hurd-path-max.patch"))))
47 (build-system gnu-build-system)
48 (arguments
49 `(#:test-target "tests"
50 #:phases
51 (modify-phases %standard-phases
52 (add-after 'build 'patch-exec-bin-sh
53 (lambda _
54 (substitute* "test/run"
55 (("/bin/sh") (which "sh")))
56 #t))
57 (add-before 'check 'patch-tests
58 (lambda _
59 ;; The coreutils do not have an ACL bit to remove from their
60 ;; output, so the sed expression that removes the bit is disabled.
61 (substitute* "test/sbits-restore.test"
62 (("\\| sed.*'") ""))
63 ;; These tests require the existence of a user named "bin", but
64 ;; this user does not exist within Guix's build environment.
65 (for-each (lambda (file)
66 (delete-file (string-append "test/" file)))
67 '("setfacl-X.test" "cp.test" "misc.test"))))
68 (replace 'install
69 (lambda _
70 (zero? (system* "make" "install" "install-lib" "install-dev")))))))
71 (inputs `(("attr" ,attr)))
72 (native-inputs
73 `(("gettext" ,gettext-minimal)
74 ("perl" ,perl)))
75 (home-page "https://savannah.nongnu.org/projects/acl")
76 (synopsis
77 "Library and tools for manipulating access control lists")
78 (description
79 "Library and tools for manipulating access control lists.")
80 (license (list gpl2+ lgpl2.1+))))