gnu: Add libunwind.
[jackhill/guix/guix.git] / gnu / packages / libunwind.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages libunwind)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses))
24
25 (define-public libunwind
26 (package
27 (name "libunwind")
28 (version "1.1")
29 (source (origin
30 (method url-fetch)
31 (uri (string-append "mirror://savannah/libunwind/libunwind-"
32 version ".tar.gz"))
33 (sha256
34 (base32
35 "16nhx2pahh9d62mvszc88q226q5lwjankij276fxwrm8wb50zzlx"))))
36 (build-system gnu-build-system)
37 (arguments
38 ;; FIXME: As of glibc 2.17, we get 3 out of 34 test failures.
39 ;; Report them upstream.
40 '(#:tests? #f))
41 (home-page "http://www.nongnu.org/libunwind")
42 (synopsis
43 "A portable and efficient API to determine the call-chain of a program")
44 (description
45 "The primary goal of this project is to define a portable and efficient C
46 programming interface (API) to determine the call-chain of a program. The API
47 additionally provides the means to manipulate the preserved (callee-saved)
48 state of each call-frame and to resume execution at any point in the
49 call-chain (non-local goto). The API supports both local (same-process) and
50 remote (across-process) operation. As such, the API is useful in a number of
51 applications.")
52 (license x11)))