gnu: r-chippeakanno: Update to 3.16.0.
[jackhill/guix/guix.git] / gnu / packages / bioconductor.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages bioconductor)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system r)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages bioinformatics)
28 #:use-module (gnu packages cran)
29 #:use-module (gnu packages compression)
30 #:use-module (gnu packages graph)
31 #:use-module (gnu packages maths)
32 #:use-module (gnu packages statistics)
33 #:use-module (gnu packages web))
34
35 (define-public r-bsgenome-dmelanogaster-ucsc-dm6
36 (package
37 (name "r-bsgenome-dmelanogaster-ucsc-dm6")
38 (version "1.4.1")
39 (source (origin
40 (method url-fetch)
41 ;; We cannot use bioconductor-uri here because this tarball is
42 ;; located under "data/annotation/" instead of "bioc/".
43 (uri (string-append "https://www.bioconductor.org/packages/"
44 "release/data/annotation/src/contrib/"
45 "BSgenome.Dmelanogaster.UCSC.dm6_"
46 version ".tar.gz"))
47 (sha256
48 (base32
49 "1bhj0rdgf7lspw4xby9y9mf7v7jxxz8001bc8vw8kf04rjsx6060"))))
50 (properties
51 `((upstream-name . "BSgenome.Dmelanogaster.UCSC.dm6")))
52 (build-system r-build-system)
53 ;; As this package provides little more than a very large data file it
54 ;; doesn't make sense to build substitutes.
55 (arguments `(#:substitutable? #f))
56 (propagated-inputs
57 `(("r-bsgenome" ,r-bsgenome)))
58 (home-page
59 "https://www.bioconductor.org/packages/BSgenome.Dmelanogaster.UCSC.dm6/")
60 (synopsis "Full genome sequences for Fly")
61 (description
62 "This package provides full genome sequences for Drosophila
63 melanogaster (Fly) as provided by UCSC (dm6) and stored in Biostrings
64 objects.")
65 (license license:artistic2.0)))
66
67 (define-public r-bsgenome-dmelanogaster-ucsc-dm3-masked
68 (package
69 (name "r-bsgenome-dmelanogaster-ucsc-dm3-masked")
70 (version "1.3.99")
71 (source (origin
72 (method url-fetch)
73 ;; We cannot use bioconductor-uri here because this tarball is
74 ;; located under "data/annotation/" instead of "bioc/".
75 (uri (string-append "http://www.bioconductor.org/packages/"
76 "release/data/annotation/src/contrib/"
77 "BSgenome.Dmelanogaster.UCSC.dm3.masked_"
78 version ".tar.gz"))
79 (sha256
80 (base32
81 "1756csb09f1br9rj1l3f08qyh4hlymdbd0cfn8x3fq39dn45m5ap"))))
82 (properties
83 `((upstream-name . "BSgenome.Dmelanogaster.UCSC.dm3.masked")))
84 (build-system r-build-system)
85 (propagated-inputs
86 `(("r-bsgenome" ,r-bsgenome)
87 ("r-bsgenome-dmelanogaster-ucsc-dm3"
88 ,r-bsgenome-dmelanogaster-ucsc-dm3)))
89 (home-page "https://www.bioconductor.org/packages/BSgenome.Dmelanogaster.UCSC.dm3.masked/")
90 (synopsis "Full masked genome sequences for Fly")
91 (description
92 "This package provides full masked genome sequences for Drosophila
93 melanogaster (Fly) as provided by UCSC (dm3, April 2006) and stored in
94 Biostrings objects. The sequences are the same as in
95 BSgenome.Dmelanogaster.UCSC.dm3, except that each of them has the 4 following
96 masks on top: (1) the mask of assembly gaps (AGAPS mask), (2) the mask of
97 intra-contig ambiguities (AMB mask), (3) the mask of repeats from
98 RepeatMasker (RM mask), and (4) the mask of repeats from Tandem Repeats
99 Finder (TRF mask). Only the AGAPS and AMB masks are \"active\" by default.")
100 (license license:artistic2.0)))
101
102 (define-public r-bsgenome-hsapiens-ucsc-hg19-masked
103 (package
104 (name "r-bsgenome-hsapiens-ucsc-hg19-masked")
105 (version "1.3.99")
106 (source (origin
107 (method url-fetch)
108 ;; We cannot use bioconductor-uri here because this tarball is
109 ;; located under "data/annotation/" instead of "bioc/".
110 (uri (string-append "http://www.bioconductor.org/packages/"
111 "release/data/annotation/src/contrib/"
112 "BSgenome.Hsapiens.UCSC.hg19.masked_"
113 version ".tar.gz"))
114 (sha256
115 (base32
116 "0452pyah0kv1vsrsjbrqw4k2rm8lc2vc771dzib45gnnfz86qxrr"))))
117 (properties
118 `((upstream-name . "BSgenome.Hsapiens.UCSC.hg19.masked")))
119 (build-system r-build-system)
120 (propagated-inputs
121 `(("r-bsgenome" ,r-bsgenome)
122 ("r-bsgenome-hsapiens-ucsc-hg19"
123 ,r-bsgenome-hsapiens-ucsc-hg19)))
124 (home-page "https://bioconductor.org/packages/BSgenome.Hsapiens.UCSC.hg19.masked/")
125 (synopsis "Full masked genome sequences for Homo sapiens")
126 (description
127 "This package provides full genome sequences for Homo sapiens (Human) as
128 provided by UCSC (hg19, Feb. 2009) and stored in Biostrings objects. The
129 sequences are the same as in BSgenome.Hsapiens.UCSC.hg19, except that each of
130 them has the 4 following masks on top: (1) the mask of assembly gaps (AGAPS
131 mask), (2) the mask of intra-contig ambiguities (AMB mask), (3) the mask of
132 repeats from RepeatMasker (RM mask), and (4) the mask of repeats from Tandem
133 Repeats Finder (TRF mask). Only the AGAPS and AMB masks are \"active\" by
134 default.")
135 (license license:artistic2.0)))
136
137 (define-public r-bsgenome-mmusculus-ucsc-mm9-masked
138 (package
139 (name "r-bsgenome-mmusculus-ucsc-mm9-masked")
140 (version "1.3.99")
141 (source (origin
142 (method url-fetch)
143 ;; We cannot use bioconductor-uri here because this tarball is
144 ;; located under "data/annotation/" instead of "bioc/".
145 (uri (string-append "http://www.bioconductor.org/packages/"
146 "release/data/annotation/src/contrib/"
147 "BSgenome.Mmusculus.UCSC.mm9.masked_"
148 version ".tar.gz"))
149 (sha256
150 (base32
151 "00bpbm3havqcxr4g63zhllsbpd9q6svgihks7qp7x73nm4gvq7fn"))))
152 (properties
153 `((upstream-name . "BSgenome.Mmusculus.UCSC.mm9.masked")))
154 (build-system r-build-system)
155 (propagated-inputs
156 `(("r-bsgenome" ,r-bsgenome)
157 ("r-bsgenome-mmusculus-ucsc-mm9"
158 ,r-bsgenome-mmusculus-ucsc-mm9)))
159 (home-page "http://bioconductor.org/packages/BSgenome.Mmusculus.UCSC.mm9.masked/")
160 (synopsis "Full masked genome sequences for Mouse")
161 (description
162 "This package provides full genome sequences for Mus musculus (Mouse) as
163 provided by UCSC (mm9, Jul. 2007) and stored in Biostrings objects. The
164 sequences are the same as in BSgenome.Mmusculus.UCSC.mm9, except that each of
165 them has the 4 following masks on top: (1) the mask of assembly gaps (AGAPS
166 mask), (2) the mask of intra-contig ambiguities (AMB mask), (3) the mask of
167 repeats from RepeatMasker (RM mask), and (4) the mask of repeats from Tandem
168 Repeats Finder (TRF mask). Only the AGAPS and AMB masks are \"active\" by
169 default." )
170 (license license:artistic2.0)))
171
172 (define-public r-genelendatabase
173 (package
174 (name "r-genelendatabase")
175 (version "1.16.0")
176 (source
177 (origin
178 (method url-fetch)
179 ;; We cannot use bioconductor-uri here because this tarball is
180 ;; located under "data/experiment/" instead of "bioc/".
181 (uri (string-append "https://bioconductor.org/packages/"
182 "release/data/experiment/src/contrib"
183 "/geneLenDataBase_" version ".tar.gz"))
184 (sha256
185 (base32
186 "07mmmn53kb7v14msc13dsbm8ghssbvwcrhifrk15hn37bw2p4ja5"))))
187 (properties
188 `((upstream-name . "geneLenDataBase")))
189 (build-system r-build-system)
190 (propagated-inputs
191 `(("r-rtracklayer" ,r-rtracklayer)
192 ("r-genomicfeatures" ,r-genomicfeatures)))
193 (home-page "https://bioconductor.org/packages/geneLenDataBase/")
194 (synopsis "Lengths of mRNA transcripts for a number of genomes")
195 (description
196 "This package provides the lengths of mRNA transcripts for a number of
197 genomes and gene ID formats, largely based on the UCSC table browser.")
198 (license license:lgpl2.0+)))
199
200 \f
201 (define-public r-hpar
202 (package
203 (name "r-hpar")
204 (version "1.24.0")
205 (source
206 (origin
207 (method url-fetch)
208 (uri (bioconductor-uri "hpar" version))
209 (sha256
210 (base32
211 "1pm3k8apgynmdzv2d0chca3b636kcai3b1x861fyv1m3xs6msgxn"))))
212 (build-system r-build-system)
213 (home-page "https://bioconductor.org/packages/hpar/")
214 (synopsis "Human Protein Atlas in R")
215 (description "This package provides a simple interface to and data from
216 the Human Protein Atlas project.")
217 (license license:artistic2.0)))
218
219 (define-public r-regioner
220 (package
221 (name "r-regioner")
222 (version "1.12.0")
223 (source
224 (origin
225 (method url-fetch)
226 (uri (bioconductor-uri "regioneR" version))
227 (sha256
228 (base32
229 "09bzlaqdgy7wmzly3zc9y2da50d07mlixlnpaxdxpiwdk8qmhxsb"))))
230 (properties `((upstream-name . "regioneR")))
231 (build-system r-build-system)
232 (propagated-inputs
233 `(("r-memoise" ,r-memoise)
234 ("r-genomicranges" ,r-genomicranges)
235 ("r-bsgenome" ,r-bsgenome)
236 ("r-rtracklayer" ,r-rtracklayer)
237 ("r-genomeinfodb" ,r-genomeinfodb)
238 ("r-iranges" ,r-iranges)
239 ("r-s4vectors" ,r-s4vectors)))
240 (home-page "https://bioconductor.org/packages/regioneR/")
241 (synopsis "Association analysis of genomic regions")
242 (description "This package offers a statistical framework based on
243 customizable permutation tests to assess the association between genomic
244 region sets and other genomic features.")
245 (license license:artistic2.0)))
246
247 (define-public r-diffbind
248 (package
249 (name "r-diffbind")
250 (version "2.10.0")
251 (source
252 (origin
253 (method url-fetch)
254 (uri (bioconductor-uri "DiffBind" version))
255 (sha256
256 (base32
257 "0j8pal40lr1gv8sss96hhkj7l1qn9sy4q4l2kqd4rfwl7qrcnfw5"))))
258 (properties `((upstream-name . "DiffBind")))
259 (build-system r-build-system)
260 (inputs
261 `(("zlib" ,zlib)))
262 (propagated-inputs
263 `(("r-amap" ,r-amap)
264 ("r-biocparallel" ,r-biocparallel)
265 ("r-deseq2" ,r-deseq2)
266 ("r-dplyr" ,r-dplyr)
267 ("r-edger" ,r-edger)
268 ("r-genomicalignments" ,r-genomicalignments)
269 ("r-genomicranges" ,r-genomicranges)
270 ("r-ggplot2" ,r-ggplot2)
271 ("r-ggrepel" ,r-ggrepel)
272 ("r-gplots" ,r-gplots)
273 ("r-iranges" ,r-iranges)
274 ("r-lattice" ,r-lattice)
275 ("r-limma" ,r-limma)
276 ("r-locfit" ,r-locfit)
277 ("r-rcolorbrewer" , r-rcolorbrewer)
278 ("r-rcpp" ,r-rcpp)
279 ("r-rsamtools" ,r-rsamtools)
280 ("r-s4vectors" ,r-s4vectors)
281 ("r-summarizedexperiment" ,r-summarizedexperiment)
282 ("r-systempiper" ,r-systempiper)
283 ("r-zlibbioc" ,r-zlibbioc)))
284 (home-page "http://bioconductor.org/packages/DiffBind")
285 (synopsis "Differential binding analysis of ChIP-Seq peak data")
286 (description
287 "This package computes differentially bound sites from multiple
288 ChIP-seq experiments using affinity (quantitative) data. Also enables
289 occupancy (overlap) analysis and plotting functions.")
290 (license license:artistic2.0)))
291
292 (define-public r-ripseeker
293 (package
294 (name "r-ripseeker")
295 (version "1.20.0")
296 (source
297 (origin
298 (method url-fetch)
299 (uri (bioconductor-uri "RIPSeeker" version))
300 (sha256
301 (base32
302 "0y9cvzqslfxj3z9mnp47mknff0pky2g5x8x1z1s5yjcx35q89xfi"))))
303 (properties `((upstream-name . "RIPSeeker")))
304 (build-system r-build-system)
305 (propagated-inputs
306 `(("r-s4vectors" ,r-s4vectors)
307 ("r-iranges" ,r-iranges)
308 ("r-genomicranges" ,r-genomicranges)
309 ("r-summarizedexperiment" ,r-summarizedexperiment)
310 ("r-rsamtools" ,r-rsamtools)
311 ("r-genomicalignments" ,r-genomicalignments)
312 ("r-rtracklayer" ,r-rtracklayer)))
313 (home-page "http://bioconductor.org/packages/RIPSeeker")
314 (synopsis
315 "Identifying protein-associated transcripts from RIP-seq experiments")
316 (description
317 "This package infers and discriminates RIP peaks from RIP-seq alignments
318 using two-state HMM with negative binomial emission probability. While
319 RIPSeeker is specifically tailored for RIP-seq data analysis, it also provides
320 a suite of bioinformatics tools integrated within this self-contained software
321 package comprehensively addressing issues ranging from post-alignments
322 processing to visualization and annotation.")
323 (license license:gpl2)))
324
325 (define-public r-multtest
326 (package
327 (name "r-multtest")
328 (version "2.38.0")
329 (source
330 (origin
331 (method url-fetch)
332 (uri (bioconductor-uri "multtest" version))
333 (sha256
334 (base32
335 "0lq62jw81hz9k840969n5byj57pwd0jqga3hqvhb6abb3g10yz7k"))))
336 (build-system r-build-system)
337 (propagated-inputs
338 `(("r-survival" ,r-survival)
339 ("r-biocgenerics" ,r-biocgenerics)
340 ("r-biobase" ,r-biobase)
341 ("r-mass" ,r-mass)))
342 (home-page "http://bioconductor.org/packages/multtest")
343 (synopsis "Resampling-based multiple hypothesis testing")
344 (description
345 "This package can do non-parametric bootstrap and permutation
346 resampling-based multiple testing procedures (including empirical Bayes
347 methods) for controlling the family-wise error rate (FWER), generalized
348 family-wise error rate (gFWER), tail probability of the proportion of
349 false positives (TPPFP), and false discovery rate (FDR). Several choices
350 of bootstrap-based null distribution are implemented (centered, centered
351 and scaled, quantile-transformed). Single-step and step-wise methods are
352 available. Tests based on a variety of T- and F-statistics (including
353 T-statistics based on regression parameters from linear and survival models
354 as well as those based on correlation parameters) are included. When probing
355 hypotheses with T-statistics, users may also select a potentially faster null
356 distribution which is multivariate normal with mean zero and variance
357 covariance matrix derived from the vector influence function. Results are
358 reported in terms of adjusted P-values, confidence regions and test statistic
359 cutoffs. The procedures are directly applicable to identifying differentially
360 expressed genes in DNA microarray experiments.")
361 (license license:lgpl3)))
362
363 (define-public r-graph
364 (package
365 (name "r-graph")
366 (version "1.60.0")
367 (source (origin
368 (method url-fetch)
369 (uri (bioconductor-uri "graph" version))
370 (sha256
371 (base32
372 "1kgnsm6f0vmb9qbkmmrnvxbwqc0gar17dq5gv1v10hrksw6mh64i"))))
373 (build-system r-build-system)
374 (propagated-inputs
375 `(("r-biocgenerics" ,r-biocgenerics)))
376 (home-page "https://bioconductor.org/packages/graph")
377 (synopsis "Handle graph data structures in R")
378 (description
379 "This package implements some simple graph handling capabilities for R.")
380 (license license:artistic2.0)))
381
382 (define-public r-codedepends
383 (package
384 (name "r-codedepends")
385 (version "0.6.5")
386 (source
387 (origin
388 (method url-fetch)
389 (uri (cran-uri "CodeDepends" version))
390 (sha256
391 (base32
392 "0l7kiv3awx50glf5cs841b4zzsff1ml90f0zr868ygvwsr4ps1hq"))))
393 (properties `((upstream-name . "CodeDepends")))
394 (build-system r-build-system)
395 (propagated-inputs
396 `(("r-codetools" ,r-codetools)
397 ("r-graph" ,r-graph)
398 ("r-xml" ,r-xml)))
399 (home-page "http://cran.r-project.org/web/packages/CodeDepends")
400 (synopsis "Analysis of R code for reproducible research and code comprehension")
401 (description
402 "This package provides tools for analyzing R expressions or blocks of
403 code and determining the dependencies between them. It focuses on R scripts,
404 but can be used on the bodies of functions. There are many facilities
405 including the ability to summarize or get a high-level view of code,
406 determining dependencies between variables, code improvement suggestions.")
407 ;; Any version of the GPL
408 (license (list license:gpl2+ license:gpl3+))))
409
410 (define-public r-chippeakanno
411 (package
412 (name "r-chippeakanno")
413 (version "3.16.0")
414 (source
415 (origin
416 (method url-fetch)
417 (uri (bioconductor-uri "ChIPpeakAnno" version))
418 (sha256
419 (base32
420 "09fhh1355diip3v3c0skmp1336vclipkm5nv02qvp5902v4262y3"))))
421 (properties `((upstream-name . "ChIPpeakAnno")))
422 (build-system r-build-system)
423 (propagated-inputs
424 `(("r-biocgenerics" ,r-biocgenerics)
425 ("r-biocmanager" ,r-biocmanager)
426 ("r-biostrings" ,r-biostrings)
427 ("r-delayedarray" ,r-delayedarray)
428 ("r-go-db" ,r-go-db)
429 ("r-biomart" ,r-biomart)
430 ("r-bsgenome" ,r-bsgenome)
431 ("r-genomicfeatures" ,r-genomicfeatures)
432 ("r-genomicranges" ,r-genomicranges)
433 ("r-genomeinfodb" ,r-genomeinfodb)
434 ("r-iranges" ,r-iranges)
435 ("r-matrixstats" ,r-matrixstats)
436 ("r-annotationdbi" ,r-annotationdbi)
437 ("r-limma" ,r-limma)
438 ("r-multtest" ,r-multtest)
439 ("r-rbgl" ,r-rbgl)
440 ("r-graph" ,r-graph)
441 ("r-regioner" ,r-regioner)
442 ("r-dbi" ,r-dbi)
443 ("r-ensembldb" ,r-ensembldb)
444 ("r-biobase" ,r-biobase)
445 ("r-s4vectors" ,r-s4vectors)
446 ("r-seqinr" ,r-seqinr)
447 ("r-idr" ,r-idr)
448 ("r-genomicalignments" ,r-genomicalignments)
449 ("r-summarizedexperiment" ,r-summarizedexperiment)
450 ("r-rsamtools" ,r-rsamtools)
451 ("r-venndiagram" ,r-venndiagram)))
452 (home-page "http://bioconductor.org/packages/ChIPpeakAnno")
453 (synopsis "Peaks annotation from ChIP-seq and ChIP-chip experiments")
454 (description
455 "The package includes functions to retrieve the sequences around the peak,
456 obtain enriched Gene Ontology (GO) terms, find the nearest gene, exon, miRNA or
457 custom features such as most conserved elements and other transcription factor
458 binding sites supplied by users. Starting 2.0.5, new functions have been added
459 for finding the peaks with bi-directional promoters with summary statistics
460 (peaksNearBDP), for summarizing the occurrence of motifs in peaks
461 (summarizePatternInPeaks) and for adding other IDs to annotated peaks or
462 enrichedGO (addGeneIDs).")
463 (license license:gpl2+)))
464
465 (define-public r-marray
466 (package
467 (name "r-marray")
468 (version "1.60.0")
469 (source (origin
470 (method url-fetch)
471 (uri (bioconductor-uri "marray" version))
472 (sha256
473 (base32 "1sh7l3c28x6zhdv99c9x05ii2yxmh9alkazp98kdi4fdb23rlzky"))))
474 (build-system r-build-system)
475 (propagated-inputs
476 `(("r-limma" ,r-limma)))
477 (home-page "http://bioconductor.org/packages/marray")
478 (synopsis "Exploratory analysis for two-color spotted microarray data")
479 (description "This package contains class definitions for two-color spotted
480 microarray data. It also includes fuctions for data input, diagnostic plots,
481 normalization and quality checking.")
482 (license license:lgpl2.0+)))
483
484 (define-public r-cghbase
485 (package
486 (name "r-cghbase")
487 (version "1.42.0")
488 (source (origin
489 (method url-fetch)
490 (uri (bioconductor-uri "CGHbase" version))
491 (sha256
492 (base32 "0ghxp49xdi09p3f2qwrdrq2p4qjafj4z1rr08ycgbf11gb22h1sc"))))
493 (properties `((upstream-name . "CGHbase")))
494 (build-system r-build-system)
495 (propagated-inputs
496 `(("r-biobase" ,r-biobase)
497 ("r-marray" ,r-marray)))
498 (home-page "http://bioconductor.org/packages/CGHbase")
499 (synopsis "Base functions and classes for arrayCGH data analysis")
500 (description "This package contains functions and classes that are needed by
501 the @code{arrayCGH} packages.")
502 (license license:gpl2+)))
503
504 (define-public r-cghcall
505 (package
506 (name "r-cghcall")
507 (version "2.44.0")
508 (source (origin
509 (method url-fetch)
510 (uri (bioconductor-uri "CGHcall" version))
511 (sha256
512 (base32 "1k65kaiqvjyllzbpa2367n6f6kkmsy463kpflzs66hqhx2fshsmi"))))
513 (properties `((upstream-name . "CGHcall")))
514 (build-system r-build-system)
515 (propagated-inputs
516 `(("r-biobase" ,r-biobase)
517 ("r-cghbase" ,r-cghbase)
518 ("r-impute" ,r-impute)
519 ("r-dnacopy" ,r-dnacopy)
520 ("r-snowfall" ,r-snowfall)))
521 (home-page "http://bioconductor.org/packages/CGHcall")
522 (synopsis "Base functions and classes for arrayCGH data analysis")
523 (description "This package contains functions and classes that are needed by
524 @code{arrayCGH} packages.")
525 (license license:gpl2+)))
526
527 (define-public r-qdnaseq
528 (package
529 (name "r-qdnaseq")
530 (version "1.18.0")
531 (source (origin
532 (method url-fetch)
533 (uri (bioconductor-uri "QDNAseq" version))
534 (sha256
535 (base32 "04ff9nbckzrlb45mr2j0c3mlh1wcggq5bbl81zklhq203c5x1wc2"))))
536 (properties `((upstream-name . "QDNAseq")))
537 (build-system r-build-system)
538 (propagated-inputs
539 `(("r-biobase" ,r-biobase)
540 ("r-biocparallel" ,r-biocparallel)
541 ("r-cghbase" ,r-cghbase)
542 ("r-cghcall" ,r-cghcall)
543 ("r-dnacopy" ,r-dnacopy)
544 ("r-genomicranges" ,r-genomicranges)
545 ("r-iranges" ,r-iranges)
546 ("r-matrixstats" ,r-matrixstats)
547 ("r-r-utils" ,r-r-utils)
548 ("r-rsamtools" ,r-rsamtools)))
549 (home-page "http://bioconductor.org/packages/QDNAseq")
550 (synopsis "Quantitative DNA sequencing for chromosomal aberrations")
551 (description "The genome is divided into non-overlapping fixed-sized bins,
552 number of sequence reads in each counted, adjusted with a simultaneous
553 two-dimensional loess correction for sequence mappability and GC content, and
554 filtered to remove spurious regions in the genome. Downstream steps of
555 segmentation and calling are also implemented via packages DNAcopy and CGHcall,
556 respectively.")
557 (license license:gpl2+)))
558
559 (define-public r-bayseq
560 (package
561 (name "r-bayseq")
562 (version "2.14.0")
563 (source
564 (origin
565 (method url-fetch)
566 (uri (bioconductor-uri "baySeq" version))
567 (sha256
568 (base32
569 "0hbmm01a8libara9mbxknpk0wzarwfngnfwlmhpww91a0cmy5klg"))))
570 (properties `((upstream-name . "baySeq")))
571 (build-system r-build-system)
572 (propagated-inputs
573 `(("r-abind" ,r-abind)
574 ("r-edger" ,r-edger)
575 ("r-genomicranges" ,r-genomicranges)))
576 (home-page "https://bioconductor.org/packages/baySeq/")
577 (synopsis "Bayesian analysis of differential expression patterns in count data")
578 (description
579 "This package identifies differential expression in high-throughput count
580 data, such as that derived from next-generation sequencing machines,
581 calculating estimated posterior likelihoods of differential expression (or
582 more complex hypotheses) via empirical Bayesian methods.")
583 (license license:gpl3)))
584
585 (define-public r-chipcomp
586 (package
587 (name "r-chipcomp")
588 (version "1.10.0")
589 (source
590 (origin
591 (method url-fetch)
592 (uri (bioconductor-uri "ChIPComp" version))
593 (sha256
594 (base32
595 "0j9nif7z33qdxf347r9wa62hhz8qs09r2p96x3hg5yz30a10ahqs"))))
596 (properties `((upstream-name . "ChIPComp")))
597 (build-system r-build-system)
598 (propagated-inputs
599 `(("r-biocgenerics" ,r-biocgenerics)
600 ("r-bsgenome-hsapiens-ucsc-hg19" ,r-bsgenome-hsapiens-ucsc-hg19)
601 ("r-bsgenome-mmusculus-ucsc-mm9" ,r-bsgenome-mmusculus-ucsc-mm9)
602 ("r-genomeinfodb" ,r-genomeinfodb)
603 ("r-genomicranges" ,r-genomicranges)
604 ("r-iranges" ,r-iranges)
605 ("r-limma" ,r-limma)
606 ("r-rsamtools" ,r-rsamtools)
607 ("r-rtracklayer" ,r-rtracklayer)
608 ("r-s4vectors" ,r-s4vectors)))
609 (home-page "https://bioconductor.org/packages/ChIPComp")
610 (synopsis "Quantitative comparison of multiple ChIP-seq datasets")
611 (description
612 "ChIPComp implements a statistical method for quantitative comparison of
613 multiple ChIP-seq datasets. It detects differentially bound sharp binding
614 sites across multiple conditions considering matching control in ChIP-seq
615 datasets.")
616 ;; Any version of the GPL.
617 (license license:gpl3+)))
618
619 (define-public r-riboprofiling
620 (package
621 (name "r-riboprofiling")
622 (version "1.10.0")
623 (source
624 (origin
625 (method url-fetch)
626 (uri (bioconductor-uri "RiboProfiling" version))
627 (sha256
628 (base32
629 "04yjklqdjkim7yxyk3cyvf0mmwyxyfvw2mmfzgwaaqbiyg29sli0"))))
630 (properties `((upstream-name . "RiboProfiling")))
631 (build-system r-build-system)
632 (propagated-inputs
633 `(("r-biocgenerics" ,r-biocgenerics)
634 ("r-biostrings" ,r-biostrings)
635 ("r-data-table" ,r-data-table)
636 ("r-genomeinfodb" ,r-genomeinfodb)
637 ("r-genomicalignments" ,r-genomicalignments)
638 ("r-genomicfeatures" ,r-genomicfeatures)
639 ("r-genomicranges" ,r-genomicranges)
640 ("r-ggbio" ,r-ggbio)
641 ("r-ggplot2" ,r-ggplot2)
642 ("r-iranges" ,r-iranges)
643 ("r-plyr" ,r-plyr)
644 ("r-reshape2" ,r-reshape2)
645 ("r-rsamtools" ,r-rsamtools)
646 ("r-rtracklayer" ,r-rtracklayer)
647 ("r-s4vectors" ,r-s4vectors)
648 ("r-sqldf" ,r-sqldf)))
649 (home-page "https://bioconductor.org/packages/RiboProfiling/")
650 (synopsis "Ribosome profiling data analysis")
651 (description "Starting with a BAM file, this package provides the
652 necessary functions for quality assessment, read start position recalibration,
653 the counting of genomic sequence reads on CDS, 3'UTR, and 5'UTR, and plotting
654 of count data: pairs, log fold-change, codon frequency and coverage
655 assessment, principal component analysis on codon coverage.")
656 (license license:gpl3)))
657
658 (define-public r-riboseqr
659 (package
660 (name "r-riboseqr")
661 (version "1.14.0")
662 (source
663 (origin
664 (method url-fetch)
665 (uri (bioconductor-uri "riboSeqR" version))
666 (sha256
667 (base32
668 "0xavd1cdhi8qfjn9a1hjhflyg6jq1ydvv56z12gjz572pwz2knvn"))))
669 (properties `((upstream-name . "riboSeqR")))
670 (build-system r-build-system)
671 (propagated-inputs
672 `(("r-abind" ,r-abind)
673 ("r-bayseq" ,r-bayseq)
674 ("r-genomeinfodb" ,r-genomeinfodb)
675 ("r-genomicranges" ,r-genomicranges)
676 ("r-iranges" ,r-iranges)
677 ("r-rsamtools" ,r-rsamtools)
678 ("r-seqlogo" ,r-seqlogo)))
679 (home-page "https://bioconductor.org/packages/riboSeqR/")
680 (synopsis "Analysis of sequencing data from ribosome profiling experiments")
681 (description
682 "This package provides plotting functions, frameshift detection and
683 parsing of genetic sequencing data from ribosome profiling experiments.")
684 (license license:gpl3)))
685
686 (define-public r-interactionset
687 (package
688 (name "r-interactionset")
689 (version "1.8.0")
690 (source
691 (origin
692 (method url-fetch)
693 (uri (bioconductor-uri "InteractionSet" version))
694 (sha256
695 (base32
696 "0xngraq7ic80jr98i1wqp8bxdgidq6py60m2wfk82n1ixpcdck8n"))))
697 (properties
698 `((upstream-name . "InteractionSet")))
699 (build-system r-build-system)
700 (propagated-inputs
701 `(("r-biocgenerics" ,r-biocgenerics)
702 ("r-genomeinfodb" ,r-genomeinfodb)
703 ("r-genomicranges" ,r-genomicranges)
704 ("r-iranges" ,r-iranges)
705 ("r-matrix" ,r-matrix)
706 ("r-rcpp" ,r-rcpp)
707 ("r-s4vectors" ,r-s4vectors)
708 ("r-summarizedexperiment" ,r-summarizedexperiment)))
709 (home-page "https://bioconductor.org/packages/InteractionSet")
710 (synopsis "Base classes for storing genomic interaction data")
711 (description
712 "This packages provides the @code{GInteractions},
713 @code{InteractionSet} and @code{ContactMatrix} objects and associated methods
714 for storing and manipulating genomic interaction data from Hi-C and ChIA-PET
715 experiments.")
716 (license license:gpl3)))
717
718 (define-public r-genomicinteractions
719 (package
720 (name "r-genomicinteractions")
721 (version "1.14.0")
722 (source
723 (origin
724 (method url-fetch)
725 (uri (bioconductor-uri "GenomicInteractions" version))
726 (sha256
727 (base32
728 "0cnagprxj0b7p6s29iyhqwxj7hgmrh75gj52y4dlil790d1bmq2q"))))
729 (properties
730 `((upstream-name . "GenomicInteractions")))
731 (build-system r-build-system)
732 (propagated-inputs
733 `(("r-biobase" ,r-biobase)
734 ("r-biocgenerics" ,r-biocgenerics)
735 ("r-data-table" ,r-data-table)
736 ("r-dplyr" ,r-dplyr)
737 ("r-genomeinfodb" ,r-genomeinfodb)
738 ("r-genomicranges" ,r-genomicranges)
739 ("r-ggplot2" ,r-ggplot2)
740 ("r-gridextra" ,r-gridextra)
741 ("r-gviz" ,r-gviz)
742 ("r-igraph" ,r-igraph)
743 ("r-interactionset" ,r-interactionset)
744 ("r-iranges" ,r-iranges)
745 ("r-rsamtools" ,r-rsamtools)
746 ("r-rtracklayer" ,r-rtracklayer)
747 ("r-s4vectors" ,r-s4vectors)
748 ("r-stringr" ,r-stringr)))
749 (home-page "https://github.com/ComputationalRegulatoryGenomicsICL/GenomicInteractions/")
750 (synopsis "R package for handling genomic interaction data")
751 (description
752 "This R package provides tools for handling genomic interaction data,
753 such as ChIA-PET/Hi-C, annotating genomic features with interaction
754 information and producing various plots and statistics.")
755 (license license:gpl3)))
756
757 (define-public r-ctc
758 (package
759 (name "r-ctc")
760 (version "1.54.0")
761 (source
762 (origin
763 (method url-fetch)
764 (uri (bioconductor-uri "ctc" version))
765 (sha256
766 (base32
767 "0sadplm4n9n3z6inmn6y3d6qbr4hllljqh700x5fygrnfacnckk9"))))
768 (build-system r-build-system)
769 (propagated-inputs `(("r-amap" ,r-amap)))
770 (home-page "https://bioconductor.org/packages/ctc/")
771 (synopsis "Cluster and tree conversion")
772 (description
773 "This package provides tools for exporting and importing classification
774 trees and clusters to other programs.")
775 (license license:gpl2)))
776
777 (define-public r-goseq
778 (package
779 (name "r-goseq")
780 (version "1.32.0")
781 (source
782 (origin
783 (method url-fetch)
784 (uri (bioconductor-uri "goseq" version))
785 (sha256
786 (base32
787 "0xmbb8ma32lrfy810r82y34gkspq4fqiqxykic9j4rq9rg9n9x2l"))))
788 (build-system r-build-system)
789 (propagated-inputs
790 `(("r-annotationdbi" ,r-annotationdbi)
791 ("r-biasedurn" ,r-biasedurn)
792 ("r-biocgenerics" ,r-biocgenerics)
793 ("r-genelendatabase" ,r-genelendatabase)
794 ("r-go-db" ,r-go-db)
795 ("r-mgcv" ,r-mgcv)))
796 (home-page "https://bioconductor.org/packages/goseq/")
797 (synopsis "Gene Ontology analyser for RNA-seq and other length biased data")
798 (description
799 "This package provides tools to detect Gene Ontology and/or other user
800 defined categories which are over/under represented in RNA-seq data.")
801 (license license:lgpl2.0+)))
802
803 (define-public r-glimma
804 (package
805 (name "r-glimma")
806 (version "1.8.2")
807 (source
808 (origin
809 (method url-fetch)
810 (uri (bioconductor-uri "Glimma" version))
811 (sha256
812 (base32
813 "0kfia60vrlys6amdchdix01iwbkwyb7nfjqn5hczsxp8rhmbg25s"))))
814 (properties `((upstream-name . "Glimma")))
815 (build-system r-build-system)
816 (propagated-inputs
817 `(("r-edger" ,r-edger)
818 ("r-jsonlite" ,r-jsonlite)
819 ("r-s4vectors" ,r-s4vectors)))
820 (home-page "https://github.com/Shians/Glimma")
821 (synopsis "Interactive HTML graphics")
822 (description
823 "This package generates interactive visualisations for analysis of
824 RNA-sequencing data using output from limma, edgeR or DESeq2 packages in an
825 HTML page. The interactions are built on top of the popular static
826 representations of analysis results in order to provide additional
827 information.")
828 (license license:lgpl3)))
829
830 (define-public r-rots
831 (package
832 (name "r-rots")
833 (version "1.8.0")
834 (source
835 (origin
836 (method url-fetch)
837 (uri (bioconductor-uri "ROTS" version))
838 (sha256
839 (base32
840 "12jvdqanyk86ihpcylp105zip22y0gkbksmyxy00q7iad0jhaqp3"))))
841 (properties `((upstream-name . "ROTS")))
842 (build-system r-build-system)
843 (propagated-inputs
844 `(("r-biobase" ,r-biobase)
845 ("r-rcpp" ,r-rcpp)))
846 (home-page "https://bioconductor.org/packages/ROTS/")
847 (synopsis "Reproducibility-Optimized Test Statistic")
848 (description
849 "This package provides tools for calculating the
850 @dfn{Reproducibility-Optimized Test Statistic} (ROTS) for differential testing
851 in omics data.")
852 (license license:gpl2+)))
853
854 (define-public r-inspect
855 (package
856 (name "r-inspect")
857 (version "1.10.0")
858 (source
859 (origin
860 (method url-fetch)
861 (uri (bioconductor-uri "INSPEcT" version))
862 (sha256
863 (base32
864 "1gk0pwyimkswrvgb2xr3c2zy4myi448a2shr5ap65rq9pcpp0l8p"))))
865 (properties `((upstream-name . "INSPEcT")))
866 (build-system r-build-system)
867 (propagated-inputs
868 `(("r-biobase" ,r-biobase)
869 ("r-biocgenerics" ,r-biocgenerics)
870 ("r-biocparallel" ,r-biocparallel)
871 ("r-desolve" ,r-desolve)
872 ("r-genomicalignments" ,r-genomicalignments)
873 ("r-genomicfeatures" ,r-genomicfeatures)
874 ("r-genomicranges" ,r-genomicranges)
875 ("r-iranges" ,r-iranges)
876 ("r-preprocesscore" ,r-preprocesscore)
877 ("r-proc" ,r-proc)
878 ("r-rootsolve" ,r-rootsolve)
879 ("r-rsamtools" ,r-rsamtools)
880 ("r-s4vectors" ,r-s4vectors)))
881 (home-page "https://bioconductor.org/packages/INSPEcT")
882 (synopsis "Analysis of 4sU-seq and RNA-seq time-course data")
883 (description
884 "INSPEcT (INference of Synthesis, Processing and dEgradation rates in
885 Time-Course experiments) analyses 4sU-seq and RNA-seq time-course data in
886 order to evaluate synthesis, processing and degradation rates and assess via
887 modeling the rates that determines changes in mature mRNA levels.")
888 (license license:gpl2)))
889
890 (define-public r-dnabarcodes
891 (package
892 (name "r-dnabarcodes")
893 (version "1.10.0")
894 (source
895 (origin
896 (method url-fetch)
897 (uri (bioconductor-uri "DNABarcodes" version))
898 (sha256
899 (base32
900 "0xhna7f0kr7pp2hqwara5i57m9mdr65shflfxiyw6yy3g90pgb5x"))))
901 (properties `((upstream-name . "DNABarcodes")))
902 (build-system r-build-system)
903 (propagated-inputs
904 `(("r-bh" ,r-bh)
905 ("r-matrix" ,r-matrix)
906 ("r-rcpp" ,r-rcpp)))
907 (home-page "https://bioconductor.org/packages/DNABarcodes")
908 (synopsis "Create and analyze DNA barcodes")
909 (description
910 "This package offers tools to create DNA barcode sets capable of
911 correcting insertion, deletion, and substitution errors. Existing barcodes
912 can be analyzed regarding their minimal, maximal and average distances between
913 barcodes. Finally, reads that start with a (possibly mutated) barcode can be
914 demultiplexed, i.e. assigned to their original reference barcode.")
915 (license license:gpl2)))
916
917 (define-public r-ruvseq
918 (package
919 (name "r-ruvseq")
920 (version "1.14.0")
921 (source
922 (origin
923 (method url-fetch)
924 (uri (bioconductor-uri "RUVSeq" version))
925 (sha256
926 (base32
927 "16i5sm5af761k4zvspfi8jknsgln48bn538hxqqmlaq7wvlfxqxj"))))
928 (properties `((upstream-name . "RUVSeq")))
929 (build-system r-build-system)
930 (propagated-inputs
931 `(("r-biobase" ,r-biobase)
932 ("r-edaseq" ,r-edaseq)
933 ("r-edger" ,r-edger)
934 ("r-mass" ,r-mass)))
935 (home-page "https://github.com/drisso/RUVSeq")
936 (synopsis "Remove unwanted variation from RNA-Seq data")
937 (description
938 "This package implements methods to @dfn{remove unwanted variation} (RUV)
939 of Risso et al. (2014) for the normalization of RNA-Seq read counts between
940 samples.")
941 (license license:artistic2.0)))