gnu: python-oslo.i18n: Update to 3.0.0.
[jackhill/guix/guix.git] / gnu / packages / openstack.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages openstack)
21 #:use-module (gnu packages python)
22 #:use-module (gnu packages version-control)
23 #:use-module (guix build-system python)
24 #:use-module (guix download)
25 #:use-module ((guix licenses)
26 #:select (asl2.0))
27 #:use-module (guix packages))
28
29 (define-public python-bandit
30 (package
31 (name "python-bandit")
32 (version "0.13.2")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append
37 "https://pypi.python.org/packages/source/b/bandit/bandit-"
38 version ".tar.gz"))
39 (sha256
40 (base32
41 "03g3cflvrc99ncjd611iy5nnnscsc2vgnrx4mjaqyx8glbfw8y7g"))))
42 (build-system python-build-system)
43 (propagated-inputs
44 `(("python-appdirs" ,python-appdirs)
45 ("python-pyyaml" ,python-pyyaml)
46 ("python-six" ,python-six)
47 ("python-stevedore" ,python-stevedore)))
48 (inputs
49 `(("python-pbr" ,python-pbr)
50 ("python-setuptools" ,python-setuptools)
51 ;; Tests
52 ("python-fixtures" ,python-fixtures)
53 ("python-mock" ,python-mock)
54 ("python-testrepository" ,python-testrepository)
55 ("python-testscenarios" ,python-testscenarios)
56 ("python-testtools" ,python-testtools)))
57 (home-page "https://wiki.openstack.org/wiki/Security/Projects/Bandit")
58 (synopsis "Security oriented static analyser for python code.")
59 (description
60 "Bandit is a tool designed to find common security issues in Python code.
61 To do this Bandit processes each file, builds an AST from it, and runs
62 appropriate plugins against the AST nodes. Once Bandit has finished scanning
63 all the files it generates a report.")
64 (license asl2.0)))
65
66 (define-public python2-bandit
67 (package-with-python2 python-bandit))
68
69 (define-public python-debtcollector
70 (package
71 (name "python-debtcollector")
72 (version "1.0.0")
73 (source
74 (origin
75 (method url-fetch)
76 (uri (pypi-uri "debtcollector" version))
77 (sha256
78 (base32
79 "0g4dfskaiy47rhsh4gh66l5vmdsrgq0qk68pl3ix1cj3ffvfndzv"))))
80 (build-system python-build-system)
81 (propagated-inputs
82 `(("python-six" ,python-six)
83 ("python-wrapt" ,python-wrapt)))
84 (inputs
85 `(("python-babel" ,python-babel)
86 ("python-pbr" ,python-pbr)
87 ("python-setuptools" ,python-setuptools)
88 ;; Tests.
89 ("python-oslotest" ,python-oslotest)))
90 (home-page "http://www.openstack.org/")
91 (synopsis
92 "Find deprecated patterns and strategies in Python code")
93 (description
94 "This package provides a collection of Python deprecation patterns and
95 strategies that help you collect your technical debt in a non-destructive
96 manner.")
97 (license asl2.0)))
98
99 (define-public python2-debtcollector
100 (package-with-python2 python-debtcollector))
101
102 (define-public python-hacking
103 (package
104 (name "python-hacking")
105 (version "0.10.2")
106 (source
107 (origin
108 (method url-fetch)
109 (uri (pypi-uri "hacking" version))
110 (sha256
111 (base32
112 "1a310k3dv04jg7zvmk37h2ql7y9kf4hvdxb74bjlwdxgmy6h4wap"))))
113 (build-system python-build-system)
114 (propagated-inputs
115 `(("python-flake8-2.2.4" ,python-flake8-2.2.4)
116 ("python-mccabe-0.2.1" ,python-mccabe-0.2.1)
117 ("python-pbr" ,python-pbr)
118 ("python-pep8-1.5.7" ,python-pep8-1.5.7)
119 ("python-pyflakes-0.8.1" ,python-pyflakes-0.8.1)
120 ("python-six" ,python-six)))
121 (inputs
122 `(("python-setuptools" ,python-setuptools)
123 ;; Tests
124 ("python-testscenarios" ,python-testscenarios)))
125 (home-page "http://github.com/openstack-dev/hacking")
126 (synopsis "OpenStack hacking guideline enforcement")
127 (description
128 "Python-hacking is a set of flake8 plugins that test and enforce the
129 @uref{http://docs.openstack.org/developer/hacking/, OpenStack style
130 guidelines}.")
131 (license asl2.0)))
132
133 (define-public python2-hacking
134 (package-with-python2 python-hacking))
135
136 (define-public python-mox3
137 (package
138 (name "python-mox3")
139 (version "0.12.0")
140 (source
141 (origin
142 (method url-fetch)
143 (uri (pypi-uri "mox3" version))
144 (sha256
145 (base32
146 "1pwz98q098cb8xxf8yryq21nvklc7hla880bsrq4y3j6bprw3iaj"))))
147 (build-system python-build-system)
148 (inputs
149 `(("python-fixtures" ,python-fixtures)
150 ("python-pbr" ,python-pbr)
151 ("python-setuptools" ,python-setuptools)
152 ("python-six" ,python-six)
153 ("python-testtools" ,python-testtools)))
154 (home-page "http://www.openstack.org/")
155 (synopsis "Mock object framework for Python")
156 (description
157 "Mox3 is an unofficial port of the Google mox framework
158 (http://code.google.com/p/pymox/) to Python 3. It was meant to be as compatible
159 with mox as possible, but small enhancements have been made. The library was
160 tested on Python version 3.2, 2.7 and 2.6.")
161 (license asl2.0)))
162
163 (define-public python-os-client-config
164 (package
165 (name "python-os-client-config")
166 (version "1.12.0")
167 (source
168 (origin
169 (method url-fetch)
170 (uri (pypi-uri "os-client-config" version))
171 (sha256
172 (base32
173 "1vjn7667pswnmpqv6ngwyqm2xn46w90hi5b4pv2grwfz751cn1lf"))))
174 (build-system python-build-system)
175 (arguments
176 `(#:tests? #f)) ;; Circular dependency with python-oslotest
177 (inputs
178 `(("python-appdirs" ,python-appdirs)
179 ("python-fixtures" ,python-fixtures)
180 ("python-mimeparse" ,python-mimeparse)
181 ("python-pbr" ,python-pbr)
182 ("python-pyyaml" ,python-pyyaml)
183 ("python-testrepository" ,python-testrepository)
184 ("python-setuptools" ,python-setuptools)
185 ("python-testscenarios" ,python-testscenarios)
186 ("python-testtools" ,python-testtools)))
187 (home-page "http://www.openstack.org/")
188 (synopsis
189 "OpenStack Client Configuration Library")
190 (description
191 "The OpenStack Client Configuration Library is a library for collecting
192 client configuration for using an OpenStack cloud in a consistent and
193 comprehensive manner.")
194 (license asl2.0)))
195
196 (define-public python2-os-client-config
197 (package-with-python2 python-os-client-config))
198
199 (define-public python2-mox3
200 (package-with-python2 python-mox3))
201
202 (define-public python-os-testr
203 (package
204 (name "python-os-testr")
205 (version "0.4.2")
206 (source
207 (origin
208 (method url-fetch)
209 (uri (pypi-uri "os-testr" version))
210 (sha256
211 (base32
212 "0474z0mxb7y3vfk4s097wf1mzji5d135vh27cvlh9q17rq3x9r3w"))))
213 (build-system python-build-system)
214 (arguments
215 ;; os-testr uses itself to run the tests. It seems like pbr writes the
216 ;; exectuable in the virtualenv when using tox. Not sure how to do this
217 ;; when building the package. Skip the tests for now.
218 `(#:tests? #f))
219 (propagated-inputs
220 `(("python-pbr" ,python-pbr)
221 ("python-subunit" ,python-subunit)
222 ("python-testtools" ,python-testtools)))
223 (inputs
224 `(("python-babel" ,python-babel)
225 ("python-setuptools" ,python-setuptools)))
226 (home-page "http://www.openstack.org/")
227 (synopsis "Testr wrapper to provide functionality for OpenStack projects")
228 (description
229 "Os-testr provides developers with a testr wrapper and an output filter
230 for subunit.")
231 (license asl2.0)))
232
233 (define-public python2-os-testr
234 (package-with-python2 python-os-testr))
235
236 (define-public python-pbr
237 (package
238 (name "python-pbr")
239 (version "1.8.1")
240 (source
241 (origin
242 (method url-fetch)
243 (uri (string-append
244 "https://pypi.python.org/packages/source/p/pbr/pbr-"
245 version
246 ".tar.gz"))
247 (sha256
248 (base32
249 "0jcny36cf3s8ar5r4a575npz080hndnrfs4np1fqhv0ym4k7c4p2"))))
250 (build-system python-build-system)
251 (arguments
252 `(#:tests? #f)) ;; Most tests seem to use the Internet.
253 (propagated-inputs
254 `(("python-testrepository" ,python-testrepository)
255 ("git" ,git))) ;; pbr actually uses the "git" binary.
256 (inputs
257 `(("python-fixtures" ,python-fixtures)
258 ("python-mimeparse" ,python-mimeparse)
259 ("python-mock" ,python-mock)
260 ("python-setuptools" ,python-setuptools)
261 ("python-six" ,python-six)
262 ("python-sphinx" ,python-sphinx)
263 ("python-testrepository" ,python-testrepository)
264 ("python-testresources" ,python-testresources)
265 ("python-testscenarios" ,python-testscenarios)
266 ("python-testtools" ,python-testtools)
267 ("python-virtualenv" ,python-virtualenv)))
268 (home-page "https://launchpad.net/pbr")
269 (synopsis "Change the default behavior of Python’s setuptools")
270 (description
271 "Python Build Reasonableness (PBR) is a library that injects some useful
272 and sensible default behaviors into your setuptools run.")
273 (license asl2.0)))
274
275 (define-public python2-pbr
276 (package-with-python2 python-pbr))
277
278 (define-public python-requests-mock
279 (package
280 (name "python-requests-mock")
281 (version "0.7.0")
282 (source
283 (origin
284 (method url-fetch)
285 (uri (pypi-uri "requests-mock" version))
286 (sha256
287 (base32
288 "0s6mrpiv2w0km39qvl1pq2d56xblnm57p369qdp5j1a55ncica7f"))))
289 (build-system python-build-system)
290 (propagated-inputs
291 `(("python-requests" ,python-requests)
292 ("python-six" ,python-six)))
293 (inputs
294 `(("python-mock" ,python-mock)
295 ("python-pbr" ,python-pbr)
296 ("python-setuptools" ,python-setuptools)))
297 (home-page "https://requests-mock.readthedocs.org/")
298 (synopsis "Mock out responses from the requests package")
299 (description
300 "This module provides a building block to stub out the HTTP requests
301 portions of your testing code.")
302 (license asl2.0)))
303
304 (define-public python2-requests-mock
305 (package-with-python2 python-requests-mock))
306
307 (define-public python-stevedore
308 (package
309 (name "python-stevedore")
310 (version "1.9.0")
311 (source
312 (origin
313 (method url-fetch)
314 (uri (pypi-uri "stevedore" version))
315 (sha256
316 (base32
317 "01pcrdqsb6ca7hmqwm11b3baj6ml8yz9pxawrgvxb3j9824906fc"))))
318 (build-system python-build-system)
319 (propagated-inputs
320 `(("python-six" ,python-six)))
321 (inputs
322 `(("python-pbr" ,python-pbr)
323 ("python-setuptools" ,python-setuptools)
324 ;; Tests
325 ("python-docutils" ,python-docutils)
326 ("python-mock" ,python-mock)
327 ("python-oslotest" ,python-oslotest)
328 ("python-sphinx" ,python-sphinx)))
329 (home-page "https://github.com/dreamhost/stevedore")
330 (synopsis "Manage dynamic plugins for Python applications")
331 (description
332 "Python makes loading code dynamically easy, allowing you to configure
333 and extend your application by discovering and loading extensions (“plugins”)
334 at runtime. Many applications implement their own library for doing this,
335 using __import__ or importlib. stevedore avoids creating yet another extension
336 mechanism by building on top of setuptools entry points. The code for managing
337 entry points tends to be repetitive, though, so stevedore provides manager
338 classes for implementing common patterns for using dynamically loaded
339 extensions.")
340 (license asl2.0)))
341
342 (define-public python2-stevedore
343 (package-with-python2 python-stevedore))
344
345 (define-public python-tempest-lib
346 (package
347 (name "python-tempest-lib")
348 (version "0.11.0")
349 (source
350 (origin
351 (method url-fetch)
352 (uri (pypi-uri "tempest-lib" version))
353 (sha256
354 (base32
355 "1q4wpqcg0yv99mr5gc43wsfirlqdjz90npyghy3mn5f6lby2yikg"))))
356 (build-system python-build-system)
357 (arguments
358 `(#:phases
359 (modify-phases %standard-phases
360 (add-before
361 'check 'pre-check
362 (lambda _
363 (substitute* "tempest_lib/tests/cli/test_execute.py"
364 (("/bin/ls") (which "ls"))))))))
365 (propagated-inputs
366 `(("python-fixtures" ,python-fixtures)
367 ("python-httplib2" ,python-httplib2)
368 ("python-iso8601" ,python-iso8601)
369 ("python-jsonschema" ,python-jsonschema)
370 ("python-oslo.log" ,python-oslo.log)
371 ("python-paramiko" ,python-paramiko)
372 ("python-pbr" ,python-pbr)
373 ("python-six" ,python-six)))
374 (inputs
375 `(("python-babel" ,python-babel)
376 ("python-mock" ,python-mock)
377 ("python-os-testr" ,python-os-testr)
378 ("python-oslotest" ,python-oslotest)
379 ("python-setuptools" ,python-setuptools)))
380 (home-page "http://www.openstack.org/")
381 (synopsis "OpenStack functional testing library")
382 (description
383 "Tempest-lib is a functional testing library for OpenStack. It provides
384 common features used in Tempest.")
385 (license asl2.0)))
386
387 (define-public python2-tempest-lib
388 (package-with-python2 python-tempest-lib))
389
390 ;; Packages from the Oslo library
391 (define-public python-oslo.config
392 (package
393 (name "python-oslo.config")
394 (version "2.4.0")
395 (source
396 (origin
397 (method url-fetch)
398 (uri (string-append
399 "https://pypi.python.org/packages/source/o/oslo.config/oslo.config-"
400 version
401 ".tar.gz"))
402 (sha256
403 (base32
404 "13r778jfb0fhna37c2pd1f2xipnsbd7zli7qhn96acrzymrwj5k1"))))
405 (build-system python-build-system)
406 (propagated-inputs
407 `(("python-netaddr" ,python-netaddr)
408 ("python-six" ,python-six)
409 ("python-stevedore" ,python-stevedore)))
410 (inputs
411 `(("python-pbr" ,python-pbr)
412 ("python-setuptools" ,python-setuptools)
413 ;; Tests
414 ("python-oslo.i18n" ,python-oslo.i18n)
415 ("python-mock" ,python-mock)
416 ("python-oslotest" ,python-oslotest)
417 ("python-testscenarios" ,python-testscenarios)))
418 (home-page "https://launchpad.net/oslo")
419 (synopsis "Oslo Configuration API")
420 (description
421 "The Oslo configuration API supports parsing command line arguments and
422 .ini style configuration files.")
423 (license asl2.0)))
424
425 (define-public python2-oslo.config
426 (package-with-python2 python-oslo.config))
427
428 (define-public python-oslo.context
429 (package
430 (name "python-oslo.context")
431 (version "1.0.0")
432 (source
433 (origin
434 (method url-fetch)
435 (uri (pypi-uri "oslo.context" version))
436 (sha256
437 (base32
438 "0kvha0rs9295njyl2z6n6zm5dapi5mrl5zwjm0m6ldqrvccyf8c3"))))
439 (build-system python-build-system)
440 (inputs
441 `(("python-babel" ,python-babel)
442 ("python-pbr" ,python-pbr)
443 ("python-setuptools" ,python-setuptools)
444 ;; Tests.
445 ("python-oslotest" ,python-oslotest)))
446 (home-page "http://launchpad.net/oslo")
447 (synopsis "Oslo context library")
448 (description
449 "The Oslo context library has helpers to maintain useful information
450 about a request context. The request context is usually populated in the WSGI
451 pipeline and used by various modules such as logging.")
452 (license asl2.0)))
453
454 (define-public python2-oslo.context
455 (package-with-python2 python-oslo.context))
456
457 (define-public python-oslo.i18n
458 (package
459 (name "python-oslo.i18n")
460 (version "3.0.0")
461 (source
462 (origin
463 (method url-fetch)
464 (uri (pypi-uri "oslo.i18n" version))
465 (sha256
466 (base32
467 "0bpb1c20sm8my650gl824nzaip83bfn8hr91s65k5ncmyh8hb6pl"))))
468 (build-system python-build-system)
469 (propagated-inputs
470 `(("python-babel" ,python-babel)
471 ("python-six" ,python-six)))
472 (inputs
473 `(("python-pbr" ,python-pbr)
474 ("python-setuptools" ,python-setuptools)
475 ;; Tests
476 ("python-mock" ,python-mock)
477 ("python-mox3" ,python-mox3)
478 ("python-oslotest" ,python-oslotest)
479 ("python-testscenarios" ,python-testscenarios)))
480 (home-page "http://launchpad.net/oslo")
481 (synopsis "Oslo internationalization (i18n) library")
482 (description
483 "The oslo.i18n library contain utilities for working with
484 internationalization (i18n) features, especially translation for text strings
485 in an application or library.")
486 (license asl2.0)))
487
488 (define-public python2-oslo.i18n
489 (package-with-python2 python-oslo.i18n))
490
491 (define-public python-oslo.log
492 (package
493 (name "python-oslo.log")
494 (version "1.6.0")
495 (source
496 (origin
497 (method url-fetch)
498 (uri (string-append
499 "https://pypi.python.org/packages/source/o/oslo.log/oslo.log-"
500 version
501 ".tar.gz"))
502 (sha256
503 (base32
504 "1fhy6yvbd565nv4x4i3ppyrlbmz3yy9d0xsvw5nkqsa7g43nmf8z"))))
505 (build-system python-build-system)
506 (propagated-inputs
507 `(("python-debtcollector" ,python-debtcollector)
508 ("python-oslo.config" ,python-oslo.config)
509 ("python-oslo.context" ,python-oslo.context)
510 ("python-oslo.i18n" ,python-oslo.i18n)
511 ("python-oslo.utils" ,python-oslo.utils)
512 ("python-oslo.serialization" ,python-oslo.serialization)
513 ("python-six" ,python-six)))
514 (inputs
515 `(("python-babel" ,python-babel)
516 ("python-iso8601" ,python-iso8601)
517 ("python-mock" ,python-mock)
518 ("python-oslotest" ,python-oslotest)
519 ("python-pbr" ,python-pbr)
520 ("python-setuptools" ,python-setuptools)))
521 (home-page "http://launchpad.net/oslo")
522 (synopsis "Python logging library of the Oslo project")
523 (description
524 "The oslo.log (logging) configuration library provides standardized
525 configuration for all OpenStack projects. It also provides custom formatters,
526 handlers and support for context specific logging (like resource id’s etc).")
527 (license asl2.0)))
528
529 (define-public python2-oslo.log
530 (package-with-python2 python-oslo.log))
531
532 (define-public python-oslo.serialization
533 (package
534 (name "python-oslo.serialization")
535 (version "1.9.0")
536 (source
537 (origin
538 (method url-fetch)
539 (uri (string-append
540 "https://pypi.python.org/packages/source/o/oslo.serialization/"
541 "oslo.serialization-" version ".tar.gz"))
542 (sha256
543 (base32
544 "00qaxg155s61ylh4fqc7m5fh0gijf33khhai9xvcsc9k106i3c9c"))))
545 (build-system python-build-system)
546 (propagated-inputs
547 `(("python-iso8601" ,python-iso8601)
548 ("python-netaddr" ,python-netaddr)
549 ("python-oslo.utils" ,python-oslo.utils)
550 ("python-simplejson" ,python-simplejson)
551 ("python-six" ,python-six)
552 ("python-pytz" ,python-pytz)))
553 (inputs
554 `(("python-babel" ,python-babel)
555 ("python-pbr" ,python-pbr)
556 ("python-setuptools" ,python-setuptools)
557 ;; Tests.
558 ("python-mock" ,python-mock)
559 ("python-oslo.i18n" ,python-oslo.i18n)
560 ("python-oslotest" ,python-oslotest)))
561 (home-page "http://launchpad.net/oslo")
562 (synopsis "Oslo serialization library")
563 (description
564 "The oslo.serialization library provides support for representing objects
565 in transmittable and storable formats, such as JSON and MessagePack.")
566 (license asl2.0)))
567
568 (define-public python2-oslo.serialization
569 (package-with-python2 python-oslo.serialization))
570
571 (define-public python-oslosphinx
572 (package
573 (name "python-oslosphinx")
574 (version "3.1.0")
575 (source
576 (origin
577 (method url-fetch)
578 (uri (pypi-uri "oslosphinx" version))
579 (sha256
580 (base32
581 "0zcshdc9s1f7hnvg0fm2ps5rak3dpnm8kqg4i21lknhmsvb7p5cb"))))
582 (build-system python-build-system)
583 (propagated-inputs
584 `(("python-requests" ,python-requests)))
585 (inputs
586 `(("python-pbr" ,python-pbr)
587 ("python-docutils" ,python-docutils)
588 ("python-hacking" ,python-hacking)
589 ("python-setuptools" ,python-setuptools)
590 ("python-sphinx" ,python-sphinx)))
591 (home-page "http://www.openstack.org/")
592 (synopsis "OpenStack sphinx extensions and theme")
593 (description
594 "This package provides themes and extensions for Sphinx documentation
595 from the OpenStack project.")
596 (license asl2.0)))
597
598 (define-public python2-oslosphinx
599 (package-with-python2 python-oslosphinx))
600
601 (define-public python-oslotest
602 (package
603 (name "python-oslotest")
604 (version "1.10.0")
605 (source
606 (origin
607 (method url-fetch)
608 (uri (string-append
609 "https://pypi.python.org/packages/source/o/oslotest/oslotest-"
610 version
611 ".tar.gz"))
612 (sha256
613 (base32
614 "0l3ny48ddz5xbf0v4r0jv1yhbdzinc2vy0lybhdkmx3xy0b886fs"))))
615 (build-system python-build-system)
616 (propagated-inputs
617 `(("python-fixtures" ,python-fixtures)
618 ("python-mock" ,python-mock)
619 ("python-mox3" ,python-mox3)
620 ("python-six" ,python-six)))
621 (inputs
622 `(("python-pbr" ,python-pbr)
623 ("python-os-client-config" ,python-os-client-config)
624 ("python-setuptools" ,python-setuptools)
625 ("python-subunit" ,python-subunit)
626 ("python-testrepository" ,python-testrepository)
627 ("python-testscenarios" ,python-testscenarios)
628 ("python-testtools" ,python-testtools)))
629 (home-page "http://launchpad.net/oslo")
630 (synopsis "Oslo test framework")
631 (description
632 "The Oslo Test framework provides common fixtures, support for debugging,
633 and better support for mocking results.")
634 (license asl2.0)))
635
636 (define-public python2-oslotest
637 (package-with-python2 python-oslotest))
638
639 (define-public python-oslo.utils
640 (package
641 (name "python-oslo.utils")
642 (version "2.5.0")
643 (source
644 (origin
645 (method url-fetch)
646 (uri (string-append
647 "https://pypi.python.org/packages/source/o/oslo.utils/oslo.utils-"
648 version
649 ".tar.gz"))
650 (sha256
651 (base32
652 "11b073gblhzkxhi1j6sqk3apq2ll8xhi9h9g9kxzx9dycqdq0qp0"))
653 (snippet
654 '(begin
655 ;; FIXME: setuptools fails to import this file during the test
656 ;; phase.
657 (delete-file "oslo_utils/tests/test_netutils.py")))))
658 (build-system python-build-system)
659 (propagated-inputs
660 `(("python-debtcollector" ,python-debtcollector)
661 ("python-oslo.i18n" ,python-oslo.i18n)
662 ("python-iso8601" ,python-iso8601)
663 ("python-monotonic" ,python-monotonic)
664 ("python-netaddr" ,python-netaddr)
665 ("python-netifaces" ,python-netifaces)
666 ("python-pytz" ,python-pytz)
667 ("python-six" ,python-six)))
668 (inputs
669 `(("python-babel" ,python-babel)
670 ("python-pbr" ,python-pbr)
671 ("python-setuptools" ,python-setuptools)
672 ;; Tests.
673 ("python-oslotest" ,python-oslotest)
674 ("python-mock" ,python-mock)
675 ("python-mox3" ,python-mox3)
676 ("python-testscenarios" ,python-testscenarios)))
677 (home-page "http://launchpad.net/oslo")
678 (synopsis "Oslo utility library")
679 (description
680 "The @code{oslo.utils} library provides support for common utility type
681 functions, such as encoding, exception handling, string manipulation, and time
682 handling.")
683 (license asl2.0)))
684
685 (define-public python2-oslo.utils
686 (package-with-python2 python-oslo.utils))