gnu: retroarch: Update to 1.3.4.
[jackhill/guix/guix.git] / gnu / packages / lua.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2014 Raimon Grau <raimonster@gmail.com>
4 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
5 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages lua)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages readline))
29
30 (define-public lua
31 (package
32 (name "lua")
33 (version "5.2.3")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "http://www.lua.org/ftp/lua-"
37 version ".tar.gz"))
38 (sha256
39 (base32 "0b8034v1s82n4dg5rzcn12067ha3nxaylp2vdp8gg08kjsbzphhk"))
40 (patches (search-patches "lua-pkgconfig.patch"
41 "lua52-liblua-so.patch"))))
42 (build-system gnu-build-system)
43 (inputs `(("readline" ,readline)))
44 (arguments
45 '(#:modules ((guix build gnu-build-system)
46 (guix build utils)
47 (srfi srfi-1))
48 #:test-target "test"
49 #:phases (alist-replace
50 'build
51 (lambda _ (zero? (system* "make" "CFLAGS=-fPIC" "linux")))
52 (alist-replace
53 'install
54 (lambda* (#:key outputs #:allow-other-keys)
55 (let ((out (assoc-ref outputs "out")))
56 (zero? (system* "make" "install"
57 (string-append "INSTALL_TOP=" out)
58 (string-append "INSTALL_MAN=" out
59 "/share/man/man1")))))
60 (alist-delete 'configure %standard-phases)))))
61 (home-page "http://www.lua.org/")
62 (synopsis "Embeddable scripting language")
63 (description
64 "Lua is a powerful, fast, lightweight, embeddable scripting language. Lua
65 combines simple procedural syntax with powerful data description constructs
66 based on associative arrays and extensible semantics. Lua is dynamically typed,
67 runs by interpreting bytecode for a register-based virtual machine, and has
68 automatic memory management with incremental garbage collection, making it ideal
69 for configuration, scripting, and rapid prototyping.")
70 (license x11)))
71
72 (define-public lua-5.1
73 (package (inherit lua)
74 (version "5.1.5")
75 (source (origin
76 (method url-fetch)
77 (uri (string-append "http://www.lua.org/ftp/lua-"
78 version ".tar.gz"))
79 (sha256
80 (base32 "0cskd4w0g6rdm2q8q3i4n1h3j8kylhs3rq8mxwl9vwlmlxbgqh16"))
81 (patches (search-patches "lua51-liblua-so.patch"))))))
82
83 (define-public luajit
84 (package
85 (name "luajit")
86 (version "2.0.3")
87 (source (origin
88 (method url-fetch)
89 (uri (string-append "http://luajit.org/download/LuaJIT-"
90 version ".tar.gz"))
91 (sha256
92 (base32 "0ydxpqkmsn2c341j4r2v6r5r0ig3kbwv3i9jran3iv81s6r6rgjm"))
93 (patches (search-patches "luajit-symlinks.patch"
94 "luajit-no_ldconfig.patch"))))
95 (build-system gnu-build-system)
96 (arguments
97 '(#:tests? #f ;luajit is distributed without tests
98 #:phases (alist-delete 'configure %standard-phases)
99 #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))))
100 (home-page "http://www.luajit.org/")
101 (synopsis "Just in time compiler for Lua programming language version 5.1")
102 (description
103 "LuaJIT is a Just-In-Time Compiler (JIT) for the Lua
104 programming language. Lua is a powerful, dynamic and light-weight programming
105 language. It may be embedded or used as a general-purpose, stand-alone
106 language.")
107 (license x11)))