gnu: Add confusion-mdl.
[jackhill/guix/guix.git] / gnu / packages / readline.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
5 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages readline)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages ncurses)
26 #:use-module (gnu packages perl)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system gnu)
30 #:use-module (guix utils)
31 #:use-module (ice-9 format))
32
33 (define (patch-url seqno)
34 (format #f "mirror://gnu/readline/readline-7.0-patches/readline70-~3,'0d" seqno))
35
36 (define (readline-patch seqno sha256)
37 "Return the origin of Readline patch SEQNO, with expected hash SHA256"
38 (origin
39 (method url-fetch)
40 (uri (patch-url seqno))
41 (sha256 sha256)))
42
43 (define-syntax-rule (patch-series (seqno hash) ...)
44 (list (readline-patch seqno (base32 hash))
45 ...))
46
47 (define %patch-series-7.0
48 (patch-series
49 (1 "0xm3sxvwmss7ddyfb11n6pgcqd1aglnpy15g143vzcf75snb7hcs")
50 (2 "0n1dxmqsbjgrfxb1hgk5c6lsraw4ncbnzxlsx7m35nym6lncjiw7")
51 (3 "1027kmymniizcy0zbdlrczxfx3clxcdln5yq05q9yzlc6y9slhwy")))
52
53 (define-public readline
54 (package
55 (name "readline")
56 (version (string-append "7.0."
57 (number->string (length %patch-series-7.0))))
58 (source (origin
59 (method url-fetch)
60 (uri (string-append "mirror://gnu/readline/readline-"
61 (version-major+minor version) ".tar.gz"))
62 (sha256
63 (base32
64 "0d13sg9ksf982rrrmv5mb6a2p4ys9rvg9r71d6il0vr8hmql63bm"))
65 (patches (append
66 %patch-series-7.0
67 (search-patches "readline-link-ncurses.patch")))
68 (patch-flags '("-p0"))))
69 (build-system gnu-build-system)
70 (propagated-inputs `(("ncurses" ,ncurses)))
71 (arguments `(#:configure-flags
72 (list (string-append "LDFLAGS=-Wl,-rpath -Wl,"
73 (assoc-ref %build-inputs "ncurses")
74 "/lib")
75
76 ;; This test does an 'AC_TRY_RUN', which aborts when
77 ;; cross-compiling, so provide the correct answer.
78 ,@(if (%current-target-system)
79 '("bash_cv_wcwidth_broken=no")
80 '())
81 ;; MinGW: ncurses provides the termcap api.
82 ,@(if (target-mingw?)
83 '("bash_cv_termcap_lib=ncurses")
84 '()))
85
86 ,@(if (target-mingw?)
87 ;; MinGW: termcap in ncurses
88 ;; some SIG_* #defined in _POSIX
89 '(#:make-flags '("TERMCAP_LIB=-lncurses"
90 "CPPFLAGS=-D_POSIX -D'chown(f,o,g)=0'"))
91 '())))
92 (synopsis "Edit command lines while typing, with history support")
93 (description
94 "The GNU readline library allows users to edit command lines as they
95 are typed in. It can maintain a searchable history of previously entered
96 commands, letting you easily recall, edit and re-enter past commands. It
97 features both Emacs-like and vi-like keybindings, making its usage
98 comfortable for anyone.")
99 (license gpl3+)
100 (home-page "https://savannah.gnu.org/projects/readline/")))
101
102 (define-public readline-6.2
103 (package (inherit readline)
104 (version "6.2")
105 (source (origin (inherit (package-source readline))
106 (method url-fetch)
107 (uri (string-append "mirror://gnu/readline/readline-"
108 version ".tar.gz"))
109 (patches (search-patches "readline-6.2-CVE-2014-2524.patch"))
110 (patch-flags '("-p0"))
111 (sha256
112 (base32
113 "10ckm2bd2rkxhvdmj7nmbsylmihw0abwcsnxf8y27305183rd9kr"))))))
114
115 (define-public rlwrap
116 (package
117 (name "rlwrap")
118 (version "0.43")
119 (source
120 (origin
121 (method url-fetch)
122 (uri (string-append "https://github.com/hanslub42/rlwrap/releases/"
123 "download/v" version "/"
124 name "-" version ".tar.gz"))
125 (sha256
126 (base32
127 "0bzb7ylk2770iv59v2d0gypb21y2xn87m299s9rqm6rdi2vx11lf"))))
128 (build-system gnu-build-system)
129 (native-inputs
130 `(("perl" ,perl)))
131 (inputs
132 `(("readline" ,readline)))
133 (synopsis "Wrapper to allow the editing of keyboard commands")
134 (description
135 "Rlwrap is a 'readline wrapper', a small utility that uses the GNU
136 readline library to allow the editing of keyboard input for any command. You
137 should consider rlwrap especially when you need user-defined completion (by way
138 of completion word lists) and persistent history, or if you want to program
139 'special effects' using the filter mechanism.")
140 (home-page "https://github.com/hanslub42/rlwrap")
141 (license gpl2+)))