gnu: Add confusion-mdl.
[jackhill/guix/guix.git] / gnu / packages / gd.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
6 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
8 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages gd)
26 #:use-module (guix packages)
27 #:use-module (guix build-system gnu)
28 #:use-module (guix build-system perl)
29 #:use-module (guix download)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages perl)
32 #:use-module (gnu packages image)
33 #:use-module (gnu packages imagemagick)
34 #:use-module (gnu packages fontutils)
35 #:use-module (gnu packages compression)
36 #:use-module (gnu packages pkg-config)
37 #:use-module ((guix licenses) #:select (non-copyleft perl-license)))
38
39 (define-public gd
40 (package
41 (name "gd")
42 (replacement gd/fixed)
43 ;; Note: With libgd.org now pointing to github.com, genuine old
44 ;; tarballs are no longer available. Notably, versions 2.0.x are
45 ;; missing.
46 (version "2.2.5")
47 (source (origin
48 (method url-fetch)
49 (uri (string-append
50 "https://github.com/libgd/libgd/releases/download/gd-"
51 version "/libgd-" version ".tar.xz"))
52 (sha256
53 (base32
54 "0lfy5f241sbv8s3splm2zqiaxv7lxrcshh875xryryk7yk5jqc4c"))
55 (patches (search-patches "gd-fix-tests-on-i686.patch"
56 "gd-freetype-test-failure.patch"))))
57 (build-system gnu-build-system)
58 (arguments
59 ;; As recommended by github.com/libgd/libgd/issues/278 to fix rounding
60 ;; issues on aarch64 and other architectures.
61 `(#:make-flags '("CFLAGS=-ffp-contract=off")
62 #:phases
63 (modify-phases %standard-phases
64 ;; This test is known to fail on i686-linux:
65 ;; https://github.com/libgd/libgd/issues/359
66 ;; TODO Replace this substitution with an upstream bug fix.
67 (add-after 'unpack 'disable-failing-test
68 (lambda _
69 (substitute* "tests/gdimagegrayscale/basic.c"
70 (("return gdNumFailures\\(\\)")
71 "return 0"))
72 #t)))))
73 (native-inputs
74 `(("pkg-config" ,pkg-config)))
75 (inputs
76 `(("freetype" ,freetype)
77 ("libpng" ,libpng)
78 ("zlib" ,zlib)))
79 (propagated-inputs
80 `(("fontconfig" ,fontconfig)
81 ("libjpeg" ,libjpeg)))
82 (home-page "http://www.libgd.org/")
83 (synopsis "Library for the dynamic creation of images by programmers")
84 (description
85 "GD is a library for the dynamic creation of images by programmers. GD
86 is written in C, and \"wrappers\" are available for Perl, PHP and other
87 languages. GD creates PNG, JPEG, GIF, WebP, XPM, BMP images, among other
88 formats. GD is commonly used to generate charts, graphics, thumbnails, and
89 most anything else, on the fly. While not restricted to use on the web, the
90 most common applications of GD involve website development.")
91 (license (non-copyleft "file://COPYING"
92 "See COPYING file in the distribution."))
93 (properties '((cpe-name . "libgd")))))
94
95 (define-public gd/fixed
96 (hidden-package
97 (package
98 (inherit gd)
99 (source (origin
100 (inherit (package-source gd))
101 (patches (append (origin-patches (package-source gd))
102 (search-patches "gd-CVE-2018-5711.patch"
103 "gd-CVE-2018-1000222.patch"))))))))
104
105 (define-public perl-gd
106 (package
107 (name "perl-gd")
108 (version "2.69")
109 (source
110 (origin
111 (method url-fetch)
112 (uri (string-append "mirror://cpan/authors/id/R/RU/RURBAN/"
113 "GD-" version ".tar.gz"))
114 (sha256
115 (base32
116 "0palmq7l42fibqxhrabnjm7di4q8kciq9323902d717x3i4jvc6x"))))
117 (build-system perl-build-system)
118 (inputs
119 `(("fontconfig" ,fontconfig)
120 ("freetype" ,freetype)
121 ("gd" ,gd)
122 ("libpng" ,libpng)
123 ("libjpeg" ,libjpeg)
124 ("zlib" ,zlib)))
125 (arguments
126 `(#:make-maker-flags
127 (list (string-append "--lib_jpeg_path="
128 (assoc-ref %build-inputs "libjpeg")))))
129 (home-page "https://metacpan.org/release/GD")
130 (synopsis "Perl interface to the GD graphics library")
131 (description "GD.pm is an autoloadable interface module for libgd, a
132 popular library for creating and manipulating PNG files. With this library
133 you can create PNG images on the fly or modify existing files.")
134 (license perl-license)))
135
136 (define-public perl-gd-securityimage
137 (package
138 (name "perl-gd-securityimage")
139 (version "1.73")
140 (source
141 (origin
142 (method url-fetch)
143 (uri (string-append "mirror://cpan/authors/id/B/BU/BURAK/"
144 "GD-SecurityImage-" version ".tar.gz"))
145 (sha256
146 (base32
147 "1kaxs67rfd4w46lxgcg3pa05a596l0h1k8n4zk2gwrrar4022wpx"))))
148 (build-system perl-build-system)
149 (arguments
150 '(#:phases
151 (modify-phases %standard-phases
152 (add-after 'unpack 'set-env
153 (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1"))))))
154 (native-inputs
155 `(("perl-module-build" ,perl-module-build)))
156 (propagated-inputs
157 `(("perl-gd" ,perl-gd)
158 ("perl-image-magick" ,perl-image-magick)))
159 (home-page "https://metacpan.org/release/GD-SecurityImage")
160 (synopsis "Security image generator")
161 (description "This module provides a basic interface to create
162 security (captcha) images. The final output is the actual graphic data, the
163 mime type of the graphic, and the created random string. The module also has
164 some \"styles\" that are used to create the background (or foreground) of the
165 image.")
166 (license perl-license)))