gnu: Add texlive-todonotes.
[jackhill/guix/guix.git] / gnu / packages / visidata.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages visidata)
20 #:use-module (gnu packages databases)
21 #:use-module (gnu packages python-science)
22 #:use-module (gnu packages python-web)
23 #:use-module (gnu packages python-xyz)
24 #:use-module (gnu packages time)
25 #:use-module (gnu packages xml)
26 #:use-module (guix build-system python)
27 #:use-module (guix download)
28 #:use-module ((guix licenses) #:prefix license:)
29 #:use-module (guix packages))
30
31 (define-public visidata
32 (package
33 (name "visidata")
34 (version "1.5.2")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (pypi-uri "visidata" version))
39 (sha256
40 (base32
41 "10adfyn4gkisvciqawgh2lakkhhnjjxiyp7mzbgcwkq1b3sigpf1"))))
42 (build-system python-build-system)
43 ;; Tests disabled because they are not packaged with the source tarball.
44 ;; Upstream suggests tests will be packaged with tarball around 2.0 release.
45 (arguments '(#:tests? #f))
46 (inputs
47 `(("python-dateutil" ,python-dateutil)
48 ("python-fonttools" ,python-fonttools)
49 ("python-h5py" ,python-h5py)
50 ("python-lxml" ,python-lxml)
51 ("python-openpyxl" ,python-openpyxl)
52 ("python-pandas" ,python-pandas)
53 ("python-psycopg2" ,python-psycopg2)
54 ("python-pyyaml" ,python-pyyaml)
55 ("python-requests" ,python-requests)
56 ("python-xlrd" ,python-xlrd)))
57 (synopsis "Terminal spreadsheet multitool for discovering and arranging data")
58 (description
59 "VisiData is an interactive multitool for tabular data. It combines the
60 clarity of a spreadsheet, the efficiency of the terminal, and the power of
61 Python, into a lightweight utility which can handle millions of rows.")
62 (home-page "https://www.visidata.org/")
63 (license (list license:gpl3
64 license:expat)))) ;; visidata/vdtui.py