gnu: Add texlive-todonotes.
[jackhill/guix/guix.git] / gnu / packages / cybersecurity.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages cybersecurity)
20 #:use-module (guix download)
21 #:use-module (guix packages)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix build-system python)
24 #:use-module (gnu packages engineering))
25
26 (define-public ropgadget
27 (package
28 (name "ropgadget")
29 (version "6.3")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (pypi-uri "ROPGadget" version))
34 (sha256
35 (base32 "0v34w88if3p4vn46aby24msfnxj6znmkf4848n4d24jnykxcsqk9"))))
36 (build-system python-build-system)
37 (propagated-inputs
38 `(("python-capstone" ,python-capstone)))
39 (home-page "http://shell-storm.org/project/ROPgadget/")
40 (synopsis "Semiautomatic return oriented programming")
41 (description
42 "This tool lets you search for @acronym{ROP, Return Oriented Programming}
43 gadgets in binaries. Some facilities are included for automatically generating
44 chains of gadgets to execute system calls.")
45 (license license:bsd-3)))