Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / terminals.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016 Mckinley Olsen <mck.olsen@gmail.com>
4 ;;; Copyright © 2016, 2017 Alex Griffin <a@ajgrf.com>
5 ;;; Copyright © 2016 David Craven <david@craven.ch>
6 ;;; Copyright © 2016, 2017 Ludovic Courtès <ludo@gnu.org>
7 ;;; Copyright © 2016, 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
8 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
10 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
11 ;;; Copyright © 2017 Petter <petter@mykolab.ch>
12 ;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
13 ;;;
14 ;;; This file is part of GNU Guix.
15 ;;;
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
20 ;;;
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
25 ;;;
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
28
29 (define-module (gnu packages terminals)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (guix build utils)
32 #:use-module (guix build-system cmake)
33 #:use-module (guix build-system gnu)
34 #:use-module (guix build-system glib-or-gtk)
35 #:use-module (guix build-system go)
36 #:use-module (guix build-system python)
37 #:use-module (guix download)
38 #:use-module (guix git-download)
39 #:use-module (guix packages)
40 #:use-module (gnu packages)
41 #:use-module (gnu packages autotools)
42 #:use-module (gnu packages check)
43 #:use-module (gnu packages docbook)
44 #:use-module (gnu packages freedesktop)
45 #:use-module (gnu packages gettext)
46 #:use-module (gnu packages gl)
47 #:use-module (gnu packages glib)
48 #:use-module (gnu packages gnome)
49 #:use-module (gnu packages gtk)
50 #:use-module (gnu packages linux)
51 #:use-module (gnu packages ncurses)
52 #:use-module (gnu packages perl)
53 #:use-module (gnu packages perl-check)
54 #:use-module (gnu packages pkg-config)
55 #:use-module (gnu packages python)
56 #:use-module (gnu packages python-web)
57 #:use-module (gnu packages qt)
58 #:use-module (gnu packages textutils)
59 #:use-module (gnu packages wm)
60 #:use-module (gnu packages xdisorg)
61 #:use-module (gnu packages xml)
62 #:use-module (gnu packages xorg)
63 #:use-module (srfi srfi-26))
64
65 (define-public tilda
66 (package
67 (name "tilda")
68 (version "1.4.1")
69 (source (origin
70 (method url-fetch)
71 (uri (string-append "https://github.com/lanoxx/tilda/archive/"
72 "tilda-" version ".tar.gz"))
73 (sha256
74 (base32
75 "0w2hry2bqcqrkik4l100b1a9jlsih6sq8zwhfpl8zzfq20i00lfs"))))
76 (build-system glib-or-gtk-build-system)
77 (arguments
78 '(#:phases (modify-phases %standard-phases
79 (add-before 'patch-source-shebangs 'bootstrap
80 (lambda _
81 (setenv "NOCONFIGURE" "true")
82 (invoke "sh" "autogen.sh"))))))
83 (native-inputs
84 `(("autoconf" ,autoconf)
85 ("automake" ,automake)
86 ("gettext" ,gettext-minimal)
87 ("pkg-config" ,pkg-config)))
88 (inputs
89 `(("libconfuse" ,libconfuse)
90 ("vte" ,vte)))
91 (synopsis "GTK+-based drop-down terminal")
92 (description "Tilda is a terminal emulator similar to normal terminals like
93 gnome-terminal (GNOME) or Konsole (KDE), with the difference that it drops down
94 from the edge of a screen when a certain configurable hotkey is pressed. This
95 is similar to the built-in consoles in some applications. Tilda is highly
96 configurable through a graphical wizard.")
97 (home-page "https://github.com/lanoxx/tilda")
98 (license license:gpl2+)))
99
100 (define-public termite
101 (package
102 (name "termite")
103 (version "13")
104 (source
105 (origin
106 (method git-fetch)
107 (uri (git-reference
108 (url (string-append "https://github.com/thestinger/"
109 name ".git"))
110 (commit (string-append "v" version))
111 (recursive? #t)))
112 (file-name (string-append name "-" version "-checkout"))
113 (sha256
114 (base32
115 "02cn70ygl93ghhkhs3xdxn5b1yadc255v3yp8cmhhyzsv5027hvj"))))
116 (build-system gnu-build-system)
117 (arguments
118 `(#:phases
119 (modify-phases %standard-phases
120 (delete 'configure))
121 #:tests? #f
122 ;; This sets the destination when installing the necessary terminal
123 ;; capability data, which are not provided by 'ncurses'. See
124 ;; <https://lists.gnu.org/archive/html/bug-ncurses/2009-10/msg00031.html>.
125 #:make-flags (list "PREFIX="
126 (string-append "VERSION=v" (version))
127 (string-append "DESTDIR="
128 (assoc-ref %outputs "out")))))
129 (inputs
130 `(("vte" ,vte-ng)
131 ("gtk+" ,gtk+)
132 ("ncurses" ,ncurses)))
133 (native-inputs
134 `(("pkg-config" ,pkg-config)))
135
136 ;; FIXME: This should only be located in 'ncurses'. Nonetheless it is
137 ;; provided for usability reasons. See <https://bugs.gnu.org/22138>.
138 (native-search-paths
139 (list (search-path-specification
140 (variable "TERMINFO_DIRS")
141 (files '("share/terminfo")))))
142 (home-page "https://github.com/thestinger/termite/")
143 (synopsis "Keyboard-centric, VTE-based terminal")
144 (description "Termite is a minimal terminal emulator designed for use with
145 tiling window managers. It is a modal application, similar to Vim, with an
146 insert mode and command mode where keybindings have different functions.")
147
148 ;; Files under util/ are under the Expat license; the rest is LGPLv2+.
149 (license license:lgpl2.0+)))
150
151 (define-public asciinema
152 (package
153 (name "asciinema")
154 (version "1.4.0")
155 (source
156 (origin
157 (method url-fetch)
158 (uri (pypi-uri "asciinema" version))
159 (sha256
160 (base32
161 "1jrf8c8711gkdilmvyv3d37kp8xfvdc5cqighw5k92a6g9z4acgv"))))
162 (build-system python-build-system)
163 (arguments
164 `(#:phases
165 (modify-phases %standard-phases
166 (add-before 'build 'patch-exec-paths
167 (lambda* (#:key inputs #:allow-other-keys)
168 (let ((ncurses (assoc-ref inputs "ncurses")))
169 (substitute* "asciinema/recorder.py"
170 (("'tput'")
171 (string-append "'" ncurses "/bin/tput'"))))
172 #t)))))
173 (inputs `(("ncurses" ,ncurses)))
174 (native-inputs
175 ;; For tests.
176 `(("python-requests" ,python-requests)))
177 (home-page "https://asciinema.org")
178 (synopsis "Terminal session recorder")
179 (description
180 "Use asciinema to record and share your terminal sessions, the right way.
181 Forget screen recording apps and blurry video. Enjoy a lightweight, purely
182 text-based approach to terminal recording.")
183 (license license:gpl3)))
184
185 (define-public libtsm
186 (package
187 (name "libtsm")
188 (version "3")
189 (source (origin
190 (method url-fetch)
191 (uri (string-append
192 "https://freedesktop.org/software/kmscon/releases/"
193 "libtsm-" version ".tar.xz"))
194 (sha256
195 (base32
196 "01ygwrsxfii0pngfikgqsb4fxp8n1bbs47l7hck81h9b9bc1ah8i"))))
197 (build-system gnu-build-system)
198 (native-inputs
199 `(("pkg-config" ,pkg-config)))
200 (inputs
201 `(("libxkbcommon" ,libxkbcommon)))
202 (synopsis "Xterm state machine library")
203 (description "TSM is a state machine for DEC VT100-VT520 compatible
204 terminal emulators. It tries to support all common standards while keeping
205 compatibility to existing emulators like xterm, gnome-terminal, konsole, etc.")
206 (home-page "https://www.freedesktop.org/wiki/Software/libtsm")
207 ;; Hash table implementation is lgpl2.1+ licensed.
208 ;; The wcwidth implementation in external/wcwidth.{h,c} uses a license
209 ;; derived from ISC.
210 ;; UCS-4 to UTF-8 encoding is copied from "terminology" which is released
211 ;; under the bsd 2 license.
212 (license (list license:expat license:lgpl2.1+ license:isc license:bsd-2))))
213
214 (define-public kmscon
215 (package
216 (name "kmscon")
217 (version "8")
218 (source (origin
219 (method url-fetch)
220 (uri (string-append
221 "https://freedesktop.org/software/kmscon/releases/"
222 "kmscon-" version ".tar.xz"))
223 (sha256
224 (base32
225 "0axfwrp3c8f4gb67ap2sqnkn75idpiw09s35wwn6kgagvhf1rc0a"))
226 (modules '((guix build utils)))
227 (snippet
228 ;; Use elogind instead of systemd.
229 '(begin
230 (substitute* "configure"
231 (("libsystemd-daemon libsystemd-login")
232 "libelogind"))
233 (substitute* "src/uterm_systemd.c"
234 (("#include <systemd/sd-login.h>")
235 "#include <elogind/sd-login.h>")
236 ;; We don't have this header.
237 (("#include <systemd/sd-daemon\\.h>")
238 "")
239 ;; Replace the call to 'sd_booted' by the truth value.
240 (("sd_booted\\(\\)")
241 "1"))
242 #t))))
243 (build-system gnu-build-system)
244 (native-inputs
245 `(("pkg-config" ,pkg-config)
246 ("libxslt" ,libxslt) ;to build the man page
247 ("libxml2" ,libxml2) ;for XML_CATALOG_FILES
248 ("docbook-xsl" ,docbook-xsl)))
249 (inputs
250 `(("libdrm" ,libdrm)
251 ("libtsm" ,libtsm)
252 ("libxkbcommon" ,libxkbcommon)
253 ("logind" ,elogind)
254 ("mesa" ,mesa)
255 ("pango" ,pango)
256 ("udev" ,eudev)))
257 (synopsis "Linux KMS-based terminal emulator")
258 (description "Kmscon is a terminal emulator based on Linux's @dfn{kernel
259 mode setting} (KMS). It can replace the in-kernel virtual terminal (VT)
260 implementation with a user-space console. Compared to the Linux console,
261 kmscon provides enhanced features including XKB-compatible internationalized
262 keyboard support, UTF-8 input/font support, hardware-accelerated rendering,
263 multi-seat support, a replacement for @command{mingetty}, and more.")
264 (home-page "https://www.freedesktop.org/wiki/Software/kmscon")
265 ;; Hash table implementation is lgpl2.1+ licensed.
266 ;; The wcwidth implementation in external/wcwidth.{h,c} uses a license
267 ;; derived from ISC.
268 ;; UCS-4 to UTF-8 encoding is copied from "terminology" which is released
269 ;; under the bsd 2 license.
270 ;; Unifont-Font is from http://unifoundry.com/unifont.html and licensed
271 ;; under the terms of the GNU GPL.
272 (license (list license:expat license:lgpl2.1+ license:bsd-2
273 license:gpl2+))
274 (supported-systems (filter (cut string-suffix? "-linux" <>)
275 %supported-systems))))
276
277 (define-public libtermkey
278 (package
279 (name "libtermkey")
280 (version "0.20")
281 (source (origin
282 (method url-fetch)
283 (uri (string-append "http://www.leonerd.org.uk/code/"
284 name "/" name "-" version ".tar.gz"))
285 (sha256
286 (base32 "1xfj6lchhfljmbcl6dz8dpakppyy13nbl4ykxiv5x4dr9b4qf3bc"))))
287 (build-system gnu-build-system)
288 (arguments
289 '(#:make-flags (list
290 "CC=gcc"
291 (string-append "PREFIX=" (assoc-ref %outputs "out")))
292 #:phases (modify-phases %standard-phases
293 (delete 'configure))
294 #:test-target "test"))
295 (inputs `(("ncurses" ,ncurses)))
296 (native-inputs `(("libtool" ,libtool)
297 ("perl-test-harness" ,perl-test-harness)
298 ("pkg-config" ,pkg-config)))
299 (synopsis "Keyboard entry processing library for terminal-based programs")
300 (description
301 "Libtermkey handles all the necessary logic to recognise special keys, UTF-8
302 combining, and so on, with a simple interface.")
303 (home-page "http://www.leonerd.org.uk/code/libtermkey")
304 (license license:expat)))
305
306 (define-public picocom
307 (package
308 (name "picocom")
309 (version "2.2")
310 (source (origin
311 (method url-fetch)
312 (uri (string-append
313 "https://github.com/npat-efault/picocom"
314 "/archive/" version ".tar.gz"))
315 (file-name (string-append name "-" version ".tar.gz"))
316 (sha256
317 (base32
318 "1knl6dglnrynx1fhy21nylw56i1q3dkizkgxzkq42mb7ilah8f9y"))))
319 (build-system gnu-build-system)
320 (arguments
321 `(#:make-flags '("CC=gcc")
322 #:tests? #f ; No tests
323 #:phases
324 (modify-phases %standard-phases
325 (delete 'configure)
326 (replace 'install
327 (lambda* (#:key outputs #:allow-other-keys)
328 (let* ((out (assoc-ref outputs "out"))
329 (bin (string-append out "/bin"))
330 (man (string-append out "/share/man/man1")))
331 (install-file "picocom" bin)
332 (install-file "picocom.1" man)))))))
333 (home-page "https://github.com/npat-efault/picocom")
334 (synopsis "Minimal dumb-terminal emulation program")
335 (description "It was designed to serve as a simple, manual, modem
336 configuration, testing, and debugging tool. It has also serves well
337 as a low-tech serial communications program to allow access to all
338 types of devices that provide serial consoles.")
339 (license license:gpl2+)))
340
341 (define-public beep
342 (package
343 (name "beep")
344 (version "1.3")
345 (source (origin
346 (method url-fetch)
347 (uri (string-append "http://www.johnath.com/" name "/"
348 name "-" version ".tar.gz"))
349 (sha256
350 (base32
351 "0bgch6jq5cahakk3kbr9549iysf2dik09afixxy5brbxk1xfzb2r"))))
352 (build-system gnu-build-system)
353 (arguments
354 `(#:tests? #f ; no tests.
355 #:phases
356 (modify-phases %standard-phases
357 (delete 'configure)
358 (add-after 'unpack 'patch-makefile
359 (lambda* (#:key outputs #:allow-other-keys)
360 (substitute* "Makefile" (("/usr") (assoc-ref outputs "out")))
361 #t))
362 (add-before 'install 'create-output-directories
363 (lambda* (#:key outputs #:allow-other-keys)
364 (let ((out (assoc-ref %outputs "out")))
365 (mkdir-p (string-append out "/bin"))
366 (mkdir-p (string-append out "/man/man1"))))))))
367 (synopsis "Linux command-line utility to control the PC speaker")
368 (description "beep allows the user to control the PC speaker with precision,
369 allowing different sounds to indicate different events. While it can be run
370 quite happily on the command line, its intended place of residence is within
371 scripts, notifying the user when something interesting occurs. Of course, it
372 has no notion of what's interesing, but it's very good at that notifying part.")
373 (home-page "http://www.johnath.com/beep")
374 (license license:gpl2+)))
375
376 (define-public unibilium
377 (package
378 (name "unibilium")
379 (version "1.2.1")
380 (source
381 (origin
382 (method url-fetch)
383 (uri (string-append "https://github.com/mauke/unibilium/"
384 "archive/v" version ".tar.gz"))
385 (file-name (string-append name "-" version ".tar.gz"))
386 (sha256
387 (base32
388 "1hbf011d8nzsp7c96fidjiq8yw8zlxf6f1s050ii2yyampvb8ib0"))))
389 (build-system gnu-build-system)
390 (arguments
391 `(#:make-flags
392 (list "CC=gcc"
393 (string-append "PREFIX=" (assoc-ref %outputs "out")))
394 #:test-target "test"
395 ;; FIXME: tests require "prove"
396 #:tests? #f
397 #:phases
398 (modify-phases %standard-phases
399 (delete 'configure))))
400 (native-inputs
401 `(("libtool" ,libtool)))
402 (home-page "https://github.com/mauke/unibilium")
403 (synopsis "Terminfo parsing library")
404 (description "Unibilium is a basic C terminfo library. It doesn't depend
405 on curses or any other library. It also doesn't use global variables, so it
406 should be thread-safe.")
407 (license license:lgpl3+)))
408
409 (define-public libvterm
410 (package
411 (name "libvterm")
412 (version "0+bzr681")
413 (source
414 (origin
415 (method url-fetch)
416 (uri (string-append "http://www.leonerd.org.uk/code/libvterm/"
417 "libvterm-" version ".tar.gz"))
418 (sha256
419 (base32
420 "1s56c8p1qz6frkcri0hg4qyydv2wcccj6n2xmz1dwcdqn38ldsmb"))))
421 (build-system gnu-build-system)
422 (arguments
423 `(#:make-flags
424 (list "CC=gcc"
425 (string-append "PREFIX=" (assoc-ref %outputs "out")))
426 #:test-target "test"
427 #:phases
428 (modify-phases %standard-phases
429 (delete 'configure))))
430 (native-inputs
431 `(("libtool" ,libtool)
432 ("perl" ,perl)))
433 (home-page "http://www.leonerd.org.uk/code/libvterm/")
434 (synopsis "VT220/xterm/ECMA-48 terminal emulator library")
435 (description "Libvterm is an abstract C99 library which implements a VT220
436 or xterm-like terminal emulator. It doesn't use any particular graphics
437 toolkit or output system, instead it invokes callback function pointers that
438 its embedding program should provide it to draw on its behalf. It avoids
439 calling @code{malloc} during normal running state, allowing it to be used in
440 embedded kernel situations.")
441 (license license:expat)))
442
443 (define-public cool-retro-term
444 (let ((commit "e48719fa44e5307df71dbd0fad234f8a6a53f863")
445 (revision "1"))
446 (package
447 (name "cool-retro-term")
448 (version (string-append "1.0.0-" revision "." (string-take commit 7)))
449 (source (origin
450 (method git-fetch)
451 (file-name (string-append name "-" version "-checkout"))
452 (uri (git-reference
453 (url (string-append "https://github.com/Swordfish90/" name))
454 (commit commit)
455 (recursive? #t)))
456 (sha256
457 (base32 "1sgqbirninkvgwchr35zgn5vzqvsmrf3cp7lqady1xgrawb8lsz3"))
458 (patches
459 (search-patches "cool-retro-term-remove-non-free-fonts.patch"
460 "cool-retro-term-fix-array-size.patch"
461 "cool-retro-term-dont-check-uninit-member.patch"
462 "cool-retro-term-memory-leak-1.patch"))
463 (modules '((guix build utils)))
464 (snippet
465 '(begin
466 (for-each (lambda (font)
467 (delete-file-recursively
468 (string-append "app/qml/fonts/" font))
469 (substitute* '("app/qml/resources.qrc")
470 (((string-append "<file>fonts/" font ".*"))
471 "")))
472 '(;;"1971-ibm-3278" ; BSD 3-clause
473 "1977-apple2" ; Non-Free
474 "1977-commodore-pet" ; Non-Free
475 "1979-atari-400-800" ; Non-Free
476 "1982-commodore64" ; Non-Free
477 "1985-atari-st" ; ?
478 "1985-ibm-pc-vga" ; Unclear
479 ;;"modern-fixedsys-excelsior" ; Redistributable
480 ;;"modern-hermit" ; SIL
481 ;;"modern-inconsolata" ; SIL
482 ;;"modern-pro-font-win-tweaked" ; X11
483 ;;"modern-proggy-tiny" ; X11
484 ;;"modern-terminus" ; SIL
485 "modern-monaco")) ; Apple non-free
486 #t))))
487 (build-system gnu-build-system)
488 (inputs
489 `(("qtbase" ,qtbase)
490 ("qtdeclarative" ,qtdeclarative)
491 ("qtgraphicaleffects" ,qtgraphicaleffects)
492 ("qtquickcontrols" ,qtquickcontrols)))
493 (arguments
494 `(#:phases
495 (modify-phases %standard-phases
496 (replace 'configure
497 (lambda* (#:key outputs #:allow-other-keys)
498 (let* ((out (assoc-ref outputs "out"))
499 (share (string-append out "/share")))
500 (substitute* '("qmltermwidget/qmltermwidget.pro")
501 (("INSTALL_DIR = \\$\\$\\[QT_INSTALL_QML\\]")
502 (string-append "INSTALL_DIR = " out "/lib/qt5/qml")))
503 (substitute* '("app/app.pro")
504 (("target.path \\+= /usr")
505 (string-append "target.path += " out))
506 (("icon32.path = /usr/share")
507 (string-append "icon32.path = " share))
508 (("icon64.path = /usr/share")
509 (string-append "icon64.path = " share))
510 (("icon128.path = /usr/share")
511 (string-append "icon128.path = " share))
512 (("icon256.path = /usr/share")
513 (string-append "icon256.path = " share)))
514 (zero? (system* "qmake")))))
515 (add-before 'install 'fix-Makefiles
516 (lambda* (#:key outputs #:allow-other-keys)
517 (let* ((out (assoc-ref outputs "out")))
518 (substitute* '("Makefile")
519 (("\\$\\(INSTALL_ROOT\\)/usr") out)))))
520 (add-after 'install 'wrap-executable
521 (lambda* (#:key inputs outputs #:allow-other-keys)
522 (let* ((out (assoc-ref outputs "out"))
523 (qml "/lib/qt5/qml"))
524 (wrap-program (string-append out "/bin/cool-retro-term")
525 `("QML2_IMPORT_PATH" ":" prefix
526 (,(string-append out qml)
527 ,(string-append
528 (assoc-ref inputs "qtdeclarative") qml)
529 ,(string-append
530 (assoc-ref inputs "qtgraphicaleffects") qml)
531 ,(string-append
532 (assoc-ref inputs "qtquickcontrols") qml)))))))
533 (add-after 'install 'add-alternate-name
534 (lambda* (#:key outputs #:allow-other-keys)
535 (let* ((bin (string-append (assoc-ref outputs "out") "/bin")))
536 (symlink (string-append bin "/cool-retro-term")
537 (string-append bin "/crt"))))))))
538 (synopsis "Terminal emulator")
539 (description
540 "Cool-retro-term (crt) is a terminal emulator which mimics the look and
541 feel of the old cathode ray tube (CRT) screens. It has been designed to be
542 eye-candy, customizable, and reasonably lightweight.")
543 (home-page "https://github.com/Swordfish90/cool-retro-term")
544 (license (list
545 license:gpl2+ ; qmltermwidget
546 license:gpl3+ ; cool-retro-term
547 ;; Fonts
548 license:silofl1.1
549 license:x11
550 license:bsd-3)))))
551
552 (define-public sakura
553 (package
554 (name "sakura")
555 (version "3.5.0")
556 (source (origin
557 (method url-fetch)
558 (uri (string-append "https://launchpad.net/" name "/trunk/"
559 version "/+download/" name "-" version
560 ".tar.bz2"))
561 (sha256
562 (base32
563 "0fhcn3540iw22l5zg3njh5z8cj0g2n9p6fvagjqa5zc323jfsc7b"))))
564 (build-system cmake-build-system)
565 (arguments
566 ;; no check phase
567 '(#:tests? #f))
568 (native-inputs
569 `(("gettext" ,gettext-minimal)
570 ("perl" ,perl) ; for pod2man
571 ("pkg-config" ,pkg-config)))
572 (inputs
573 `(("libxft" ,libxft)
574 ("vte" ,vte)))
575 (home-page "https://launchpad.net/sakura")
576 (synopsis "A simple but powerful libvte-based terminal emulator")
577 (description "@code{Sakura} is a terminal emulator based on GTK+ and VTE.
578 It's a terminal emulator with few dependencies, so you don't need a full GNOME
579 desktop installed to have a decent terminal emulator.")
580 (license license:gpl2)))
581
582 (define-public go-github.com-nsf-termbox-go
583 (let ((commit "4ed959e0540971545eddb8c75514973d670cf739")
584 (revision "0"))
585 (package
586 (name "go-github.com-nsf-termbox-go")
587 (version (git-version "0.0.0" revision commit))
588 (source (origin
589 (method git-fetch)
590 (uri (git-reference
591 (url "https://github.com/nsf/termbox-go.git")
592 (commit commit)))
593 (file-name (git-file-name name version))
594 (sha256
595 (base32
596 "1vx64i1mg660if3wwm81p4b7lzxfb3qbr39i7misdyld3fc486p9"))))
597 (build-system go-build-system)
598 (arguments
599 '(#:import-path "github.com/nsf/termbox-go"))
600 (propagated-inputs
601 `(("go-github.com-mattn-go-runewidth"
602 ,go-github.com-mattn-go-runewidth)))
603 (synopsis "@code{termbox} provides a minimal API for text-based user
604 interfaces")
605 (description
606 "Termbox is a library that provides a minimalistic API which allows the
607 programmer to write text-based user interfaces.")
608 (home-page "https://github.com/nsf/termbox-go")
609 (license license:expat))))
610
611 (define-public go-golang.org-x-crypto-ssh-terminal
612 (let ((commit "c78caca803c95773f48a844d3dcab04b9bc4d6dd")
613 (revision "0"))
614 (package
615 (name "go-golang.org-x-crypto-ssh-terminal")
616 (version (git-version "0.0.0" revision commit))
617 (source (origin
618 (method git-fetch)
619 (uri (git-reference
620 (url "https://go.googlesource.com/crypto")
621 (commit commit)))
622 (file-name (git-file-name name version))
623 (sha256
624 (base32
625 "0vxlfxr9y681yn2cfh6dbqmq35vvq4f45ay0mm31ffkny9cms0y4"))))
626 (build-system go-build-system)
627 (arguments
628 '(#:import-path "golang.org/x/crypto/ssh/terminal"
629 #:unpack-path "golang.org/x/crypto"
630 #:phases
631 (modify-phases %standard-phases
632 (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
633 (lambda* (#:key outputs #:allow-other-keys)
634 (map (lambda (file)
635 (make-file-writable file))
636 (find-files
637 (string-append (assoc-ref outputs "out")
638 "/src/golang.org/x/crypto/ed25519/testdata")
639 ".*\\.gz$"))
640 #t)))))
641 (synopsis "Support functions for dealing with terminals in Go")
642 (description "@code{terminal} provides support functions for dealing
643 with terminals in Go.")
644 (home-page "https://go.googlesource.com/crypto/")
645 (license license:bsd-3))))
646
647 (define-public go-github.com-howeyc-gopass
648 (let ((commit "bf9dde6d0d2c004a008c27aaee91170c786f6db8")
649 (revision "0"))
650 (package
651 (name "go-github.com-howeyc-gopass")
652 (version (git-version "0.0.0" revision commit))
653 (source (origin
654 (method git-fetch)
655 (uri (git-reference
656 (url "https://github.com/howeyc/gopass.git")
657 (commit commit)))
658 (file-name (git-file-name name version))
659 (sha256
660 (base32
661 "1jxzyfnqi0h1fzlsvlkn10bncic803bfhslyijcxk55mgh297g45"))))
662 (build-system go-build-system)
663 (arguments
664 '(#:import-path "github.com/howeyc/gopass"))
665 (propagated-inputs
666 `(("go-golang.org-x-crypto-ssh-terminal"
667 ,go-golang.org-x-crypto-ssh-terminal)))
668 (synopsis "Retrieve password from a terminal or piped input in Go")
669 (description
670 "@code{gopass} is a Go package for retrieving a password from user
671 terminal or piped input.")
672 (home-page "https://github.com/howeyc/gopass")
673 (license license:isc))))
674
675 (define-public python-pyte
676 (package
677 (name "python-pyte")
678 (version "0.7.0")
679 (source
680 (origin
681 (method url-fetch)
682 (uri (pypi-uri "pyte" version))
683 (sha256
684 (base32
685 "1an54hvyjm8gncx8cgabz9mkpgjkdb0bkyjlkh7g7f94nr3wnfl7"))))
686 (build-system python-build-system)
687 (arguments
688 '(#:phases
689 (modify-phases %standard-phases
690 (add-after 'unpack 'remove-failing-test
691 ;; TODO: Reenable when the `captured` files required by this test
692 ;; are included in the archive.
693 (lambda _
694 (delete-file "tests/test_input_output.py")
695 #t)))))
696 (propagated-inputs
697 `(("python-wcwidth" ,python-wcwidth)))
698 (native-inputs
699 `(("python-pytest-runner" ,python-pytest-runner)
700 ("python-pytest" ,python-pytest)))
701 (home-page "https://pyte.readthedocs.io/")
702 (synopsis "Simple VTXXX-compatible terminal emulator")
703 (description "@code{pyte} is an in-memory VTxxx-compatible terminal
704 emulator. @var{VTxxx} stands for a series of video terminals, developed by
705 DEC between 1970 and 1995. The first and probably most famous one was the
706 VT100 terminal, which is now a de-facto standard for all virtual terminal
707 emulators.
708
709 pyte is a fork of vt102, which was an incomplete pure Python implementation
710 of VT100 terminal.")
711 (license license:lgpl3+)))
712
713 (define-public python2-pyte
714 (package-with-python2 python-pyte))
715
716 (define-public python-blessings
717 (package
718 (name "python-blessings")
719 (version "1.6.1")
720 (source
721 (origin
722 (method url-fetch)
723 (uri (pypi-uri "blessings" version))
724 (sha256
725 (base32
726 "1smngy65p8mi62lgm04icasx22v976szhs2aq95y2ljmi1srb4bl"))))
727 (build-system python-build-system)
728 (arguments
729 ;; TODO: For py3, 2to2 is used to convert the code, but test-suite fails
730 `(#:tests? #f))
731 (native-inputs
732 `(("python-nose" ,python-nose)))
733 (home-page "https://github.com/erikrose/blessings")
734 (synopsis "Python module to manage terminal color, styling, and
735 positioning")
736 (description "Blessings is a pythonic API to manipulate terminal color,
737 styling, and positioning. It provides similar features to curses but avoids
738 some of curses’s limitations: it does not require clearing the whole screen
739 for little changes, provides a scroll-back buffer after the program exits, and
740 avoids styling altogether when the output is redirected to something other
741 than a terminal.")
742 (license license:expat)))
743
744 (define-public python2-blessings
745 (package-with-python2 python-blessings))
746
747 (define-public python-curtsies
748 (package
749 (name "python-curtsies")
750 (version "0.2.11")
751 (source
752 (origin
753 (method url-fetch)
754 (uri (pypi-uri "curtsies" version))
755 (sha256
756 (base32
757 "1vljmw3sy6lrqahhpyg4gk13mzcx3mwhvg8s41698ms3cpgkjipc"))))
758 (build-system python-build-system)
759 (arguments
760 `(#:phases
761 (modify-phases %standard-phases
762 (replace 'check
763 (lambda _
764 (invoke "nosetests" "-v"))))))
765 (propagated-inputs
766 `(("python-blessings" ,python-blessings)
767 ("python-wcwidth" ,python-wcwidth)))
768 (native-inputs
769 `(("python-mock" ,python-mock)
770 ("python-pyte" ,python-pyte)
771 ("python-nose" ,python-nose)))
772 (home-page "https://github.com/thomasballinger/curtsies")
773 (synopsis "Library for curses-like terminal interaction with colored
774 strings")
775 (description "Curtsies is a Python library for interacting with the
776 terminal. It features string-like objects which carry formatting information,
777 per-line fullscreen terminal rendering, and keyboard input event reporting.")
778 (license license:expat)))
779
780 (define-public python2-curtsies
781 (package-with-python2 python-curtsies))