gnu: moka-icon-theme: Add faba-icon-theme as propagated input.
[jackhill/guix/guix.git] / gnu / packages / cobol.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages cobol)
20 #:use-module (gnu packages)
21 #:use-module (guix build-system gnu)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (gnu packages databases)
26 #:use-module (gnu packages multiprecision)
27 #:use-module (gnu packages ncurses))
28
29 (define-public gnucobol
30 (package
31 (name "gnucobol")
32 (version "2.2")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append
37 "mirror://gnu/gnucobol/gnucobol-"
38 version ".tar.xz"))
39 (sha256
40 (base32
41 "1814s1n95xax2dz938cf4fkcp0q94nkj1gjbdblbzpk9q92zq66w"))))
42 (arguments
43 '(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
44 (assoc-ref %outputs "out")
45 "/lib"))))
46 (inputs
47 `(("bdb" ,bdb)
48 ("gmp" ,gmp)
49 ("ncurses" ,ncurses)))
50 (build-system gnu-build-system)
51 (home-page "https://savannah.gnu.org/projects/gnucobol/")
52 (synopsis "A modern COBOL compiler")
53 (description "GnuCOBOL is a free, modern COBOL compiler. GnuCOBOL
54 implements a substantial part of the COBOL 85, COBOL 2002 and COBOL 2014
55 standards and X/Open COBOL, as well as many extensions included in other
56 COBOL compilers (IBM COBOL, MicroFocus COBOL, ACUCOBOL-GT and others).
57 GnuCOBOL translates COBOL into C and compiles the translated code using
58 a native C compiler.")
59 (license gpl3+)))