gnu: Add envstore.
[jackhill/guix/guix.git] / gnu / packages / shellutils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages shellutils)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix utils)
24 #:use-module (guix build-system gnu))
25
26 (define-public envstore
27 (package
28 (name "envstore")
29 (version "2.1")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append "https://finalrewind.org/projects/"
34 name "/" name "-" version ".tar.bz2"))
35 (sha256
36 (base32 "1x97lxad80m5blhdfanl5v2qzjwcgbij2i23701bn8mpyxsrqszi"))))
37 (build-system gnu-build-system)
38 (arguments
39 `(#:test-target "test"
40 #:make-flags (list "CC=gcc"
41 (string-append "PREFIX=" (assoc-ref %outputs "out")))
42 #:phases
43 (modify-phases %standard-phases
44 (delete 'configure))))
45 (home-page "https://finalrewind.org/projects/envstore/")
46 (synopsis "Save and restore environment variables")
47 (description "Envstore is a program for sharing environment variables
48 between various shells or commands.")
49 (license
50 (non-copyleft "http://www.wtfpl.net/txt/copying/"))))