gnu: Add GNU Smalltalk.
[jackhill/guix/guix.git] / gnu / packages / smalltalk.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages smalltalk)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages zip))
25
26 (define-public smalltalk
27 (package
28 (name "smalltalk")
29 (version "3.2.4")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/smalltalk/smalltalk-"
34 version ".tar.xz"))
35 (sha256
36 (base32
37 "1bdhbppjv1fswh4ls9q90zix38l1hg9qd4c4bz1pbg1af991xq3a"))))
38 (build-system gnu-build-system)
39 (inputs `(("zip" ,zip)))
40 (arguments
41 `(#:phases (alist-cons-before
42 'configure 'fix-libc
43 (lambda _
44 (let ((libc (assoc-ref %build-inputs "libc")))
45 (substitute* "libc.la.in"
46 (("@LIBC_SO_NAME@") "libc.so")
47 (("@LIBC_SO_DIR@") (string-append libc "/lib")))))
48 %standard-phases)))
49 (home-page "https://www.gnu.org/software/smalltalk/")
50 (synopsis
51 "GNU Smalltalk, a free implementation of the Smalltalk-80 language")
52 (description
53 "GNU Smalltalk is a free implementation of the Smalltalk-80 language.
54
55 In the Smalltalk language, everything is an object. This includes numbers,
56 executable procedures (methods), stack frames (called method contexts or block
57 contexts), etc. Each object is an \"instance\" of a \"class\". A class can
58 be thought of as a datatype and the set of functions that operate on that
59 datatype. An instance is a particular variable of that datatype. When you
60 want to perform an operation on an object, you send it a \"message\", and the
61 object performs an operation that corresponds to that message.")
62 (license gpl2+)))