gnu: ledger: Fix test failures.
[jackhill/guix/guix.git] / gnu / packages / patches / ledger-revert-boost-python-fix.patch
1 From 01220484f428a447e9b00e071a0d85185f30e1de Mon Sep 17 00:00:00 2001
2 From: Alexis Hildebrandt <afh@surryhill.net>
3 Date: Wed, 22 Jun 2016 15:43:37 +0200
4 Subject: [PATCH] Revert "[python] Add fix for Boost.Python compile errors"
5
6 This reverts commit 11590e134eafa768ccc4a171cc7fb216e906095f.
7 ---
8 src/py_commodity.cc | 3 ---
9 src/py_journal.cc | 3 ---
10 2 files changed, 6 deletions(-)
11
12 diff --git a/src/py_commodity.cc b/src/py_commodity.cc
13 index 5aafa6c..c457e64 100644
14 --- a/src/py_commodity.cc
15 +++ b/src/py_commodity.cc
16 @@ -243,9 +243,6 @@ namespace {
17
18 void export_commodity()
19 {
20 -#if BOOST_VERSION >= 106000
21 - python::register_ptr_to_python< shared_ptr<commodity_pool_t> >();
22 -#endif
23 class_< commodity_pool_t, shared_ptr<commodity_pool_t>,
24 boost::noncopyable > ("CommodityPool", no_init)
25 .add_property("null_commodity",
26 diff --git a/src/py_journal.cc b/src/py_journal.cc
27 index c1c38a9..879f954 100644
28 --- a/src/py_journal.cc
29 +++ b/src/py_journal.cc
30 @@ -232,9 +232,6 @@ void export_journal()
31 boost::noncopyable >("PostHandler")
32 ;
33
34 -#if BOOST_VERSION >= 106000
35 - python::register_ptr_to_python< shared_ptr<collector_wrapper> >();
36 -#endif
37 class_< collector_wrapper, shared_ptr<collector_wrapper>,
38 boost::noncopyable >("PostCollectorWrapper", no_init)
39 .def("__len__", &collector_wrapper::length)