gnu: icecat: Update to 78.10.0-guix0-preview1 [security fixes].
[jackhill/guix/guix.git] / gnu / packages / poedit.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
3 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages poedit)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (gnu packages)
23 #:use-module (guix packages)
24 #:use-module (guix git-download)
25 #:use-module (guix utils)
26 #:use-module (guix build-system gnu)
27 #:use-module (gnu packages autotools)
28 #:use-module (gnu packages boost)
29 #:use-module (gnu packages enchant)
30 #:use-module (gnu packages gettext)
31 #:use-module (gnu packages gtk)
32 #:use-module (gnu packages icu4c)
33 #:use-module (gnu packages pkg-config)
34 #:use-module (gnu packages rdf)
35 #:use-module (gnu packages wxwidgets)
36 #:use-module (gnu packages xml))
37
38 (define-public poedit
39 (package
40 (name "poedit")
41 (version "2.2.4")
42 (source (origin
43 (method git-fetch)
44 (uri (git-reference
45 (url "https://github.com/vslavik/poedit")
46 (commit (string-append "v" version "-oss"))))
47 (file-name (git-file-name name version))
48 (sha256
49 (base32
50 "147jiiab4n0nbhzp1vw1jn8ykhy7qh6zf02654ppi0imdfvfnjss"))
51 (modules '((guix build utils)))
52 (snippet
53 '(begin
54 (delete-file-recursively "deps")
55 #t))))
56 (build-system gnu-build-system)
57 (arguments
58 `(#:configure-flags
59 (list (string-append "--with-boost-libdir="
60 (assoc-ref %build-inputs "boost")
61 "/lib"))))
62 (native-inputs
63 `(("autoconf" ,autoconf)
64 ("automake" ,automake)
65 ("gettext-minimal" ,gettext-minimal)
66 ("pkg-config" ,pkg-config)))
67 (inputs
68 `(("boost" ,boost)
69 ("enchant" ,enchant)
70 ("gtk+" ,gtk+)
71 ("gtkspell3" ,gtkspell3)
72 ("icu4c" ,icu4c)
73 ("lucene++" ,lucene++)
74 ("pugixml" ,pugixml)
75 ("wxwidgets" ,wxwidgets)))
76 (home-page "https://poedit.net/")
77 (synopsis "Gettext catalog editing tool")
78 (description "Poedit is a GUI frontend to the GNU gettext utilities and
79 a catalog editor/source code parser. It helps with translating applications
80 into other languages.")
81 (license license:expat)))