gnu: icecat: Update to 78.10.0-guix0-preview1 [security fixes].
[jackhill/guix/guix.git] / gnu / packages / ncdu.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages ncdu)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages ncurses)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu))
27
28 (define-public ncdu
29 (package
30 (name "ncdu")
31 (version "1.15.1")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "https://dev.yorhel.nl/download/ncdu-"
35 version ".tar.gz"))
36 (sha256
37 (base32
38 "1c1zxalm5asyhn4p1hd51h7khw17515gbqmvdz63kc8xpx6xqbdh"))))
39 (build-system gnu-build-system)
40 (inputs `(("ncurses" ,ncurses)))
41 (synopsis "Ncurses-based disk usage analyzer")
42 (description
43 "Ncdu is a disk usage analyzer with an ncurses interface, aimed to be
44 run on a remote server where you don't have an entire graphical setup, but have
45 to do with a simple SSH connection. ncdu aims to be fast, simple and easy to
46 use, and should be able to run in any minimal POSIX-like environment with
47 ncurses installed.")
48 (license (x11-style
49 (string-append "https://g.blicky.net/ncdu.git/plain/COPYING?id=v"
50 version)))
51 (home-page "https://dev.yorhel.nl/ncdu")))