gnu: icecat: Update to 78.10.0-guix0-preview1 [security fixes].
[jackhill/guix/guix.git] / gnu / packages / key-mon.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages key-mon)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (gnu packages)
24 #:use-module (gnu packages python)
25 #:use-module (gnu packages python-xyz)
26 #:use-module (gnu packages gtk)
27 #:use-module (gnu packages gnome)
28 #:use-module (guix build-system python))
29
30 (define-public key-mon
31 (package
32 (name "key-mon")
33 (version "1.17")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append
37 "http://key-mon.googlecode.com/files/key-mon-"
38 version ".tar.gz"))
39 (sha256
40 (base32
41 "1liz0dxcqmchbnl1xhlxkqm3gh76wz9jxdxn9pa7dy77fnrjkl5q"))))
42 (build-system python-build-system)
43 (arguments
44 `(#:python ,python-2 ;uses the Python 2 'print' syntax
45 #:tests? #f)) ;no tests
46 (inputs
47 `(("python2-xlib" ,python2-xlib)
48 ("python2-pygtk" ,python2-pygtk)
49 ("python2-rsvg" ,python2-rsvg)))
50 (home-page "https://code.google.com/p/key-mon")
51 (synopsis "Show keyboard and mouse status")
52 (description
53 "The key-mon utility displays the current keyboard and mouse status.
54 This is useful for teaching and screencasts.")
55 (license asl2.0)))