gnu: icecat: Update to 78.10.0-guix0-preview1 [security fixes].
[jackhill/guix/guix.git] / gnu / packages / kde-multimedia.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
3 ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
4 ;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages kde-multimedia)
22 #:use-module (guix build-system qt)
23 #:use-module (guix download)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (guix packages)
26 #:use-module (guix utils)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages audio)
29 #:use-module (gnu packages base)
30 #:use-module (gnu packages compression)
31 #:use-module (gnu packages cdrom)
32 #:use-module (gnu packages glib)
33 #:use-module (gnu packages gtk)
34 #:use-module (gnu packages gnome)
35 #:use-module (gnu packages gstreamer)
36 #:use-module (gnu packages kde-frameworks)
37 #:use-module (gnu packages libcanberra)
38 #:use-module (gnu packages linux)
39 #:use-module (gnu packages mp3)
40 #:use-module (gnu packages music)
41 #:use-module (gnu packages pkg-config)
42 #:use-module (gnu packages pulseaudio)
43 #:use-module (gnu packages qt)
44 #:use-module (gnu packages video)
45 #:use-module (gnu packages xiph)
46 #:use-module (gnu packages xorg))
47
48 (define-public audiocd-kio
49 (package
50 (name "audiocd-kio")
51 (version "20.04.1")
52 (source
53 (origin
54 (method url-fetch)
55 (uri (string-append "mirror://kde/stable/release-service/" version
56 "/src/audiocd-kio-" version ".tar.xz"))
57 (sha256
58 (base32 "0qlnxxbayqhz25jbvzis27jw2zbw1pmacp8rv7v5wa7zfqn3kmyk"))))
59 (build-system qt-build-system)
60 (native-inputs
61 `(("extra-cmake-modules" ,extra-cmake-modules)
62 ("kdoctools" ,kdoctools)))
63 (inputs
64 `(("cdparanoia" ,cdparanoia)
65 ("flac" ,flac)
66 ("kcmutils" ,kcmutils)
67 ("kconfig" ,kconfig)
68 ("ki18n" ,ki18n)
69 ("kio" ,kio)
70 ("libkcddb" ,libkcddb)
71 ("libkcompactdisc" ,libkcompactdisc)
72 ("libvorbis" ,libvorbis)
73 ("phonon" ,phonon)
74 ("qtbase" ,qtbase)))
75 (home-page "https://kde.org/applications/multimedia/org.kde.kio_audiocd")
76 (synopsis "Transparent audio CD integration for applications using the KDE
77 Platform")
78 (description "KIO AudioCD is a KIO slave that enables KIO-aware
79 applications (such as Dolphin or k3b) to access audio and CD text data on the
80 audio compact disks. It allows transparent drag and drop conversion of audio
81 data into the popular formats and has a configuration System Settings module
82 available in the \"Multimedia\" section.
83
84 This package is part of the KDE multimedia module.")
85 (license ;; GPL for programs, FDL for documentation
86 (list license:gpl2+ license:fdl1.2+))))
87
88 (define-public dragon
89 (package
90 (name "dragon")
91 (version "20.04.1")
92 (source
93 (origin
94 (method url-fetch)
95 (uri (string-append "mirror://kde/stable/release-service/" version
96 "/src/dragon-" version ".tar.xz"))
97 (sha256
98 (base32 "1sssg20a1vpwk816lp5jgwahilaswb9f3hgfqvc73il4g11ky1xj"))))
99 (build-system qt-build-system)
100 (native-inputs
101 `(("extra-cmake-modules" ,extra-cmake-modules)
102 ("kdoctools" ,kdoctools)))
103 (inputs
104 `(("kconfig" ,kconfig)
105 ("kconfigwidgets" ,kconfigwidgets)
106 ("kcoreaddons" ,kcoreaddons)
107 ("kcrash" ,kcrash)
108 ("kdbusaddons" ,kdbusaddons)
109 ("ki18n" ,ki18n)
110 ("kio" ,kio)
111 ("kjobwidgets" ,kjobwidgets)
112 ("knotifications" ,knotifications)
113 ("kparts" ,kparts)
114 ("kwidgetsaddons" ,kwidgetsaddons)
115 ("kwindowsystem" ,kwindowsystem)
116 ("kxmlgui" ,kxmlgui)
117 ("oxygen-icons" ,oxygen-icons) ; default icon set
118 ("phonon" ,phonon)
119 ("phonon-backend-gstreamer" ,phonon-backend-gstreamer)
120 ("qtbase" ,qtbase)
121 ("solid" ,solid)))
122 (home-page "https://kde.org/applications/multimedia/org.kde.dragonplayer")
123 (synopsis "Simple video player")
124 (description "Dragon Player is a multimedia player where the focus is on
125 simplicity, instead of features. Dragon Player does one thing, and only one
126 thing, which is playing multimedia files. It's simple interface is designed
127 not to get in your way and instead empower you to simply play multimedia
128 files.
129
130 This package is part of the KDE multimedia module.")
131 (license ;; GPL for programs, FDL for documentation
132 (list license:gpl2+ license:fdl1.2+))))
133
134 (define-public elisa
135 (package
136 (name "elisa")
137 (version "20.12.0")
138 (source
139 (origin
140 (method url-fetch)
141 (uri (string-append "mirror://kde/stable/release-service/" version
142 "/src/elisa-" version ".tar.xz"))
143 (sha256
144 (base32 "02450lsnbd37fms1i2bb9qc9wir4vym6qqd9p5hr6a6s6qwfs6qf"))))
145 (build-system qt-build-system)
146 (native-inputs
147 `(("extra-cmake-modules" ,extra-cmake-modules)
148 ("pkg-config" ,pkg-config)
149 ("dbus" ,dbus)
150 ("kdoctools" ,kdoctools)
151 ("xorg-server" , xorg-server-for-tests)))
152 (inputs
153 `(("kconfig" ,kconfig)
154 ("baloo" ,baloo)
155 ("kconfigwidgets" ,kconfigwidgets)
156 ("kcoreaddons" ,kcoreaddons)
157 ("kcrash" ,kcrash)
158 ("kcmutils" ,kcmutils)
159 ("kdbusaddons" ,kdbusaddons)
160 ("kdeclarative" ,kdeclarative)
161 ("kfilemetadata" ,kfilemetadata)
162 ("ki18n" ,ki18n)
163 ("kio" ,kio)
164 ("kirigami" ,kirigami)
165 ("kmediaplayer" ,kmediaplayer)
166 ("kparts" ,kparts)
167 ("kpackage" ,kpackage)
168 ("kwidgetsaddons" ,kwidgetsaddons)
169 ("kxmlgui" ,kxmlgui)
170 ("oxygen-icons" ,oxygen-icons) ; default icon set
171 ("phonon" ,phonon)
172 ("qtbase" ,qtbase)
173 ("qtdeclarative" ,qtdeclarative)
174 ("qtgraphicaleffects" ,qtgraphicaleffects) ; not listed as dependency
175 ("qtmultimedia" ,qtmultimedia)
176 ("qtquickcontrols" ,qtquickcontrols)
177 ("qtquickcontrols2" ,qtquickcontrols2)
178 ("qtsvg" ,qtsvg)
179 ("qtx11extras" ,qtx11extras)
180 ;; TODO: upnpqt https://gitlab.com/homeautomationqt/upnp-player-qt
181 ("vlc" ,vlc)))
182 (arguments
183 `(#:phases
184 (modify-phases %standard-phases
185 (add-before 'check 'start-xorg-server
186 (lambda* (#:key inputs #:allow-other-keys)
187 ;; The test suite requires a running X server, setting
188 ;; QT_QPA_PLATFORM=offscreen does not suffice.
189 (system (string-append (assoc-ref inputs "xorg-server")
190 "/bin/Xvfb :1 -screen 0 640x480x24 &"))
191 (setenv "DISPLAY" ":1")
192 #t))
193 (replace 'check
194 (lambda* (#:key tests? test-target #:allow-other-keys)
195 (when tests?
196 (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
197 (invoke "dbus-launch" "make" test-target))
198 #t)))))
199 (home-page "https://kde.org/applications/multimedia/org.kde.elisa")
200 (synopsis "Powerful music player for Plasma 5")
201 (description "Elisa is a simple music player aiming to provide a nice
202 experience for its users. Elisa browses music by album, artist or
203 all tracks. The music is indexed using either a private indexer or an indexer
204 using Baloo. The private one can be configured to scan music on chosen paths.
205 The Baloo one is much faster because Baloo is providing all needed data from
206 its own database. You can build and play your own playlist.")
207 (license license:lgpl3+)))
208
209 (define-public ffmpegthumbs
210 (package
211 (name "ffmpegthumbs")
212 (version "20.04.1")
213 (source
214 (origin
215 (method url-fetch)
216 (uri (string-append "mirror://kde/stable/release-service/" version
217 "/src/ffmpegthumbs-" version ".tar.xz"))
218 (sha256
219 (base32 "17l50z33a1h5zkrrfkb261yi2hms66qj36l1mndq7mvs97y2ggmc"))))
220 (build-system qt-build-system)
221 (native-inputs
222 `(("extra-cmake-modules" ,extra-cmake-modules)
223 ("pkg-config" ,pkg-config)))
224 (inputs
225 `(("ffmpeg" ,ffmpeg)
226 ("kconfig" ,kconfig)
227 ("ki18n" ,ki18n)
228 ("kio" ,kio)
229 ("qtbase" ,qtbase)))
230 (home-page "https://kde.org/applications/multimedia/org.kde.ffmpegthumbs")
231 (synopsis "Video thumbnail generator for KDE using ffmpeg")
232 (description "
233 FFMpegThumbs is a video thumbnail generator for KDE file managers
234 like Dolphin and Konqueror. It enables them to show preview images
235 of video files using FFMpeg.
236
237 This package is part of the KDE multimedia module.")
238 (license license:gpl2+)))
239
240 (define-public juk
241 (package
242 (name "juk")
243 (version "20.04.1")
244 (source
245 (origin
246 (method url-fetch)
247 (uri (string-append "mirror://kde/stable/release-service/" version
248 "/src/juk-" version ".tar.xz"))
249 (sha256
250 (base32 "06vsh7knyhcbcbf632jhldbqpzfkdyils2l8dbcdw5nj5hhgzzmr"))))
251 (build-system qt-build-system)
252 (native-inputs
253 `(("extra-cmake-modules" ,extra-cmake-modules)))
254 (inputs
255 `(("kcoreaddons" ,kcoreaddons)
256 ("kcompletion" ,kcompletion)
257 ("kconfig" ,kconfig)
258 ("kcrash" ,kcrash)
259 ("kdbusaddons" ,kdbusaddons)
260 ("kdoctools" ,kdoctools)
261 ("kglobalaccel" ,kglobalaccel)
262 ("ki18n" ,ki18n)
263 ("kiconthemes" ,kiconthemes)
264 ("kjobwidgets" ,kjobwidgets)
265 ("kio" ,kio)
266 ("knotifications" ,knotifications)
267 ("ktextwidgets" ,ktextwidgets)
268 ("kwallet" ,kwallet)
269 ("kwidgetsaddons" ,kwidgetsaddons)
270 ("kwindowsystem" ,kwindowsystem)
271 ("kxmlgui" ,kxmlgui)
272 ("oxygen-icons" ,oxygen-icons) ; default icon set
273 ("phonon" ,phonon)
274 ("phonon-backend-gstreamer" ,phonon-backend-gstreamer)
275 ("qtbase" ,qtbase)
276 ("qtsvg" ,qtsvg)
277 ("taglib" ,taglib)))
278 (home-page "https://kde.org/applications/multimedia/org.kde.juk")
279 (synopsis "Music jukebox / music player")
280 (description "JuK is a powerful music player capable of managing a large
281 music collection.
282
283 Some of JuK's features include:
284 @itemize
285 @item Music collection, playlists, and smart playlists
286 @item Tag editing support, including the ability to edit multiple files at once
287 @item Tag-based music file organization and renaming
288 @item CD burning support using k3b
289 @item Album art using Google Image Search
290 @end itemize
291
292 This package is part of the KDE multimedia module.")
293 (license license:gpl2+)))
294
295 (define-public k3b
296 (package
297 (name "k3b")
298 (version "20.04.2")
299 (source
300 (origin
301 (method url-fetch)
302 (uri (string-append "mirror://kde/stable/release-service/" version
303 "/src/k3b-" version ".tar.xz"))
304 (sha256
305 (base32 "15wm987hz6rfs9ds9l1gbs6gdsardj1ywvk6zmpvj2i2190y4b3q"))))
306 (build-system qt-build-system)
307 (arguments
308 `(#:phases
309 (modify-phases %standard-phases
310 (add-after 'unpack 'set-absolute-library-paths
311 (lambda _
312 ;; Set absolute paths for dlopened libraries. We can’t use k3b’s
313 ;; runpath as they are loaded by the Qt library.
314 (let ((libcdio-paranoia (assoc-ref %build-inputs "libcdio-paranoia"))
315 (libdvdcss (assoc-ref %build-inputs "libdvdcss")))
316 (substitute* "libk3b/tools/k3bcdparanoialib.cpp"
317 (("\"(cdio_cdda|cdio_paranoia)\"" _ library)
318 (string-append "\"" libcdio-paranoia "/lib/" library "\"")))
319 (substitute* "libk3b/tools/k3blibdvdcss.cpp"
320 (("\"(dvdcss)\"" _ library)
321 (string-append "\"" libdvdcss "/lib/" library "\""))))
322 #t))
323 (add-after 'qt-wrap 'wrap-path
324 (lambda _
325 ;; Set paths to backend programs.
326 (wrap-program (string-append (assoc-ref %outputs "out") "/bin/k3b")
327 `("PATH" ":" prefix
328 ,(map (lambda (input)
329 (string-append (assoc-ref %build-inputs input) "/bin"))
330 '("cdrdao" "dvd+rw-tools" "libburn" "sox"))))
331 #t)))))
332 (native-inputs
333 `(("extra-cmake-modules" ,extra-cmake-modules)
334 ("pkg-config" ,pkg-config)
335 ("kdoctools" ,kdoctools)))
336 (inputs
337 `(("cdrdao" ,cdrdao)
338 ("dvd+rw-tools" ,dvd+rw-tools)
339 ("ffmpeg" ,ffmpeg)
340 ("flac" ,flac)
341 ("karchive" ,karchive)
342 ("kcmutils" ,kcmutils)
343 ("kconfig" ,kconfig)
344 ("kcoreaddons" ,kcoreaddons)
345 ("kfilemetadata" ,kfilemetadata)
346 ("ki18n" ,ki18n)
347 ("kiconthemes" ,kiconthemes)
348 ("kio" ,kio)
349 ("kjobwidgets" ,kjobwidgets)
350 ("knewstuff" ,knewstuff)
351 ("knotifications" ,knotifications)
352 ("knotifyconfig" ,knotifyconfig)
353 ("kservice" ,kservice)
354 ("kwidgetsaddons" ,kwidgetsaddons)
355 ("kxmlgui" ,kxmlgui)
356 ("lame" ,lame)
357 ("libburn" ,libburn)
358 ("libcdio-paranoia" ,libcdio-paranoia)
359 ("libdvdcss" ,libdvdcss)
360 ("libdvdread" ,libdvdread)
361 ;; TODO: LibFuzzer
362 ("libiconv" ,libiconv)
363 ("libkcddb" ,libkcddb)
364 ("libmad" ,libmad)
365 ("libmpcdec" ,libmpcdec)
366 ;;("libmusicbrainz" ,libmusicbrainz) ; wants old version 2
367 ("libsamplerate" ,libsamplerate)
368 ("libsndfile" ,libsndfile)
369 ("libvorbis" ,libvorbis)
370 ("oxygen-icons" ,oxygen-icons) ; default icon set
371 ("qtbase" ,qtbase)
372 ("qtwebkit" ,qtwebkit)
373 ("shared-mime-info" ,shared-mime-info)
374 ("solid" ,solid)
375 ("sox" ,sox)
376 ("taglib" ,taglib)
377 ("zlib" ,zlib)))
378 (home-page "https://kde.org/applications/multimedia/org.kde.k3b")
379 (synopsis "Sophisticated CD/DVD burning application")
380 (description "K3b is CD-writing software which intends to be feature-rich
381 and provide an easily usable interface. Features include burning audio CDs
382 from .WAV and .MP3 audio files, configuring external programs and configuring
383 devices.
384
385 The @code{udisks-service} should be enabled for @command{k3b} to discover the
386 available CD drives.")
387 (license ;; GPL for programs, FDL for documentation
388 (list license:gpl2+ license:fdl1.2+))))
389
390 (define-public kaffeine
391 (package
392 (name "kaffeine")
393 (version "2.0.18")
394 (source
395 (origin
396 (method url-fetch)
397 (uri (string-append "mirror://kde/stable/kaffeine"
398 "/kaffeine-" version ".tar.xz"))
399 (sha256
400 (base32 "10dnhr9v2jlki44i3gmjagky66ybixmv6f29z5imk9clgddrlyfr"))))
401 (build-system qt-build-system)
402 (native-inputs
403 `(("extra-cmake-modules" ,extra-cmake-modules)
404 ("pkg-config" ,pkg-config)
405 ("kdoctools" ,kdoctools)))
406 (inputs
407 `(("eudev" ,eudev)
408 ("kcoreaddons" ,kcoreaddons)
409 ("kdbusaddons" ,kdbusaddons)
410 ("ki18n" ,ki18n)
411 ("kio" ,kio)
412 ("kwidgetsaddons" ,kwidgetsaddons)
413 ("kwindowsystem" ,kwindowsystem)
414 ("kxmlgui" ,kxmlgui)
415 ("libxscrnsaver" ,libxscrnsaver)
416 ("oxygen-icons" ,oxygen-icons) ; default icon set
417 ("qtbase" ,qtbase)
418 ("qtx11extras" ,qtx11extras)
419 ("solid" ,solid)
420 ("v4l-utils" ,v4l-utils) ; libdvbv5
421 ("vlc" ,vlc)))
422 (arguments
423 `(#:phases
424 (modify-phases %standard-phases
425 (add-after 'unpack 'fix-code
426 (lambda _
427 (substitute* "src/dvb/dvbdevice_linux.cpp"
428 (("\\s*qPrintable\\(transponder\\.getTransmissionType\\(\\)\\)\\);")
429 "transponder.getTransmissionType());"))
430 #t)))))
431 (home-page "https://kde.org/applications/multimedia/org.kde.kaffeine")
432 (synopsis "Versatile media player for KDE")
433 (description "Kaffeine is a media player for KDE. While it supports
434 multiple Phonon backends, its default backend is Xine, giving Kaffeine a wide
435 variety of supported media types and letting Kaffeine access CDs, DVDs, and
436 network streams easily.
437
438 Kaffeine can keep track of multiple playlists simultaneously, and supports
439 autoloading of subtitle files for use while playing video.")
440 (license ;; GPL for programs, FDL for documentation
441 (list license:gpl2+ license:fdl1.2+))))
442
443 (define-public kamoso
444 (package
445 (name "kamoso")
446 (version "20.04.1")
447 (source
448 (origin
449 (method url-fetch)
450 (uri (string-append "mirror://kde/stable/release-service/" version
451 "/src/kamoso-" version ".tar.xz"))
452 (sha256
453 (base32 "0c47j315kjfikd3b6x18786k3gqymicjjslpm0a58zdxl3wpqfay"))))
454 (build-system qt-build-system)
455 (native-inputs
456 `(("extra-cmake-modules" ,extra-cmake-modules)
457 ("glib:bin" ,glib "bin")
458 ("kdoctools" ,kdoctools)
459 ("pkg-config" ,pkg-config)))
460 (inputs
461 `(("gstreamer" ,gstreamer)
462 ("gst-plugins-base" ,gst-plugins-base)
463 ("kconfig" ,kconfig)
464 ("ki18n" ,ki18n)
465 ("kio" ,kio)
466 ("kirigami" ,kirigami)
467 ("knotifications" ,knotifications)
468 ("kparts" ,kparts)
469 ("oxygen-icons" ,oxygen-icons) ; default icon set
470 ("purpose" ,purpose)
471 ("qtbase" ,qtbase)
472 ("qtdeclarative" ,qtdeclarative)
473 ("qtgraphicaleffects" ,qtgraphicaleffects)
474 ("qtquickcontrols" ,qtquickcontrols)
475 ("qtquickcontrols2" ,qtquickcontrols2) ; not listed as dependency
476 ("qtx11extras" ,qtx11extras)))
477 (arguments
478 `(#:tests? #f ; test program gets built, but is not found
479 #:configure-flags
480 (list (string-append "-DCMAKE_CXX_FLAGS=-I"
481 (assoc-ref %build-inputs "gst-plugins-base")
482 "/include/gstreamer-1.0"))))
483 (home-page "https://kde.org/applications/multimedia/org.kde.kamoso")
484 (synopsis "Take pictures and videos out of your webcam")
485 (description "Kamoso is a simple and friendly program to use your
486 camera. Use it to take pictures and make videos to share.")
487 (license ;; GPL for programs, LGPL for libraries
488 (list license:gpl2+ license:lgpl2.0+))))
489
490 (define-public kmix
491 (package
492 (name "kmix")
493 (version "20.04.1")
494 (source
495 (origin
496 (method url-fetch)
497 (uri (string-append "mirror://kde/stable/release-service/" version
498 "/src/kmix-" version ".tar.xz"))
499 (sha256
500 (base32 "1na52ypp57wqrc6pl1khinx9i6fidv1k97nnxcy8zb4l7d5sh1nd"))))
501 (build-system qt-build-system)
502 (native-inputs
503 `(("extra-cmake-modules" ,extra-cmake-modules)
504 ("pkg-config" ,pkg-config)))
505 (inputs
506 `(("alsa-lib" ,alsa-lib)
507 ("glib" ,glib)
508 ("kconfigwidgets" ,kconfigwidgets)
509 ("kcompletion" ,kcompletion)
510 ("kconfig" ,kconfig)
511 ("kconfigwidgets" ,kconfigwidgets)
512 ("kcrash" ,kcrash)
513 ("kdbusaddons" ,kdbusaddons)
514 ("kdoctools" ,kdoctools)
515 ("kglobalaccel" ,kglobalaccel)
516 ("ki18n" ,ki18n)
517 ("kiconthemes" ,kiconthemes)
518 ("knotifications" ,knotifications)
519 ("kwidgetsaddons" ,kwidgetsaddons)
520 ("kwindowsystem" ,kwindowsystem)
521 ("kxmlgui" ,kxmlgui)
522 ("libcanberra" ,libcanberra)
523 ("oxygen-icons" ,oxygen-icons) ; default icon set
524 ("plasma-framework" ,plasma-framework)
525 ("pulseaudio" ,pulseaudio)
526 ("qtbase" ,qtbase)
527 ("solid" ,solid)))
528 (home-page "https://kde.org/applications/multimedia/org.kde.kmix")
529 (synopsis "Volume control and mixer")
530 (description "KMix is an audio device mixer, used to adjust volume, select
531 recording inputs, and set other hardware options.
532
533 This package is part of the KDE multimedia module.")
534 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
535 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
536
537 (define-public kmplayer
538 (package
539 (name "kmplayer")
540 (version "0.12.0b")
541 (source
542 (origin
543 (method url-fetch)
544 (uri (string-append "mirror://kde/stable/kmplayer/0.12"
545 "/kmplayer-" version ".tar.bz2"))
546 (sha256
547 (base32 "0wzdxym4fc83wvqyhcwid65yv59a2wvp1lq303cn124mpnlwx62y"))
548 (patches (search-patches
549 "kmplayer-aarch64.patch"
550 "kmplayer-upstream_Fix-build-with-Qt-5.9.patch"))))
551 (build-system qt-build-system)
552 (native-inputs
553 `(("extra-cmake-modules" ,extra-cmake-modules)
554 ("pkg-config" ,pkg-config)
555 ("kdoctools" ,kdoctools)))
556 (inputs
557 `(("kconfig" ,kconfig)
558 ("kcoreaddons" ,kcoreaddons)
559 ("kdelibs4support" ,kdelibs4support)
560 ("ki18n" ,ki18n)
561 ("kinit" ,kinit)
562 ("kio" ,kio)
563 ("kparts" ,kparts)
564 ("kmediaplayer" ,kmediaplayer)
565 ("kwidgetsaddons" ,kwidgetsaddons)
566 ("libxcb" ,libxcb) ;; FIXME: why does cmake not find XEVIE and XPRINT?
567 ("oxygen-icons" ,oxygen-icons) ; default icon set
568 ("phonon" ,phonon)
569 ("qtbase" ,qtbase)
570 ("cairo" ,cairo)
571 ("qtsvg" ,qtsvg)
572 ("qtx11extras" ,qtx11extras)
573 ("xcb-util" ,xcb-util)
574 ("xcb-util-cursor" ,xcb-util-cursor)
575 ("xcb-util-errors" ,xcb-util-errors)
576 ("xcb-util-image" ,xcb-util-image)
577 ("xcb-util-keysyms" ,xcb-util-keysyms)
578 ("xcb-util-wm" ,xcb-util-wm)))
579 (arguments
580 `(#:configure-flags
581 (list (string-append
582 "-DCMAKE_CXX_FLAGS=-I"
583 (assoc-ref %build-inputs "qtx11extras") "/include/qt5"))))
584 (home-page "https://kde.org/applications/multimedia/org.kde.kmplayer")
585 (synopsis "Media player using mplayer/phonon as backend")
586 (description "Kmplayer can play all the audio/video supported by
587 mplayer/phonon from a local file or URL and be embedded in Konqueror and
588 KHTML. It also plays DVDs.
589
590 Some features:
591 @itemize
592 @item play DVD/VCD movies (from file or url and from a video device)
593 @item embed inside konqueror (movie is played inside konqueror)
594 @item embed inside khtml (movie playback inside a html page)
595 @item Movie recording using mencoder (part of the mplayer package)
596 @item No video during recording, but you can always open a new window and play it
597 @item Broadcasting, http streaming, using ffserver/ffmpeg
598 @item For TV sources, you need v4lctl (part of the xawtv package)
599 @end itemize")
600 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
601 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
602
603 (define-public kwave
604 (package
605 (name "kwave")
606 (version "20.04.1")
607 (source
608 (origin
609 (method url-fetch)
610 (uri (string-append "mirror://kde/stable/release-service/" version
611 "/src/kwave-" version ".tar.xz"))
612 (sha256
613 (base32 "0ysa873pc2gip95cxr8yv7ifd9qql5zg6h67i9n9q3iqa6v58iyw"))))
614 (build-system qt-build-system)
615 (native-inputs
616 `(("extra-cmake-modules" ,extra-cmake-modules)
617 ("librsvg" ,librsvg)
618 ("pkg-config" ,pkg-config)
619 ("kdoctools" ,kdoctools)))
620 (inputs
621 `(("also-lib" ,alsa-lib)
622 ("audiofile" ,audiofile)
623 ("flac" ,flac)
624 ("id3lib" ,id3lib)
625 ("karchive" ,karchive)
626 ("kcompletion" ,kcompletion)
627 ("kconfig" ,kconfig)
628 ("kconfigwidgets" ,kconfigwidgets)
629 ("kcoreaddons" ,kcoreaddons)
630 ("kcrash" ,kcrash)
631 ("kdbusaddons" ,kdbusaddons)
632 ("ki18n" ,ki18n)
633 ("kiconthemes" ,kiconthemes)
634 ("kio" ,kio)
635 ("kservice" ,kservice)
636 ("ktextwidgets" ,ktextwidgets)
637 ("kwidgetsaddons" ,kwidgetsaddons)
638 ("kxmlgui" ,kxmlgui)
639 ("libmad" ,libmad)
640 ("libsamplerate" ,libsamplerate)
641 ("libvorbis" ,libvorbis)
642 ("opus" ,opus)
643 ("oxygen-icons" ,oxygen-icons) ; default icon set
644 ("pulseaudio" ,pulseaudio)
645 ("qtbase" ,qtbase)
646 ("qtmultimedia" ,qtmultimedia)
647 ("zlib" ,zlib)))
648 (home-page "https://kde.org/applications/multimedia/org.kde.kwave")
649 (synopsis "Sound editor for KDE")
650 (description "Kwave is a sound editor designed for the KDE Desktop
651 Environment.
652
653 With Kwave you can record, play back, import and edit many sorts of audio
654 files including multi-channel files. It includes some plugins to transform
655 audio files in several ways and presents a graphical view with a complete
656 zoom- and scroll capability.
657
658 Its features include:
659 @itemize
660 @item 24 Bit Support
661 @item Undo/Redo
662 @item Use of multicore CPUs (SMP, hyperthreading)
663 @item Simple Drag & Drop
664 @item Realtime Pre-Listen for some effects
665 @item Support for multi-track files
666 @item Playback and recording via native ALSA (or OSS, deprecated)
667 @item Playback via PulseAudio and Phonon
668 @item Load and edit-capability for large files (can use virtual memory)
669 @item Reading and auto-repair of damaged wav-files
670 @item Supports multiple windows
671 @item Extendable Plugin interface
672 @item a nice splashscreen
673 @item some label handling
674 @end itemize")
675 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
676 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+
677 license:cc-by-sa3.0 license:cc-by-sa4.0 ;; icons, samples
678 license:cc0 license:bsd-3)))) ;; utilities files
679
680 (define-public libkcddb
681 (package
682 (name "libkcddb")
683 (version "20.04.1")
684 (source
685 (origin
686 (method url-fetch)
687 (uri (string-append "mirror://kde/stable/release-service/" version
688 "/src/libkcddb-" version ".tar.xz"))
689 (sha256
690 (base32 "1fwryaj8ldmsqhl5qxjda8by9i7xlb97r8p9rqzckw697hkfhs0h"))))
691 (build-system qt-build-system)
692 (native-inputs
693 `(("extra-cmake-modules" ,extra-cmake-modules)
694 ("kdoctools" ,kdoctools)))
695 (inputs
696 `(("kcodecs" ,kcodecs)
697 ("kconfig" ,kconfig)
698 ("ki18n" ,ki18n)
699 ("kio" ,kio)
700 ("kwidgetsaddons" ,kwidgetsaddons)
701 ("libmusicbrainz" ,libmusicbrainz)
702 ("qtbase" ,qtbase)))
703 (arguments
704 `(#:tests? #f)) ; Most tests require network
705 (home-page "https://invent.kde.org/multimedia/libkcddb")
706 (synopsis "CDDB library for KDE Platform (runtime)")
707 (description "A library for retrieving and sending cddb information.")
708 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
709 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
710
711 (define-public libkcompactdisc
712 (package
713 (name "libkcompactdisc")
714 (version "20.04.1")
715 (source
716 (origin
717 (method url-fetch)
718 (uri (string-append "mirror://kde/stable/release-service/" version
719 "/src/libkcompactdisc-" version ".tar.xz"))
720 (sha256
721 (base32 "0iy4i0hxqsrnndd4iqkww7v1rqry7kvi5paxdw5qjfffwn8kcsbx"))))
722 (build-system qt-build-system)
723 (native-inputs
724 `(("extra-cmake-modules" ,extra-cmake-modules)))
725 (inputs
726 `(("alsa-lib" ,alsa-lib)
727 ("kcoreaddons" ,kcoreaddons)
728 ("ki18n" ,ki18n)
729 ("phonon" ,phonon)
730 ("qtbase" ,qtbase)
731 ("solid" ,solid)))
732 (home-page "https://invent.kde.org/multimedia/libkcompactdisc")
733 (synopsis "KDE library for playing & ripping CDs")
734 (description "The KDE Compact Disc library provides an API for
735 applications using the KDE Platform to interface with the CD drives for audio
736 CDs.")
737 (license ;; GPL for programs, LGPL for libraries
738 (list license:gpl2+ license:lgpl2.0+))))