gnu: icecat: Update to 78.10.0-guix0-preview1 [security fixes].
[jackhill/guix/guix.git] / gnu / packages / kawa.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Carlo Zancanaro <carlo@zancanaro.id.au>
3 ;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages kawa)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (gnu packages java))
27
28 (define-public kawa
29 (package
30 (name "kawa")
31 (version "3.1.1")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append "mirror://gnu/kawa/kawa-" version ".tar.gz"))
36 (sha256
37 (base32 "06g015zjlfgsx0n4lb326czkbf1grlx0n6dx074m808hdg6m16lc"))))
38 (build-system gnu-build-system)
39 (arguments
40 `(#:parallel-build? #f
41 #:parallel-tests? #f
42 #:phases
43 (modify-phases %standard-phases
44 (add-after 'install 'wrap-kawa
45 (lambda* (#:key inputs outputs #:allow-other-keys)
46 (let ((out (assoc-ref outputs "out")))
47 (wrap-program (string-append out "/share/kawa/bin/kawa")
48 `("JAVA_HOME" ":" = (,(assoc-ref inputs "icedtea"))))
49 #t))))))
50 (inputs
51 `(("icedtea" ,icedtea-8 "jdk")))
52 (home-page "https://www.gnu.org/software/kawa/")
53 (synopsis "Java framework and implementation of Scheme, Elisp, and more")
54 (description
55 "GNU Kawa is an implementation of the Scheme programming language that
56 is built on top of the Java platform. It is thus conveniently integrated
57 with Java and benefits from this by having a compiler, optional static
58 typing, and so on. Kawa also serves as a framework for implementing other
59 programming languages on the Java platform. Included in Kawa is qexo, a
60 partial implementation of XQuery in Java.")
61 (license license:expat)))