gnu: icecat: Update to 78.10.0-guix0-preview1 [security fixes].
[jackhill/guix/guix.git] / gnu / packages / gxmessage.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages gxmessage)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages glib)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (gnu packages gtk)
28 #:use-module (gnu packages))
29
30 (define-public gxmessage
31 (package
32 (name "gxmessage")
33 (version "3.4.3")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/gxmessage/gxmessage-"
37 version ".tar.gz"))
38 (sha256
39 (base32 "01ggvvp0nyn8xczh93icifnji468wsjgqzd1f1bixwsqziaicknv"))))
40 (build-system gnu-build-system)
41 (arguments
42 '(#:phases
43 (modify-phases %standard-phases
44 (add-before 'install 'skip-gtk-update-icon-cache
45 ;; Don't create 'icon-theme.cache'.
46 (lambda _
47 (substitute* "Makefile"
48 (("gtk-update-icon-cache") "true"))
49 #t)))))
50 (inputs
51 `(("gtk+" ,gtk+)))
52 (native-inputs
53 `(("intltool" ,intltool)
54 ("pkg-config" ,pkg-config)))
55 (home-page "https://www.gnu.org/software/gxmessage/")
56 (synopsis "Open popup message window with buttons for return")
57 (description "GNU gxmessage is a program that pops up dialog windows, which display
58 a message to the user and waits for their action. The program then exits
59 with an exit code corresponding to the response.")
60 (license gpl3+)))