gnu: icecat: Update to 78.10.0-guix0-preview1 [security fixes].
[jackhill/guix/guix.git] / gnu / packages / direct-connect.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages direct-connect)
20 #:use-module (guix build-system scons)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (gnu packages boost)
25 #:use-module (gnu packages compression)
26 #:use-module (gnu packages gettext)
27 #:use-module (gnu packages gnome)
28 #:use-module (gnu packages gtk)
29 #:use-module (gnu packages pkg-config)
30 #:use-module (gnu packages python-xyz)
31 #:use-module (gnu packages tls)
32 #:use-module (gnu packages version-control))
33
34 (define-public linuxdcpp
35 (package
36 (name "linuxdcpp")
37 (version "1.1.0")
38 (source
39 (origin
40 (method url-fetch)
41 (uri (string-append
42 "https://launchpad.net/linuxdcpp/1.1/1.1.0/+download/linuxdcpp-"
43 version ".tar.bz2"))
44 (sha256
45 (base32
46 "12i92hirmwryl1qy0n3jfrpziwzb82f61xca9jcjwyilx502f0b6"))))
47 (build-system scons-build-system)
48 (arguments
49 `(#:scons ,scons-python2
50 #:scons-flags (list (string-append "PREFIX=" %output))
51 #:tests? #f)) ; no tests
52 (inputs
53 `(("boost" ,boost)
54 ("bzip2" ,bzip2)
55 ("gtk+" ,gtk+-2)
56 ("libglade" ,libglade)
57 ("libnotify" ,libnotify)
58 ("openssl" ,openssl)))
59 (native-inputs
60 `(("bazaar" ,bazaar)
61 ("gettext-minimal" ,gettext-minimal)
62 ("pkg-config" ,pkg-config)))
63 (home-page "https://launchpad.net/linuxdcpp/")
64 (synopsis "Direct Connect client")
65 (description "LinuxDC++ is a Direct Connect (DC) client. Direct Connect
66 is a peer-to-peer file-sharing protocol. Clients connect to a central hub
67 where they can chat or share files with one another. Users can view other
68 users' list of shared files or search the hub for files.")
69 (license license:gpl2+)))