gnu: icecat: Update to 78.10.0-guix0-preview1 [security fixes].
[jackhill/guix/guix.git] / gnu / packages / cybersecurity.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
3 ;;; Copyright © 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages cybersecurity)
21 #:use-module (guix download)
22 #:use-module (guix packages)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix build-system python)
25 #:use-module (gnu packages engineering))
26
27 (define-public ropgadget
28 (package
29 (name "ropgadget")
30 (version "6.5")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (pypi-uri "ROPGadget" version))
35 (sha256
36 (base32 "0p4h8xi27xcicz8sq6xi40hbj99mcsnnla6ar2r17vqapbr5c3jc"))))
37 (build-system python-build-system)
38 (propagated-inputs
39 `(("python-capstone" ,python-capstone)))
40 (home-page "http://shell-storm.org/project/ROPgadget/")
41 (synopsis "Semiautomatic return oriented programming")
42 (description
43 "This tool lets you search for @acronym{ROP, Return Oriented Programming}
44 gadgets in binaries. Some facilities are included for automatically generating
45 chains of gadgets to execute system calls.")
46 (license license:bsd-3)))