Merge branch 'core-updates'
[jackhill/guix/guix.git] / gnu / packages / apl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages apl)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages gettext)
25 #:use-module (gnu packages maths)
26 #:use-module (gnu packages readline))
27
28 (define-public apl
29 (package
30 (name "apl")
31 (version "1.1")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append "mirror://gnu/apl/apl-" version ".tar.gz"))
36 (sha256
37 (base32
38 "1myinxa0m3y4fanpxflfakfk3m1s8641wdlbwbs0vg5yp10xm0m3"))))
39 (build-system gnu-build-system)
40 (home-page "http://www.gnu.org/software/apl/")
41 (inputs
42 `(("gettext" ,gnu-gettext)
43 ("lapack" ,lapack)
44 ("readline" ,readline)))
45 (synopsis "APL interpreter")
46 (description
47 "GNU APL is a free interpreter for the programming language APL. It is
48 an implementation of the ISO standard 13751.")
49 (license gpl3+)))