Merge branch 'core-updates'
[jackhill/guix/guix.git] / gnu / packages / dico.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages dico)
20 #:use-module (guix packages)
21 #:use-module ((guix licenses) #:select (gpl3+))
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages readline)
26 #:use-module (gnu packages m4)
27 #:use-module (gnu packages guile)
28 #:use-module (gnu packages python)
29 #:use-module (gnu packages pcre)
30 #:use-module (gnu packages gsasl)
31 #:use-module (gnu packages autotools)
32 #:use-module (gnu packages compression)
33 #:use-module (gnu packages wordnet))
34
35 (define-public dico
36 (package
37 (name "dico")
38 (version "2.2")
39 (source (origin
40 (method url-fetch)
41 (uri (string-append "mirror://gnu/dico/dico-"
42 version ".tar.xz"))
43 (sha256
44 (base32
45 "04pjks075x20d19l623mj50bw64g8i41s63z4kzzqcbg9qg96x64"))
46 (patches (search-patches "cpio-gets-undeclared.patch"
47 "dico-libtool-deterministic.patch"
48 "dico-idxgcide-bug.patch"))))
49 (build-system gnu-build-system)
50 (arguments
51 '(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
52 "/share/guile/site/2.0"))
53 #:make-flags '("V=1")
54 #:phases (modify-phases %standard-phases
55 (add-before 'check 'silence-guile
56 (lambda _
57 ;; Guile is too talkative, which disturbs the test
58 ;; infrastructure. Gag it.
59 (setenv "GUILE_AUTO_COMPILE" "0")
60 (setenv "GUILE_WARN_DEPRECATED" "no")
61 #t)))))
62 (inputs
63 `(("m4" ,m4) ;used at run time
64 ("pcre" ,pcre)
65 ;; ("python" ,python-2)
66 ("guile" ,guile-2.0)
67 ("gsasl" ,gsasl)
68 ("readline" ,readline-6.2)
69 ("zlib" ,zlib)
70 ;; ("wordnet" ,wordnet) ;FIXME: link failure
71 ("libltdl" ,libltdl)))
72 (home-page "http://www.gnu.org/software/dico/")
73 (synopsis "Implementation of DICT server (RFC 2229)")
74 (description
75 "GNU Dico implements a flexible dictionary server and client according to
76 RFC 2229 (DICT Server). It is able to access any database available,
77 regardless of format, thanks to its modular structure. New modules may be
78 written in C, Guile or Python. Dico also includes a command-line client,
79 which may be used to query remote dictionary databases.")
80 (license gpl3+)))