gnu: mariadb: Fix CVE-2021-27928.
[jackhill/guix/guix.git] / gnu / packages / patches / kmail-Fix-missing-link-libraries.patch
1 From 6b0a3a60870499b20ce9ae2ea07cbc5ee53cbdd2 Mon Sep 17 00:00:00 2001
2 From: Hartmut Goebel <h.goebel@crazy-compilers.com>
3 Date: Tue, 21 Jan 2020 23:23:38 +0100
4 Subject: [PATCH] Fix missing link libraries.
5
6 See <https://phabricator.kde.org/D26821>
7
8 These are only actually missing if the libraries reside in different
9 prefixes, as it is the case in Guix or Nix.
10 ---
11 agents/archivemailagent/CMakeLists.txt | 1 +
12 agents/followupreminderagent/CMakeLists.txt | 1 +
13 2 files changed, 2 insertions(+)
14
15 diff --git a/agents/archivemailagent/CMakeLists.txt b/agents/archivemailagent/CMakeLists.txt
16 index 95c6249de..d0ddcd475 100644
17 --- a/agents/archivemailagent/CMakeLists.txt
18 +++ b/agents/archivemailagent/CMakeLists.txt
19 @@ -22,6 +22,7 @@ ki18n_wrap_ui(libarchivemailagent_SRCS ui/archivemailwidget.ui )
20 add_library(archivemailagent STATIC ${libarchivemailagent_SRCS})
21 target_link_libraries(archivemailagent
22 KF5::MailCommon
23 + KF5::Libkdepim
24 KF5::I18n
25 KF5::Notifications
26 KF5::KIOWidgets
27 diff --git a/agents/followupreminderagent/CMakeLists.txt b/agents/followupreminderagent/CMakeLists.txt
28 index 9ae7eaa29..527044807 100644
29 --- a/agents/followupreminderagent/CMakeLists.txt
30 +++ b/agents/followupreminderagent/CMakeLists.txt
31 @@ -27,6 +27,7 @@ target_link_libraries(followupreminderagent
32 KF5::AkonadiMime
33 KF5::AkonadiAgentBase
34 KF5::DBusAddons
35 + KF5::FollowupReminder
36 KF5::XmlGui
37 KF5::KIOWidgets
38 KF5::Notifications
39 --
40 2.21.1
41