gnu: lrzip: Update to 0.640.
[jackhill/guix/guix.git] / gnu / packages / patches / slim-session.patch
1 Exit after the user's session has finished. This works around slim's broken
2 PAM session handling (see
3 http://developer.berlios.de/bugs/?func=detailbug&bug_id=19102&group_id=2663).
4
5 Patch by Eelco Dolstra, from Nixpkgs.
6
7 --- slim-1.3.6/app.cpp 2013-10-15 11:02:55.629263422 +0200
8 +++ slim-1.3.6/app.cpp 2013-10-15 13:00:10.141210784 +0200
9 @@ -816,7 +822,7 @@
10 StopServer();
11 RemoveLock();
12 while (waitpid(-1, NULL, WNOHANG) > 0); /* Collects all dead childrens */
13 - Run();
14 + exit(OK_EXIT);
15 }
16
17 void App::KillAllClients(Bool top) {