gnu: python-argcomplete: Update to 1.11.1.
[jackhill/guix/guix.git] / gnu / packages / patches / python-argcomplete-1.11.1-fish31.patch
1 Upstream commit fixing testcases for fish>=3.1, see
2 https://github.com/kislyuk/argcomplete/commit/08bfc8a788e8081515d733e67be026d051c726f7
3
4 diff --git a/test/test.py b/test/test.py
5 index e91352b..2c34806 100755
6 --- a/test/test.py
7 +++ b/test/test.py
8 @@ -28,6 +28,8 @@
9
10 BASH_VERSION = subprocess.check_output(['bash', '-c', 'echo $BASH_VERSION']).decode()
11 BASH_MAJOR_VERSION = int(BASH_VERSION.split('.')[0])
12 +FISH_VERSION_STR = subprocess.check_output(['fish', '-c', 'echo -n $FISH_VERSION']).decode()
13 +FISH_VERSION_TUPLE = tuple(int(x) for x in FISH_VERSION_STR.split('.'))
14
15
16 class TempDir(object):
17 @@ -1258,8 +1260,11 @@ class TestFish(_TestSh, unittest.TestCase):
18 expected_failures = [
19 'test_parse_special_characters',
20 'test_comp_point',
21 - 'test_special_characters_double_quoted'
22 ]
23 + if FISH_VERSION_TUPLE < (3, 1):
24 + expected_failures.extend([
25 + 'test_special_characters_double_quoted'
26 + ])
27
28 skipped = [
29 'test_single_quotes_in_single_quotes',