Merge branch 'staging'
[jackhill/guix/guix.git] / gnu / packages / perl-compression.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
4 ;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2017 Petter <petter@mykolab.ch>
6 ;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages perl-compression)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (guix utils)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system perl)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages compression)
31 #:use-module (gnu packages perl)
32 #:use-module (gnu packages perl-check))
33
34 (define-public perl-compress-raw-bzip2
35 (package
36 (name "perl-compress-raw-bzip2")
37 (version "2.084")
38 (source
39 (origin
40 (method url-fetch)
41 (uri (string-append "mirror://cpan/authors/id/P/PM/PMQS/"
42 "Compress-Raw-Bzip2-" version ".tar.gz"))
43 (sha256
44 (base32
45 "0kwjrsl519bv48b7698a9anj6l0n3z1vrd1a7im2r1pbffxxw5kx"))))
46 (build-system perl-build-system)
47 ;; TODO: Use our bzip2 package.
48 (home-page "https://metacpan.org/release/Compress-Raw-Bzip2")
49 (synopsis "Low-level interface to bzip2 compression library")
50 (description "This module provides a Perl interface to the bzip2
51 compression library.")
52 (license license:perl-license)))
53
54 (define-public perl-compress-raw-zlib
55 (package
56 (name "perl-compress-raw-zlib")
57 (version "2.084")
58 (source
59 (origin
60 (method url-fetch)
61 (uri (string-append "mirror://cpan/authors/id/P/PM/PMQS/"
62 "Compress-Raw-Zlib-" version ".tar.gz"))
63 (sha256
64 (base32
65 "0vv69a8kjx64cxhjgaccidy2yyij2j3aqlrv1r0dwa1fl9xijpim"))))
66 (build-system perl-build-system)
67 (inputs
68 `(("zlib" ,zlib)))
69 (arguments
70 `(#:phases (modify-phases %standard-phases
71 (add-before
72 'configure 'configure-zlib
73 (lambda* (#:key inputs #:allow-other-keys)
74 (call-with-output-file "config.in"
75 (lambda (port)
76 (format port "
77 BUILD_ZLIB = False
78 INCLUDE = ~a/include
79 LIB = ~:*~a/lib
80 OLD_ZLIB = False
81 GZIP_OS_CODE = AUTO_DETECT"
82 (assoc-ref inputs "zlib"))))
83 #t)))))
84 (home-page "https://metacpan.org/release/Compress-Raw-Zlib")
85 (synopsis "Low-level interface to zlib compression library")
86 (description "This module provides a Perl interface to the zlib
87 compression library.")
88 (license license:perl-license)))
89
90 (define-public perl-io-compress
91 (package
92 (name "perl-io-compress")
93 (version "2.084")
94 (source
95 (origin
96 (method url-fetch)
97 (uri (string-append "mirror://cpan/authors/id/P/PM/PMQS/"
98 "IO-Compress-" version ".tar.gz"))
99 (sha256
100 (base32
101 "1dbdsxhbikmbbfsdam3crv8474l8ax6d9d7r3s6safk4v8z51g8x"))))
102 (build-system perl-build-system)
103 (propagated-inputs
104 `(("perl-compress-raw-zlib" ,perl-compress-raw-zlib) ; >=2.081
105 ("perl-compress-raw-bzip2" ,perl-compress-raw-bzip2))) ; >=2.081
106 (home-page "https://metacpan.org/release/IO-Compress")
107 (synopsis "IO Interface to compressed files/buffers")
108 (description "IO-Compress provides a Perl interface to allow reading and
109 writing of compressed data created with the zlib and bzip2 libraries.")
110 (license license:perl-license)))
111
112 (define-public perl-archive-extract
113 (package
114 (name "perl-archive-extract")
115 (version "0.80")
116 (source
117 (origin
118 (method url-fetch)
119 (uri (string-append "mirror://cpan/authors/id/B/BI/BINGOS/Archive-Extract-"
120 version ".tar.gz"))
121 (sha256
122 (base32
123 "1x15j1q6w6z8hqyqgap0lz4qbq2174wfhksy1fdd653ccbaw5jr5"))))
124 (build-system perl-build-system)
125 (home-page "https://metacpan.org/release/Archive-Extract")
126 (synopsis "Generic archive extracting mechanism")
127 (description "It allows you to extract any archive file of the type .tar,
128 .tar.gz, .gz, .Z, tar.bz2, .tbz, .bz2, .zip, .xz,, .txz, .tar.xz or .lzma
129 without having to worry how it does so, or use different interfaces for each
130 type by using either Perl modules, or command-line tools on your system.")
131 (license license:perl-license)))
132
133 (define-public perl-archive-zip
134 (package
135 (name "perl-archive-zip")
136 (version "1.64")
137 (source
138 (origin
139 (method url-fetch)
140 (uri (string-append
141 "mirror://cpan/authors/id/P/PH/PHRED/Archive-Zip-"
142 version ".tar.gz"))
143 (sha256
144 (base32
145 "0zfinh8nx3rxzscp57vq3w8hihpdb0zs67vvalykcf402kr88pyy"))))
146 (build-system perl-build-system)
147 (native-inputs
148 ;; For tests.
149 `(("perl-test-mockmodule" ,perl-test-mockmodule)))
150 (synopsis "Provides an interface to Zip archive files")
151 (description "The @code{Archive::Zip} module allows a Perl program to
152 create, manipulate, read, and write Zip archive files.")
153 (home-page "https://metacpan.org/release/Archive-Zip")
154 (license license:perl-license)))