Merge branch 'staging' into core-updates
[jackhill/guix/guix.git] / gnu / packages / mes.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017,2018 Jan Nieuwenhuizen <janneke@gnu.org>
3 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages mes)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages base)
24 #:use-module (gnu packages cross-base)
25 #:use-module (gnu packages gcc)
26 #:use-module (gnu packages graphviz)
27 #:use-module (gnu packages guile)
28 #:use-module (gnu packages man)
29 #:use-module (gnu packages package-management)
30 #:use-module (gnu packages perl)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages texinfo)
33 #:use-module (guix build-system gnu)
34 #:use-module (guix download)
35 #:use-module (guix git-download)
36 #:use-module (guix licenses)
37 #:use-module (guix packages))
38
39 (define-public nyacc-0.86
40 (package
41 (name "nyacc")
42 (version "0.86.0")
43 (source (origin
44 (method url-fetch)
45 (uri (string-append "mirror://savannah/nyacc/"
46 name "-" version ".tar.gz"))
47 (patches (search-patches "nyacc-binary-literals.patch"))
48 (sha256
49 (base32
50 "0lkd9lyspvhxlfs0496gsllwinh62jk9wij6gpadvx9gwz6yavd9"))))
51 (build-system gnu-build-system)
52 (native-inputs
53 `(("guile" ,guile-2.2)))
54 (synopsis "LALR(1) Parser Generator in Guile")
55 (description
56 "NYACC is an LALR(1) parser generator implemented in Guile.
57 The syntax and nomenclature should be considered not stable. It comes with
58 extensive examples, including parsers for the Javascript and C99 languages.")
59 (home-page "https://savannah.nongnu.org/projects/nyacc")
60 (license (list gpl3+ lgpl3+))))
61
62 (define-public nyacc
63 (package
64 (inherit nyacc-0.86)
65 (version "0.94.0")
66 (source (origin
67 (method url-fetch)
68 (uri (string-append "mirror://savannah/nyacc/nyacc-"
69 version ".tar.gz"))
70 (sha256
71 (base32
72 "12qnzwm1n3j8z7hbr9hy2wka9a1aasm2rvnpnvdxkjcsbdzj8fn4"))
73 (modules '((guix build utils)))
74 (snippet
75 '(begin
76 (substitute* (find-files "." "^Makefile\\.in$")
77 (("^SITE_SCM_DIR =.*")
78 "SITE_SCM_DIR = \
79 @prefix@/share/guile/site/@GUILE_EFFECTIVE_VERSION@\n")
80 (("^SITE_SCM_GO_DIR =.*")
81 "SITE_SCM_GO_DIR = \
82 @prefix@/lib/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n")
83 (("^INFODIR =.*")
84 "INFODIR = @prefix@/share/info\n")
85 (("^DOCDIR =.*")
86 "DOCDIR = @prefix@/share/doc/$(PACKAGE_TARNAME)\n"))
87 #t))))
88 (native-inputs
89 `(("pkg-config" ,pkg-config)))
90 (inputs
91 `(("guile" ,guile-2.2)))))
92
93 (define-public mes
94 (package
95 (name "mes")
96 (version "0.19")
97 (source (origin
98 (method url-fetch)
99 (uri (string-append "mirror://gnu/mes/"
100 "mes-" version ".tar.gz"))
101 (sha256
102 (base32
103 "15h4yhaywdc0djpjlin2jz1kzahpqxfki0r0aav1qm9nxxmnp1l0"))))
104 (build-system gnu-build-system)
105 (supported-systems '("i686-linux" "x86_64-linux"))
106 (propagated-inputs
107 `(("mescc-tools" ,mescc-tools)
108
109 ;; XXX: MesCC appears to enter an infinite loop (?) while building
110 ;; crt1.o when we switch to nyacc 0.94.
111 ("nyacc" ,nyacc-0.86)))
112 (native-inputs
113 `(("guile" ,guile-2.2)
114 ,@(let ((target-system (or (%current-target-system)
115 (%current-system))))
116 (cond
117 ((string-prefix? "x86_64-linux" target-system)
118 ;; Use cross-compiler rather than #:system "i686-linux" to get
119 ;; MesCC 64 bit .go files installed ready for use with Guile.
120 `(("i686-linux-binutils" ,(cross-binutils "i686-unknown-linux-gnu"))
121 ("i686-linux-gcc" ,(cross-gcc "i686-unknown-linux-gnu"))))
122 (else
123 '())))
124 ("graphviz" ,graphviz)
125 ("help2man" ,help2man)
126 ("perl" ,perl) ; build-aux/gitlog-to-changelog
127 ("texinfo" ,texinfo)))
128 (arguments
129 `(#:strip-binaries? #f)) ; binutil's strip b0rkes MesCC/M1/hex2 binaries
130 (synopsis "Scheme interpreter and C compiler for full source bootstrapping")
131 (description
132 "GNU Mes--Maxwell Equations of Software--brings the Reduced Binary Seed
133 bootstrap to Guix and aims to help create full source bootstrapping for
134 GNU/Linux distributions. It consists of a mutual self-hosting Scheme
135 interpreter in C and a Nyacc-based C compiler in Scheme and is compatible with
136 Guile.")
137 (home-page "https://gnu.org/software/mes")
138 (license gpl3+)))
139
140 (define-public mescc-tools
141 (let ((commit "bb062b0da7bf2724ca40f9002b121579898d4ef7")
142 (revision "0")
143 (version "0.5.2"))
144 (package
145 (name "mescc-tools")
146 (version (string-append version "-" revision "." (string-take commit 7)))
147 (source (origin
148 (method url-fetch)
149 (uri (string-append
150 "https://git.savannah.nongnu.org/cgit/mescc-tools.git/snapshot/"
151 name "-" commit
152 ".tar.gz"))
153 (sha256
154 (base32
155 "1h6j57wyf91i42b26f8msbv6451cw3nm4nmpl1fckp9c7vi8mwkh"))))
156 (build-system gnu-build-system)
157 (supported-systems '("i686-linux" "x86_64-linux"))
158 (arguments
159 `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
160 #:test-target "test"
161 #:phases (modify-phases %standard-phases
162 (delete 'configure))))
163 (synopsis "Tools for the full source bootstrapping process")
164 (description
165 "Mescc-tools is a collection of tools for use in a full source
166 bootstrapping process. It consists of the M1 macro assembler, the hex2
167 linker, the blood-elf symbol table generator, the kaem shell, exec_enable and
168 get_machine.")
169 (home-page "https://savannah.nongnu.org/projects/mescc-tools")
170 (license gpl3+))))