gnu: openjpeg: Fix CVE-2016-5157.
[jackhill/guix/guix.git] / gnu / packages / patches / openjpeg-CVE-2016-5157.patch
1 Fix CVE-2016-5157 (heap overflow in opj_dwt_interleave_v() allowing execution of
2 arbitrary code):
3
4 https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-5157
5 https://pdfium.googlesource.com/pdfium/+/b6befb2ed2485a3805cddea86dc7574510178ea9
6 http://seclists.org/oss-sec/2016/q3/441
7
8 Adapted from upstream source repository:
9
10 https://github.com/uclouvain/openjpeg/commit/e078172b1c3f98d2219c37076b238fb759c751ea
11
12 The final hunk of the patch, affecting
13 'tests/nonregression/test_suite.ctest.in', had to be adjusted, since it referred
14 to some context that is not yet provided by a tagged release.
15
16 From c80286a4d573ad07ccc3c8b53289c38bb8256b30 Mon Sep 17 00:00:00 2001
17 From: Leo Famulari <leo@famulari.name>
18 Date: Fri, 9 Sep 2016 04:37:40 -0400
19 Subject: [PATCH] CVE-2016-5157 adjusted to apply to 2.1.0.
20
21 ---
22 src/lib/openjp2/tcd.c | 11 +++++++++++
23 tests/compare_dump_files.c | 14 +++++++-------
24 tests/nonregression/test_suite.ctest.in | 2 ++
25 3 files changed, 20 insertions(+), 7 deletions(-)
26
27 diff --git a/src/lib/openjp2/tcd.c b/src/lib/openjp2/tcd.c
28 index 12da05c..7a29c49 100644
29 --- a/src/lib/openjp2/tcd.c
30 +++ b/src/lib/openjp2/tcd.c
31 @@ -696,9 +696,20 @@ static INLINE OPJ_BOOL opj_tcd_init_tile(opj_tcd_t *p_tcd, OPJ_UINT32 p_tile_no,
32 l_tx0 = l_cp->tx0 + p * l_cp->tdx; /* can't be greater than l_image->x1 so won't overflow */
33 l_tile->x0 = (OPJ_INT32)opj_uint_max(l_tx0, l_image->x0);
34 l_tile->x1 = (OPJ_INT32)opj_uint_min(opj_uint_adds(l_tx0, l_cp->tdx), l_image->x1);
35 + /* all those OPJ_UINT32 are casted to OPJ_INT32, let's do some sanity check */
36 + if ((l_tile->x0 < 0) || (l_tile->x1 <= l_tile->x0)) {
37 + opj_event_msg(manager, EVT_ERROR, "Tile X coordinates are not supported\n");
38 + return OPJ_FALSE;
39 + }
40 l_ty0 = l_cp->ty0 + q * l_cp->tdy; /* can't be greater than l_image->y1 so won't overflow */
41 l_tile->y0 = (OPJ_INT32)opj_uint_max(l_ty0, l_image->y0);
42 l_tile->y1 = (OPJ_INT32)opj_uint_min(opj_uint_adds(l_ty0, l_cp->tdy), l_image->y1);
43 + /* all those OPJ_UINT32 are casted to OPJ_INT32, let's do some sanity check */
44 + if ((l_tile->y0 < 0) || (l_tile->y1 <= l_tile->y0)) {
45 + opj_event_msg(manager, EVT_ERROR, "Tile Y coordinates are not supported\n");
46 + return OPJ_FALSE;
47 + }
48 +
49
50 /* testcase 1888.pdf.asan.35.988 */
51 if (l_tccp->numresolutions == 0) {
52 diff --git a/tests/compare_dump_files.c b/tests/compare_dump_files.c
53 index 946c92a..7d22270 100644
54 --- a/tests/compare_dump_files.c
55 +++ b/tests/compare_dump_files.c
56 @@ -118,10 +118,10 @@ int main(int argc, char **argv)
57 test_cmp_parameters inParam;
58 FILE *fbase=NULL, *ftest=NULL;
59 int same = 0;
60 - char lbase[256];
61 - char strbase[256];
62 - char ltest[256];
63 - char strtest[256];
64 + char lbase[512];
65 + char strbase[512];
66 + char ltest[512];
67 + char strtest[512];
68
69 if( parse_cmdline_cmp(argc, argv, &inParam) == 1 )
70 {
71 @@ -154,9 +154,9 @@ int main(int argc, char **argv)
72
73 while (fgets(lbase, sizeof(lbase), fbase) && fgets(ltest,sizeof(ltest),ftest))
74 {
75 - int nbase = sscanf(lbase, "%255[^\r\n]", strbase);
76 - int ntest = sscanf(ltest, "%255[^\r\n]", strtest);
77 - assert( nbase != 255 && ntest != 255 );
78 + int nbase = sscanf(lbase, "%511[^\r\n]", strbase);
79 + int ntest = sscanf(ltest, "%511[^\r\n]", strtest);
80 + assert( nbase != 511 && ntest != 511 );
81 if( nbase != 1 || ntest != 1 )
82 {
83 fprintf(stderr, "could not parse line from files\n" );
84 diff --git a/tests/nonregression/test_suite.ctest.in b/tests/nonregression/test_suite.ctest.in
85 index d393e6c..90cfa43 100644
86 --- a/tests/nonregression/test_suite.ctest.in
87 +++ b/tests/nonregression/test_suite.ctest.in
88 @@ -564,3 +564,5 @@ opj_decompress -i @INPUT_NR_PATH@/issue726.j2k -o @TEMP_PATH@/issue726.png
89 # issue 775
90 !opj_decompress -i @INPUT_NR_PATH@/issue775.j2k -o @TEMP_PATH@/issue775.png
91 !opj_decompress -i @INPUT_NR_PATH@/issue775-2.j2k -o @TEMP_PATH@/issue775-2.png
92 +# issue 823 (yes, not a typo, test image is issue822)
93 +!opj_decompress -i @INPUT_NR_PATH@/issue822.jp2 -o @TEMP_PATH@/issue822.png
94 --
95 2.10.0
96