gnu: icecat: Apply fixes for CVE-2015-{0817,0818} and other selected bugs.
[jackhill/guix/guix.git] / gnu / packages / xdisorg.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2014, 2015 Alex Kost <alezost@gmail.com>
6 ;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
7 ;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
8 ;;; Copyright © 2015 Alexander I.Grafov <grafov@gmail.com>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages xdisorg)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system gnu)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages image)
33 #:use-module (gnu packages pkg-config)
34 #:use-module (gnu packages glib)
35 #:use-module (gnu packages perl)
36 #:use-module (gnu packages linux)
37 #:use-module (gnu packages guile)
38 #:use-module (gnu packages xorg))
39
40 ;; packages outside the x.org system proper
41
42 (define-public xclip
43 (package
44 (name "xclip")
45 (version "0.12")
46 (source
47 (origin
48 (method url-fetch)
49 (uri (string-append
50 "mirror://sourceforge/" name "/" name "-" version ".tar.gz"))
51 (sha256
52 (base32
53 "0ibcf46rldnv0r424qcnai1fa5iq3lm5q5rdd7snsi5sb78gmixp"))))
54 (build-system gnu-build-system)
55 (arguments
56 '(#:tests? #f)) ; There is no test suite
57 (inputs `(("libxmu" ,libxmu)
58 ("libxt" ,libxt)))
59 (home-page "http://xclip.sourceforge.net/")
60 (synopsis "Command line interface to X11 clipboard")
61 (description "Xclip is a command line interface to the X11 clipboard. It
62 can also be used for copying files, as an alternative to sftp/scp, thus
63 avoiding password prompts when X11 forwarding has already been setup.")
64 (license license:gpl2+)))
65
66 (define-public xdotool
67 (package
68 (name "xdotool")
69 (version "2.20110530.1")
70 (source
71 (origin
72 (method url-fetch)
73 (uri (string-append
74 "http://semicomplete.googlecode.com/files/" name "-"
75 version ".tar.gz"))
76 (sha256
77 (base32
78 "0rxggg1cy7nnkwidx8x2w3c5f3pk6dh2b6q0q7hp069r3n5jrd77"))))
79 (build-system gnu-build-system)
80 (arguments
81 '(#:tests? #f ; Test suite requires a lot of black magic
82 #:phases
83 (alist-replace 'configure
84 (lambda* (#:key outputs #:allow-other-keys #:rest args)
85 (setenv "PREFIX" (assoc-ref outputs "out"))
86 (setenv "LDFLAGS" (string-append "-Wl,-rpath="
87 (assoc-ref
88 %outputs "out") "/lib"))
89 (setenv "CC" "gcc"))
90 %standard-phases)))
91 (native-inputs `(("perl" ,perl))) ; for pod2man
92 (inputs `(("libx11" ,libx11)
93 ("libxext" ,libxext)
94 ("libxi" ,libxi)
95 ("libxinerama" ,libxinerama)
96 ("libxtst" ,libxtst)))
97 (home-page "http://www.semicomplete.com/projects/xdotool")
98 (synopsis "Fake keyboard/mouse input, window management, and more")
99 (description "Xdotool lets you simulate keyboard input and mouse activity,
100 move and resize windows, etc. It does this using X11's XTEST extension and
101 other Xlib functions. Additionally, you can search for windows and move,
102 resize, hide, and modify window properties like the title. If your window
103 manager supports it, you can use xdotool to switch desktops, move windows
104 between desktops, and change the number of desktops.")
105 (license license:bsd-3)))
106
107 (define-public xeyes
108 (package
109 (name "xeyes")
110 (version "1.0.1")
111 (source
112 (origin
113 (method url-fetch)
114 (uri (string-append
115 "http://xeyes.sourcearchive.com/downloads/1.0.1/xeyes_"
116 version
117 ".orig.tar.gz"))
118 (sha256
119 (base32
120 "04c3md570j67g55h3bix1qbngcslnq91skli51k3g1avki88zkm9"))))
121 (build-system gnu-build-system)
122 (inputs
123 `(("libxext" ,libxext)
124 ("libxmu" ,libxmu)
125 ("libxt" ,libxt)))
126 (native-inputs
127 `(("pkg-config" ,pkg-config)))
128 (home-page "http://xeyes.sourcearchive.com/")
129 (synopsis "Follow-the-mouse X demo")
130 (description "Xeyes is a demo program for x.org. It shows eyes
131 following the mouse.")
132 (license license:x11)))
133
134
135 (define-public pixman
136 (package
137 (name "pixman")
138 (version "0.32.6")
139 (source
140 (origin
141 (method url-fetch)
142 (uri (string-append
143 "http://cairographics.org/releases/pixman-"
144 version
145 ".tar.gz"))
146 (sha256
147 (base32
148 "0129g4zdrw5hif5783li7rzcr4vpbc2cfia91azxmsk0h0xx3zix"))))
149 (build-system gnu-build-system)
150 (inputs
151 `(("libpng" ,libpng)
152 ("zlib" ,zlib)))
153 (native-inputs
154 `(("pkg-config" ,pkg-config)))
155 (home-page "http://www.pixman.org/")
156 (synopsis "Low-level pixel manipulation library")
157 (description "Pixman is a low-level software library for pixel
158 manipulation, providing features such as image compositing and trapezoid
159 rasterisation.")
160 (license license:x11)))
161
162
163 (define-public libdrm
164 (package
165 (name "libdrm")
166 (version "2.4.58")
167 (source
168 (origin
169 (method url-fetch)
170 (uri (string-append
171 "http://dri.freedesktop.org/libdrm/libdrm-"
172 version
173 ".tar.bz2"))
174 (sha256
175 (base32
176 "1pb5lfb3kh36p9axq620daclq68rqb3mhzxpz0pb18y9p7kglmdi"))))
177 (build-system gnu-build-system)
178 (inputs
179 `(("libpciaccess" ,libpciaccess)
180 ("libpthread-stubs" ,libpthread-stubs)))
181 (native-inputs
182 `(("pkg-config" ,pkg-config)))
183 (home-page "http://dri.freedesktop.org/wiki/")
184 (synopsis "Direct rendering userspace library")
185 (description "The Direct Rendering Infrastructure, also known as the DRI,
186 is a framework for allowing direct access to graphics hardware under the
187 X Window System in a safe and efficient manner. It includes changes to the
188 X server, to several client libraries, and to the kernel (DRM, Direct
189 Rendering Manager). The most important use for the DRI is to create fast
190 OpenGL implementations providing hardware acceleration for Mesa.
191 Several 3D accelerated drivers have been written to the DRI specification,
192 including drivers for chipsets produced by 3DFX, AMD (formerly ATI), Intel
193 and Matrox.")
194 (license license:x11)))
195
196
197 (define-public mtdev
198 (package
199 (name "mtdev")
200 (version "1.1.3")
201 (source
202 (origin
203 (method url-fetch)
204 (uri (string-append
205 "http://bitmath.org/code/mtdev/mtdev-"
206 version ".tar.bz2"))
207 (sha256
208 (base32
209 "159ndzwfpw0xr8mw4lhl47w9c2krshlfrscs7k6n186vknv2hk3d"))))
210 (build-system gnu-build-system)
211 (home-page "http://bitmath.org/code/mtdev/")
212 (synopsis "Multitouch protocol translation library")
213 (description "Mtdev is a stand-alone library which transforms all
214 variants of kernel MT events to the slotted type B protocol. The events
215 put into mtdev may be from any MT device, specifically type A without
216 contact tracking, type A with contact tracking, or type B with contact
217 tracking.")
218 (license license:x11)))
219
220 (define-public startup-notification
221 (package
222 (name "startup-notification")
223 (version "0.12")
224 (source
225 (origin
226 (method url-fetch)
227 (uri (string-append "http://www.freedesktop.org/software/" name
228 "/releases/" name "-" version ".tar.gz"))
229 (sha256
230 (base32
231 "0jmyryrpqb35y9hd5sgxqy2z0r1snw7d3ljw0jak0n0cjdz1yf9w"))))
232 (build-system gnu-build-system)
233 (native-inputs `(("pkg-config" ,pkg-config)))
234 (inputs
235 `(("libx11" ,libx11)
236 ("xcb-util" ,xcb-util)))
237 (home-page "http://www.freedesktop.org/wiki/Software/startup-notification/")
238 (synopsis "Application startup notification and feedback library")
239 (description
240 "Startup-notification contains a reference implementation of the startup
241 notification protocol. The reference implementation is mostly under an X Window
242 System style license, and has no special dependencies.")
243 ;; Most of the code is provided under x11 license.
244 (license license:lgpl2.0+)))
245
246 (define-public wmctrl
247 (package
248 (name "wmctrl")
249 (version "1.07")
250 (source (origin
251 (method url-fetch)
252 (uri (string-append
253 "http://tomas.styblo.name/wmctrl/dist/wmctrl-"
254 version ".tar.gz"))
255 (sha256
256 (base32
257 "1afclc57b9017a73mfs9w7lbdvdipmf9q0xdk116f61gnvyix2np"))
258 (patches (list (search-patch "wmctrl-64-fix.patch")))))
259 (build-system gnu-build-system)
260 (arguments
261 '(#:configure-flags
262 (list (string-append "--mandir="
263 (assoc-ref %outputs "out")
264 "/share/man"))))
265 (native-inputs
266 `(("pkg-config" ,pkg-config)))
267 (inputs
268 `(("libx11" ,libx11)
269 ("libxmu" ,libxmu)
270 ("glib" ,glib)))
271 (home-page "http://tomas.styblo.name/wmctrl/")
272 (synopsis "Command-line tool to control X window managers")
273 (description
274 "Wmctrl allows to interact with an X window manager that is compatible
275 with the EWMH/NetWM specification. It can query the window manager for
276 information, and request for certain window management actions (resize and
277 move windows, switch between desktops, etc.)")
278 (license license:gpl2+)))
279
280 (define-public scrot
281 (package
282 (name "scrot")
283 (version "0.8")
284 (source (origin
285 (method url-fetch)
286 (uri (string-append
287 "http://linuxbrit.co.uk/downloads/scrot-"
288 version ".tar.gz"))
289 (sha256
290 (base32
291 "1wll744rhb49lvr2zs6m93rdmiq59zm344jzqvijrdn24ksiqgb1"))))
292 (build-system gnu-build-system)
293 (arguments
294 ;; By default, man and doc are put in PREFIX/{man,doc} instead of
295 ;; PREFIX/share/{man,doc}.
296 '(#:configure-flags
297 (list (string-append "--mandir="
298 (assoc-ref %outputs "out")
299 "/share/man"))
300 #:phases (alist-replace
301 'install
302 (lambda* (#:key inputs outputs #:allow-other-keys)
303 (let* ((out (assoc-ref outputs "out"))
304 (doc (string-append out "/share/doc/scrot")))
305 (mkdir-p doc)
306 (zero?
307 (system* "make" "install"
308 (string-append "docsdir=" doc)))))
309 %standard-phases)))
310 (inputs
311 `(("libx11" ,libx11)
312 ("giblib" ,giblib)))
313 (home-page "http://linuxbrit.co.uk/software/")
314 (synopsis "Command-line screen capture utility for X Window System")
315 (description
316 "Scrot allows to save a screenshot of a full screen, a window or a part
317 of the screen selected by mouse.")
318 ;; This license removes a clause about X Consortium from the original
319 ;; X11 license.
320 (license (license:x11-style "file://COPYING"
321 "See 'COPYING' in the distribution."))))
322
323 (define-public unclutter
324 (package
325 (name "unclutter")
326 (version "8")
327 (source (origin
328 (method url-fetch)
329 (uri (string-append
330 "http://ftp.x.org/contrib/utilities/unclutter-"
331 version ".tar.Z"))
332 (sha256
333 (base32
334 "0ahrr5z6wxqqfyihm112hnq0859zlxisrb3y5232zav58j6sfmdq"))))
335 (build-system gnu-build-system)
336 (arguments
337 '(#:tests? #f ; no check target
338 #:phases (alist-delete
339 'configure
340 (alist-replace
341 'install
342 (lambda* (#:key inputs outputs #:allow-other-keys)
343 (let* ((out (assoc-ref outputs "out"))
344 (bin (string-append out "/bin"))
345 (man1 (string-append out "/share/man/man1")))
346 (mkdir-p bin)
347 (mkdir-p man1)
348 (zero?
349 (system* "make" "install" "install.man"
350 (string-append "BINDIR=" bin)
351 (string-append "MANDIR=" man1)))))
352 %standard-phases))))
353 (inputs `(("libx11" ,libx11)))
354 (home-page "http://ftp.x.org/contrib/utilities/")
355 (synopsis "Hide idle mouse cursor")
356 (description
357 "Unclutter is a program which runs permanently in the background of an
358 X11 session. It checks on the X11 pointer (cursor) position every few
359 seconds, and when it finds it has not moved (and no buttons are pressed
360 on the mouse, and the cursor is not in the root window) it creates a
361 small sub-window as a child of the window the cursor is in. The new
362 window installs a cursor of size 1x1 but a mask of all 0, i.e. an
363 invisible cursor. This allows you to see all the text in an xterm or
364 xedit, for example. The human factors crowd would agree it should make
365 things less distracting.")
366 (license license:public-domain)))
367
368 (define-public xlockmore
369 (package
370 (name "xlockmore")
371 (version "5.45")
372 (source (origin
373 (method url-fetch)
374 (uri (string-append "http://www.tux.org/~bagleyd/xlock/xlockmore-"
375 version "/xlockmore-" version ".tar.bz2"))
376 (sha256
377 (base32
378 "1xqm61bbfn5q056w57vp16gvai8nqpcw570ysxlm5h46nh6ai0bz"))))
379 (build-system gnu-build-system)
380 (arguments
381 '(#:configure-flags (list (string-append "--enable-appdefaultdir="
382 (assoc-ref %outputs "out")
383 "/lib/X11/app-defaults"))
384 #:tests? #f)) ;no such thing as a test suite
385 (inputs
386 `(("libX11" ,libx11)
387 ("libXext" ,libxext)
388 ("libXt" ,libxt)
389 ("linux-pam" ,linux-pam)))
390 (home-page "http://www.tux.org/~bagleyd/xlockmore.html")
391 (synopsis "Screen locker for the X Window System")
392 (description
393 "XLockMore is a classic screen locker and screen saver for the
394 X Window System.")
395 (license (license:non-copyleft #f "See xlock.c.")
396 ;; + GPLv2 in modes/glx/biof.c.
397 )))
398
399 (define-public xosd
400 (package
401 (name "xosd")
402 (version "2.2.14")
403 (source (origin
404 (method url-fetch)
405 (uri (string-append
406 "mirror://sourceforge/libxosd/xosd-"
407 version ".tar.gz"))
408 (sha256
409 (base32
410 "025m7ha89q29swkc7s38knnbn8ysl24g2h5s7imfxflm91psj7sg"))))
411 (build-system gnu-build-system)
412 (arguments
413 '(#:configure-flags
414 (list (string-append "--mandir=" %output "/share/man"))))
415 (inputs
416 `(("libx11" ,libx11)
417 ("libxt" ,libxt)
418 ("libxext" ,libxext)
419 ("libxinerama" ,libxinerama)))
420 (home-page "http://sourceforge.net/projects/libxosd/")
421 (synopsis "X On Screen Display")
422 (description
423 "XOSD provides a C library and a simple utility (osd_cat) for displaying
424 transparent text on your screen.")
425 (license license:gpl2+)))
426
427 (define-public xbindkeys
428 (package
429 (name "xbindkeys")
430 (version "1.8.6")
431 (source (origin
432 (method url-fetch)
433 ;; Download from the savannah mirror list fails
434 (uri (string-append
435 "http://www.nongnu.org/xbindkeys/xbindkeys-"
436 version
437 ".tar.gz"))
438 (sha256
439 (base32
440 "060df6d8y727jp1inp7blp44cs8a7jig7vcm8ndsn6gw36z1h3bc"))))
441 (build-system gnu-build-system)
442 (inputs
443 `(("libx11" ,libx11)
444 ("guile" ,guile-2.0)))
445 (home-page "http://www.nongnu.org/xbindkeys/")
446 (synopsis "Associate a combination of keys with a shell command")
447 (description
448 "XBindKeys is a program that allows you to launch shell commands with
449 your keyboard or your mouse under the X Window System. It links commands to
450 keys or mouse buttons, using a configuration file. It's independent of the
451 window manager and can capture all keyboard keys (ex: Power, Wake...). It
452 optionally supports a Guile-based configuration file layout, which enables you
453 to access all XBindKeys internals, so you can have key combinations, double
454 clicks or timed double clicks take actions. Also all functions that work in
455 Guile will work for XBindKeys.")
456 (license license:gpl2+)))
457
458 (define-public rxvt-unicode
459 (package
460 (name "rxvt-unicode")
461 (version "9.21")
462 (source
463 (origin
464 (method url-fetch)
465 (uri (string-append
466 "http://dist.schmorp.de/rxvt-unicode/"
467 name "-"
468 version
469 ".tar.bz2"))
470 (sha256
471 (base32
472 "0swmi308v5yxsddrdhvi4cch88k2bbs2nffpl5j5m2f55gbhw9vm"))))
473 (build-system gnu-build-system)
474 (inputs
475 `(("libXft" ,libxft)
476 ("libX11" ,libx11)))
477 (native-inputs
478 `(("perl" ,perl)
479 ("pkg-config" ,pkg-config)))
480 (home-page "http://software.schmorp.de/pkg/rxvt-unicode.html")
481 (synopsis "Rxvt clone with XFT and unicode support")
482 (description "Rxvt-unicode (urxvt) is a colour vt102 terminal emulator
483 intended as an xterm replacement for users who do not require features such as
484 Tektronix 4014 emulation and toolkit-style configurability. It supports
485 unicode, XFT and may be extended with Perl plugins. It also comes with a
486 client/daemon pair that lets you open any number of terminal windows from
487 within a single process.")
488 (license license:gpl3+)))
489
490 (define-public xcape
491 (package
492 (name "xcape")
493 (version "1.1")
494 (source
495 (origin
496 (method url-fetch)
497 (uri (string-append "https://github.com/alols/" name
498 "/archive/v" version ".tar.gz"))
499 (file-name (string-append name "-" version ".tar.gz"))
500 (sha256
501 (base32
502 "0jkdiaxc6sryrbibdgi2y1c48n4l9xyazhxr16l6h4ibddx95bk9"))))
503 (build-system gnu-build-system)
504 (arguments
505 `(#:tests? #f ; no check target
506 #:phases (alist-delete 'configure %standard-phases) ; no configure script
507 #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
508 "MANDIR=/share/man/man1"
509 "CC=gcc")))
510 (inputs
511 `(("libxtst" ,libxtst)
512 ("libx11" ,libx11)))
513 (native-inputs
514 `(("pkg-config" ,pkg-config)))
515 (home-page "http://github.com/alols/xcape")
516 (synopsis "Use a modifier key in X.org as another key")
517 (description
518 "This utility for X.org allows to use modifier key as another key when
519 pressed and released on its own. The default behaviour is to generate the
520 Escape key when Left Control is pressed and released on its own.")
521 (license license:gpl3+)))