gnu: icecat: Apply fixes for CVE-2015-{0817,0818} and other selected bugs.
[jackhill/guix/guix.git] / gnu / packages / pulseaudio.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages pulseaudio)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:prefix l:)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages algebra)
27 #:use-module ((gnu packages autotools) #:select (libltdl))
28 #:use-module (gnu packages avahi)
29 #:use-module (gnu packages check)
30 #:use-module (gnu packages gdbm)
31 #:use-module (gnu packages glib)
32 #:use-module (gnu packages gtk)
33 #:use-module (gnu packages libcanberra)
34 #:use-module (gnu packages web)
35 #:use-module (gnu packages linux)
36 #:use-module (gnu packages m4)
37 #:use-module (gnu packages pkg-config)
38 #:use-module (gnu packages xiph)
39 #:export (libsndfile
40 libsamplerate
41 pulseaudio))
42
43 (define libsndfile
44 (package
45 (name "libsndfile")
46 (version "1.0.25")
47 (source (origin
48 (method url-fetch)
49 (uri (string-append "http://www.mega-nerd.com/libsndfile/files/libsndfile-"
50 version ".tar.gz"))
51 (sha256
52 (base32
53 "10j8mbb65xkyl0kfy0hpzpmrp0jkr12c7mfycqipxgka6ayns0ar"))))
54 (build-system gnu-build-system)
55 (inputs
56 `(("libvorbis" ,libvorbis)
57 ("libogg" ,libogg)
58 ("flac" ,flac)
59 ("pkg-config" ,pkg-config)))
60 (home-page "http://www.mega-nerd.com/libsndfile/")
61 (synopsis "Reading and writing files containing sampled sound")
62 (description
63 "Libsndfile is a C library for reading and writing files containing
64 sampled sound (such as MS Windows WAV and the Apple/SGI AIFF format) through
65 one standard library interface.
66
67 It was designed to handle both little-endian (such as WAV) and
68 big-endian (such as AIFF) data, and to compile and run correctly on
69 little-endian (such as Intel and DEC/Compaq Alpha) processor systems as well
70 as big-endian processor systems such as Motorola 68k, Power PC, MIPS and
71 SPARC. Hopefully the design of the library will also make it easy to extend
72 for reading and writing new sound file formats.")
73 (license l:gpl2+)))
74
75 (define libsamplerate
76 (package
77 (name "libsamplerate") ; aka. Secret Rabbit Code (SRC)
78 (version "0.1.8")
79 (source (origin
80 (method url-fetch)
81 (uri (string-append "http://www.mega-nerd.com/SRC/libsamplerate-"
82 version ".tar.gz"))
83 (sha256
84 (base32
85 "01hw5xjbjavh412y63brcslj5hi9wdgkjd3h9csx5rnm8vglpdck"))))
86 (build-system gnu-build-system)
87 (inputs `(("pkg-config" ,pkg-config)))
88 (propagated-inputs
89 `(("libsndfile" ,libsndfile)
90 ("fftw" ,fftw)))
91 (home-page "http://www.mega-nerd.com/SRC/index.html")
92 (synopsis "Audio sample rate conversion library")
93 (description
94 "Secret Rabbit Code (aka. libsamplerate) is a Sample Rate Converter for
95 audio. One example of where such a thing would be useful is converting audio
96 from the CD sample rate of 44.1kHz to the 48kHz sample rate used by DAT
97 players.
98
99 SRC is capable of arbitrary and time varying conversions; from downsampling by
100 a factor of 256 to upsampling by the same factor. Arbitrary in this case means
101 that the ratio of input and output sample rates can be an irrational
102 number. The conversion ratio can also vary with time for speeding up and
103 slowing down effects.
104
105 SRC provides a small set of converters to allow quality to be traded off
106 against computation cost. The current best converter provides a
107 signal-to-noise ratio of 145dB with -3dB passband extending from DC to 96% of
108 the theoretical best bandwidth for a given pair of input and output sample
109 rates. ")
110 (license l:gpl2+)))
111
112 (define pulseaudio
113 (package
114 (name "pulseaudio")
115 (version "6.0")
116 (source (origin
117 (method url-fetch)
118 (uri (string-append
119 "http://freedesktop.org/software/pulseaudio/releases/pulseaudio-"
120 version ".tar.xz"))
121 (sha256
122 (base32
123 "1xpnfxa0d8pgf6b4qdgnkcvrvdxbbbjd5ync19h0f5hbp3h401mm"))
124 (modules '((guix build utils)))
125 (snippet
126 ;; Disable console-kit support by default since it's deprecated
127 ;; anyway.
128 '(substitute* "src/daemon/default.pa.in"
129 (("load-module module-console-kit" all)
130 (string-append "#" all "\n"))))
131 (patches (list (search-patch "pulseaudio-fix-mult-test.patch")))))
132 (build-system gnu-build-system)
133 (arguments
134 `(#:configure-flags (list "--localstatedir=/var" ;"--sysconfdir=/etc"
135 "--disable-oss-output"
136 (string-append "--with-udev-rules-dir="
137 (assoc-ref %outputs "out")
138 "/lib/udev/rules.d"))
139 #:phases (alist-cons-before
140 'check 'pre-check
141 (lambda _
142 ;; 'tests/lock-autospawn-test.c' wants to create a file
143 ;; under ~/.config/pulse.
144 (setenv "HOME" (getcwd))
145 ;; 'thread-test' needs more time on hydra and on slower
146 ;; machines, so we set the default timeout to 120 seconds.
147 (setenv "CK_DEFAULT_TIMEOUT" "120"))
148 %standard-phases)))
149 (inputs
150 ;; TODO: Add optional inputs (GTK+?).
151 `(;; ("sbc" ,sbc)
152 ("alsa-lib" ,alsa-lib)
153 ("json-c" ,json-c)
154 ("speex" ,speex)
155 ("libsndfile" ,libsndfile)
156 ("libsamplerate" ,libsamplerate)
157 ("dbus" ,dbus)
158 ("glib" ,glib)
159 ("intltool" ,intltool)
160 ("pkg-config" ,pkg-config)
161 ("m4" ,m4)
162 ("libltdl" ,libltdl)
163 ("fftwf" ,fftwf)
164 ("avahi" ,avahi)
165 ("eudev" ,eudev) ;for the detection of hardware audio devices
166 ("check" ,check)))
167 (propagated-inputs
168 ;; 'libpulse*.la' contain `-lgdbm' and `-lcap', so propagate them.
169 `(("libcap" ,libcap)
170 ("gdbm" ,gdbm)))
171 (home-page "http://www.pulseaudio.org/")
172 (synopsis "Sound server")
173 (description
174 "PulseAudio is a sound server. It is basically a proxy for your sound applications.
175 It allows you to do advanced operations on your sound data as it passes
176 between your application and your hardware. Things like transferring the
177 audio to a different machine, changing the sample format or channel count and
178 mixing several sounds into one are easily achieved using a sound server. ")
179
180 ;; PulseAudio is LGPLv2+, but some of the optional dependencies (GNU dbm,
181 ;; FFTW, etc.) are GPL'd, so the result is effectively GPLv2+. See
182 ;; 'LICENSE' for details.
183 (license l:gpl2+)))
184
185 (define-public pavucontrol
186 (package
187 (name "pavucontrol")
188 (version "2.0")
189 (source (origin
190 (method url-fetch)
191 (uri (string-append
192 "http://freedesktop.org/software/pulseaudio/pavucontrol/pavucontrol-"
193 version
194 ".tar.xz"))
195 (sha256
196 (base32
197 "02s775m1531sshwlbvfddk3pz8zjmwkv1sgzggn386ja3gc9vwi2"))
198 (patches (list (search-patch "pavucontrol-sigsegv.patch")))))
199 (build-system gnu-build-system)
200 (inputs
201 `(("libcanberra" ,libcanberra)
202 ("gtkmm" ,gtkmm)
203 ("pulseaudio" ,pulseaudio)))
204 (native-inputs
205 `(("intltool" ,intltool)
206 ("pkg-config" ,pkg-config)))
207 (home-page "http://freedesktop.org/software/pulseaudio/pavucontrol/")
208 (synopsis "PulseAudio volume control")
209 (description
210 "PulseAudio Volume Control (pavucontrol) provides a GTK+
211 graphical user interface to connect to a PulseAudio server and
212 easily control the volume of all clients, sinks, etc.")
213 (license l:gpl2+)))