gnu: icecat: Apply fixes for CVE-2015-{0817,0818} and other selected bugs.
[jackhill/guix/guix.git] / gnu / packages / ccache.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages ccache)
20 #:use-module (guix packages)
21 #:use-module ((guix licenses) #:select (gpl3+))
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages perl)
26 #:use-module (gnu packages compression))
27
28 (define-public ccache
29 (package
30 (name "ccache")
31 (version "3.1.10")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append "https://www.samba.org/ftp/ccache/ccache-"
36 version ".tar.xz"))
37 (sha256
38 (base32
39 "0mr8n1nbykxw4rs55ad8wd6xmfhihn09mxpxb91sn9mlsd1ryhw8"))))
40 (build-system gnu-build-system)
41 (native-inputs `(("perl" ,perl))) ;for test.sh
42 (inputs `(("zlib" ,zlib)))
43 (arguments
44 '(#:phases (alist-cons-before
45 'check 'patch-test-shebangs
46 (lambda _
47 (substitute* '("test/test_hashutil.c" "test.sh")
48 (("#!/bin/sh") (string-append "#!" (which "sh")))))
49 %standard-phases)))
50 (home-page "https://ccache.samba.org/")
51 (synopsis "Compiler cache")
52 (description
53 "Ccache is a compiler cache. It speeds up recompilation by caching
54 previous compilations and detecting when the same compilation is being done
55 again. Supported languages are C, C++, Objective-C and Objective-C++.")
56 (license gpl3+)))