gnu: Replace uses of 'libjpeg' with 'libjpeg-turbo'.
[jackhill/guix/guix.git] / gnu / packages / scribus.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2018 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
5 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
6 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages scribus)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix utils)
27 #:use-module ((guix licenses) #:prefix license:)
28 #:use-module (guix build-system cmake)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages boost)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages cups)
33 #:use-module (gnu packages fontutils)
34 #:use-module (gnu packages ghostscript)
35 #:use-module (gnu packages gtk)
36 #:use-module (gnu packages icu4c)
37 #:use-module (gnu packages image)
38 #:use-module (gnu packages imagemagick)
39 #:use-module (gnu packages libreoffice)
40 #:use-module (gnu packages linux)
41 #:use-module (gnu packages pdf)
42 #:use-module (gnu packages pkg-config)
43 #:use-module (gnu packages python)
44 #:use-module (gnu packages qt)
45 #:use-module (gnu packages tls)
46 #:use-module (gnu packages xml))
47
48 (define-public scribus
49 (package
50 (name "scribus")
51 (version "1.5.5")
52 (source
53 (origin
54 (method url-fetch)
55 (uri (string-append "mirror://sourceforge/scribus/scribus-devel/"
56 version "/scribus-" version ".tar.xz"))
57 (sha256
58 (base32
59 "0w9zzsiaq3f7vpxybk01c9z2b4qqg67mzpyfb2gjchz8dhdb423r"))))
60 (build-system cmake-build-system)
61 (arguments
62 `(#:tests? #f ;no test target
63 #:configure-flags
64 '("-DWANT_GRAPHICSMAGICK=1")
65 #:phases
66 (modify-phases %standard-phases
67 (add-after 'install 'wrap-program
68 (lambda* (#:key inputs outputs #:allow-other-keys)
69 ;; Fix "ImportError: No module named _sysconfigdata_nd"
70 ;; runtime error where Scribus checks PATH and eventually
71 ;; runs system's Python instead of package's.
72 (let* ((out (assoc-ref outputs "out"))
73 (py2 (assoc-ref inputs "python")))
74 (wrap-program (string-append out "/bin/scribus")
75 `("PATH" ":" prefix (,(string-append py2 "/bin")))))
76 #t)))))
77 (inputs
78 `(("boost" ,boost)
79 ("cairo" ,cairo)
80 ("cups" ,cups)
81 ("fontconfig" ,fontconfig)
82 ("freetype" ,freetype)
83 ("graphicsmagick" ,graphicsmagick)
84 ("harfbuzz" ,harfbuzz)
85 ("hunspell" ,hunspell)
86 ("icu4c" ,icu4c)
87 ("lcms" ,lcms)
88 ("libcdr" ,libcdr)
89 ("libfreehand" ,libfreehand)
90 ("libjpeg" ,libjpeg-turbo)
91 ("libmspub" ,libmspub)
92 ("libpagemaker" ,libpagemaker)
93 ("librevenge" ,librevenge)
94 ("libtiff" ,libtiff)
95 ("libvisio" ,libvisio)
96 ("libxml2" ,libxml2)
97 ("libzmf" ,libzmf)
98 ("openssl" ,openssl)
99 ("podofo" ,podofo)
100 ("poppler" ,poppler)
101 ("python" ,python-2) ;need Python library
102 ("qtbase" ,qtbase)
103 ("qtdeclarative" ,qtdeclarative)
104 ("zlib" ,zlib)))
105 (native-inputs
106 `(("pkg-config" ,pkg-config)
107 ("qttools" ,qttools)
108 ("util-linux" ,util-linux)))
109 (home-page "https://www.scribus.net")
110 (synopsis "Desktop publishing and page layout program")
111 (description
112 "Scribus is a @dfn{desktop publishing} (DTP) application and can
113 be used for many tasks; from brochure design to newspapers, magazines,
114 newsletters and posters to technical documentation. Scribus supports
115 professional DTP features, such as CMYK color and a color management
116 system to soft proof images for high quality color printing, flexible
117 PDF creation options, Encapsulated PostScript import/export and
118 creation of four color separations, import of EPS/PS and SVG as native
119 vector graphics, Unicode text including right to left scripts such as
120 Arabic and Hebrew via FreeType.")
121 (license license:gpl2+)))